Image 01
profile-image

Etric

Joerg Ehrichs , Germany

wacom tablet

System Software Oct 28 2015
Score 81%
81 Likes
19 Dislikes

Nepomuk WebMiner

Database May 13 2013
Score 60%
60 Likes
40 Dislikes

Bot Race

Board Jul 26 2012
Score 52%
52 Likes
48 Dislikes
wacom tablet

System Software 267 comments

by Etric
Score 81%
81 Likes
19 Dislikes
Oct 28 2015
Weng Xuetian ported it already to kf5 including a qml plasmoid as replacement for the current one. If you like you can chaeckout the kf5 branch. - Feb 01 2015
small google search assumes this the error comes from an older Qt version.

http://mail.kde.org/pipermail/amarok-devel/2012-November/011218.html

what Qt Version do you use? - Jul 07 2014
What is exactly the problem there?

It "usually" should work out-of-the-box
as long as you have a "recent" wacom driver (+xsetwacom) installed. - Jun 10 2014
Could you tell me what tablet you use?

Usually this happens only when your tablet is not in the list of known devices. Which is especially for "newer" devices always the case at the moment.

I need the tablet id
xsetwacom get "Wacom Bamboo" tabletid

where "Wacom Bamboo" is the name of your tablet - Feb 01 2014
Weird.

What happens if you "calibrate" the tablet. So in the "Tablet" tab open "Map Tablet Area to Screen" make the tablet are fit to the screen area.

Also did you try to create a new profile or just reused the old one? And did you restart the kded after installing this? - Mar 23 2013
Great! Thanks for the hint. I'll ask Alex why he added the condition around it. - Mar 23 2013
Not sure why this happens, but could you try to remove

-DKDE4_BUILD_TESTS=OFF

We check only if the variable is set and this results ina static library instead of a shared one for some parts. This might cause the problem.

without -DKDE4_BUILD_TESTS=OFF the unit tests are not build as well, so there is no need to specify this directly - Mar 21 2013
I have added the [0026] parts to the default list of known device files. This the manufactoring detection should not be a problem anymore.

Regarding the wireless "problem" AFowle mentioned already, that the wirless adapter reports a different id for the connected tablet.

This means, detection the tablet correctly is out of my scope here.

yoY should get different tablet id when you connect your tablet and call
xsetwacom get Wacom Intuos5 touch S Pen pad" TabletID

Sadly the only "workaround" I know is to manually change the waom_device file. Some hopes are still left, there does exit a libWacom that is the future way to unify the tablet detection. Alex and I are going to adapt to this library in the future and thus remove our own tablet detection code. Hopefully this will resolve this issue "one day".
- Mar 09 2013
Hi,
sorry for the late answer.

Can you please
* deinstall the wacom kcm stuff
* start "xev" on the console
* point the mouse over the opened window
* press the button 1 on the tablet
* check which button gets reported in the console
* do the same with all other buttons

Now with the list of buttons

* now install the latest version again
Than you can change the file
/usr/share/kde4/apps/wacomtablet/data/wacom_devicelist

find you tablet in this list and change the lines

hwbutton1=1
hwbutton2=2
hwbutton3=3
hwbutton4=8

according to your observations.

Afterwards reconnect the tablet and everything should work again.
Please send me your changed lines so I can put it into git again - Jan 22 2013
This is unlikely to work with Unity ever.

In order to work properly it needs the kde deamon, so this won't work outside of the KDE enviroment. - Jan 11 2013
Hi,

yes please add this bug to bugs.kde.org. This helps to sort this kind of stuff out for the upcomming 2.0 release.

Both bugs should not happen.
Please also add to the bugreport which version you are running (1.3.6/1.3.7 or the newest 2.0 beta1)

For the "button" stuff.
If you set one of the Expresskeys to emit a "Button 1" signals thats exactly the kind of signals which is send via X11.

For a mouse Button 1 is a left click, button 2 is middle, button 3 is right click. You could this way around also set "Button 1" from teh tablet assign to any other program you wanna use.

Using keystrokes is on the other hand the mor natural choice to do. So we rather try to fix this :) - Nov 25 2012
So with the devicelist change from above you tablet is detected correctly now?

The button/keystroke mapping works in the following way:

The Hardwarebuttons on your tablet can be mapped to "Button 1/ Button 2" etc and when you press them the xserver emits a signal that a "Button 1 click" happend. For a mouse Button 1 is a interpreted as left click, Button 2 is right click and so on. For the Keyboard/tablet the system sends a Button 1 event but no program knows what to do with it usually.

This means you need to tell your program to listen to Button4 if you press the hardware button 4 to make this work.

To make it easier you can also assign keystrokes instead of button events.

If you assign CTRL+C to your HardwareButton 4 and than the copy event is send by the xserver and this will work out of the box in any program, without the need to configure anything else. - Oct 09 2012
I'm a bit confused here.

Your tablet can be conneted in 2 different ways? Via USB cable (0x27) and a wireles dongle (0x84) ?

The conflict with th ewaltop device should on the other hand not happen. There is a manufacturer detection available. But i nevertested it. As it seems there is a bug in there.

Currently the wacom config is rewritten to fix some remaining bugs and add support for libwacom and others to it (done by Alexander Maret-Huskinson)

We'll fix this bug in the new version than.
- Oct 09 2012
I remember someone else already ask this a while ago.

Th question is, what exactly needs to be changed to make it left-handed friendly? - Aug 02 2012
Can't really explain what cause this problem.
I'll skip this until I have time to update to Kubuntu 12.04 myself and let you know then (1-2 Month approximately) - Jun 25 2012
The "the default profile does not exist" is a normal behaviour, but usually the first time you open the config module in the system settings a new profile will be created and you should be able to configure your tablet.

Could you test if you can delete all profiles and create a new one. And if it still fails send me the $HOME/.kde/share/config/tabletprofilesrc

I'am still running Kubuntu 11.10 atm, in the worst case you need to wait a while until I can update my system again so I can fix it (need to fix a few other things as well) - Jun 19 2012
You could try a call like
xsetwacom set "device name sytlus" Button 1 3

I have removed the feature to change the pen tip to anything else than left click a while ago, because it causes only trouble. Not sure this is fixed in the driver yet.

For the touch gestures I'm not sure how this would be done.
As far as I know, the gestures are hard coded.

Should you find a way to solve your problem via xsetwacom please let me know and I'll change this tool accordingly. - Mar 01 2012
*oucht* that sounds serious.

Now the sad thing. I'm a bit lost about this behavior in general.

the #1 error is normal. After installation or whenever you attach a new unknown tablet to the system you do not have a profile (hence the message) and a default one will be created.

What happens at this point in the background:
* a new entry in ~/.kde/share/config/tabletsprofiles is created for your tablet device.
* to get good defaults I'll ask the current tablet what default values it has.

So the question is. can you reproduce this behavior? ( you should definitely backup before you try ;)
* Did you have your tablet in use via the standard approach and some xsetwacom calls?
* What tablet do you have in use? and which version of the wacom driver?

The error a) is frighten me a bit, but I access the harddrive only via KConfig method and this should definitely not produce these errors.

also c) make uninstall will remove the program but you have to delete the ~/.kde/share/config/tabletsprofiles by hand to remove this too (also if you wanna check if this happens every time you start the program the first time you only need to delete config file too). - Jan 31 2012
Hi,

1.3.3 was correct, I simply forgot to update the versions string ;) Fixed this for the new update

The button mapping problem was a bag "bug" introduced by soem kernel changes with kernels >= 2.6.38

I'll upload a new version soon to fix this and some other bugs - Dec 23 2011
Sorry to hear it is not working correctly. At the end it is my fault not "KDE 4.7.3's current state".

Could you do me a little favour and try 1.3.5 again, when you see the error save the
~/.kde/share/config/tabletprofilesrc and send it to me together with your bash script that works correctly. - Dec 04 2011
It is still at the same place, I've simply forgot to tag the repo. 1.3.5 is the current master - Nov 17 2011
In the case you didn't found out yourself already.

The easiest way to start it, is by simply relogging into KDE to start the kded afterwards hotplugging and the systemsettings module are working. - Nov 17 2011
*hmpf* >_<

seems the rotating stuff is not as easy as I have hoped it. I'll see what I can do about it on the next weekend then. Thanks for the report - Nov 05 2011
Hi,

that's odd, I've changed the cw/cw parameters because there was a bug in the xsetwacom where this was mixed as well. But it's been a while I checked that. Thanks for the report I'll change them back and see if I can find a way to support older and new er xsetwacom calls finally.

About the wrong screen dimension. The error lies in my mapTabletToScreen(..) function in wacominterface.cpp and the fact that only 0 and 180 degree are calculated properly when I set the "Coordinate Transformation Matrix".

Sadly my tablets are not at my place currently, that's why it takes a while to correct this error.

But I have this on my big todo list, and will find a solution as soon as I get my tablets back to test it properly - Oct 14 2011
that's a rather short compile error. I have no clue why it fails for you. (I Assume something with the build dependencies is wrong)

Nonetheless you can get a 1.3.3 .deb from
http://packages.debian.org/wheezy/kde-config-tablet - Sep 16 2011
Hi,

can you try to update the wacom driver. This sounds lot like the leftmouse pointing bug some people had with an "older" driver.

same behaviour can than be reproduced if you type in

xsetwacon "yourtabletname" set Button 1 1

right after system start when my program is not installed

This is sadly out of my scope. Only thing you can do if you still want to use my settings program with the current driver is to delete the line:
Button1=1
from the tabletsrc file. This works around this type of bug. - Aug 30 2011
Thanks for the bugreport, I'll keep a note and fix it as soon as I can. - Jun 25 2011
The kRandRTray application does nothing on my screen. I guess this has to do with the prop. Nvidia driver.

This indicates however that the krandrtray does something special and not use the xrandr backend in the same way the xrandr cmd tool use it.

I assume the "bug" is introduced somewhere in this part. - Jun 25 2011
Hi,

I've updated git and nor the rotation should work again as intended with the next release.

Just the resolution bug is a problem.
On my system (wacomtool 0.11.99 with Wacom Bamboo and Wacom Pen and Touch) after the rotation with xrandr -o left or xrandr -o right the screen space is exactly as it should be to the rotated monitor.

In fact all I do in this case is calling the xsetwacom command for the rotation.

*Could it be that that somehow your tablet device was switched to relative mode?
*Did you play around with the MapToScreen and MapToTablet parts?
*What version of the xorg driver do you use? - Jun 25 2011
It is part of this discussion
http://sourceforge.net/mailarchive/message.php?msg_id=27533898

Totally forgot switching to relative mode also solves this problem, but is no solution I can work with - Jun 14 2011
Sadly nesting doesn't work to good here. But I still see all the comments ;)

I will have a look at the crashing issue in the next days. This one might come back with later updates again.

About the left-click pen issue, this is a driver bug which only occurs with the new Pen and Touch Wacom Models. Seems there is something wrong with the way the TCPButton feature is handled.

There is a "workaround" for now. As soon as you finished with all your settings open the file
$HOME/.kde/share/config/tabletprofilesrc

and remove the lines with Button1=1

this prevents the kded to call the line
xsetwacom set ... Button 1 1 and thus the default is used which is still working

You have to do this step everytime you open the system settings module - Jun 14 2011
Thanks for the bugreport!

nicoduv has the same problem and I had no idea how to reproduce this. Still wonder why xorg chrashes but now I can debug this.

Do you remember which version of the odler xorg driver you used beforehand? the default from ubuntu 0.10.11? - Jun 14 2011
*mhh* can't recreate this behaviour on my system :/

I installed the program on a fresh kubuntu natty 64Bit system with the BambooPT 2FG

Did you have the tablet connected when you started the system settings module?

Did a notify window pop up when you connect the tablet after a fresh login or after you restartet the kded4? - Jun 09 2011
you need to execute "make install" with root rigths

simply type

sudo make install

this should run without any problems - Jun 08 2011
I'll have a look at it tomorrow or tuesday.

in the meantime the best thing to do is to checkout 1.3 from the gi repro.

What I "thought" was a quick fix after a long day, turned out to be a horrible crash. Funny though that this works on my computer after all. - May 28 2011
Actually it is not a "normal Systray" icon.
What you can put in the taskbar is a simple plasma applet like the trashbin.

So I don't think this works. But the icon is selected from the overall icon theme you use - Mar 18 2011
this cmake module is somewhere in the kde development files

for kubuntu "kdelibs5-dev" - Mar 18 2011
In theory yes, but you have to install the kded4 deamon tools too and this will install half of the KDE libs I could imagine.

A standalone version is not supported and I don't think it every will be. - Mar 16 2011
Try the new 1.2.6 version I did fix a small problem with the tablet detection in general. Usually it should work now out of the box - Mar 16 2011
found a small bug (wounder why I never had any troubles with it before)

try it again with the new version. Hopefully this fix your problem - Mar 16 2011
It depends on the setting you use (this part of the settings interface is not explained in detail yet)

If you want to use both screen fully as one screen with the full table area, select Twinview = none

If yo want to use the "full" table tare for each screen select Twinview, add the monitor resolution and maybe switch the two monitors if you ran into troubles.

Now if you check the "Multi Monitor" setup, a small portion of the tablet is used to switch the courser between the two tablets (can be mapped to a shortcut as well)

if it is disabled, only 1 screen is used and switching to the 2nd monitor is only possible via the shortcut.

The Map to screen can be set to none (have not found a use to it, but i support it, as xsetwacom does so too ;)

This way it works for my Kubuntu machine 10.04 the 1.2.5 tablet program and the wacom bamboo)

Please send me another message if you still run into troubles - Mar 16 2011
The cmake file is correct (with kde4)
it is just a matter of the build system and the missing cmake macros.

Sadly, can't remember what i did once to fix this. Google might help here if you search for kde4_add_plugin" - Jan 14 2011
This might be solved now. - Jan 14 2011
Haven't set up my Wacom tablet in multiview setup in a while. I'll have to check that

It did work a while ago, but since the change to the new wacom-driver in xorg a few things changed

Will change the second thing
and i ddn't fetch them from it, because I had weired results with my nvidia card and the twinview option regarding the settings there (I have just 1 screen according to it, but the wacom driver still expects 2 screen to be set)

I did want to add this into the normal KDE repo (it is in KDE review since a while)

sadly the new xorg driver has changed and reduced in functionality, but added some bugs ;)

Some gus reported they couldn't use their tablet at all. Thats why it will have to wait a while before this will be available on a large scale - Nov 26 2010
could you install the debug packages for kde as well and tell me the line in which the kded4 crashes (so the proper output from the KCrashHandler)

It is somewhere in findXInputDevice but i can't find where and on my end the kded will not crash no matter what I try. - Oct 09 2010
Nepomuk WebMiner

Database 9 comments

by Etric
Score 60%
60 Likes
40 Dislikes
May 13 2013
usually the problem is the missing Kross-python plugin.

If you open the system settings module Webminer -> plugins you get more detailed hints what is missing.

As soon as I have the time I'll make this more prominent - Jun 18 2013
It will fetch the data automatically in the background (as a Nepomuk::Service) once your computer is in idle state.

If you like to start it manually to have full control over the process, you can either right click on a file in dolphin and select Actions->Desktop-Search->"one of the entries" or you start the ui in the console via "nepomuk-webminer filename" - May 15 2013
Bot Race

Board 7 comments

by Etric
Score 52%
52 Likes
48 Dislikes
Jul 26 2012
Thanks for the hint :)
Most of the packages build again, just the xUbuntu build seem broken on the OBS (build fine on my Ubuntu box though)

Glad at least 1 person likes this game as much as I do :) - Jul 26 2012
Thanks :)
The open build service creates Mandriva packages.
What kind of changes are necessary for mdv/rosa? - Jul 19 2012
Eventlist

Plasma 4 Widgets 298 comments

Score 85%
85 Likes
15 Dislikes
Mar 15 2015
Thanks for this plasmoid.

Works like a charm :) - Sep 07 2011
Eventlist

Plasma 4 Widgets

by Etric
Score 85%
85 Likes
15 Dislikes
Sep 07 2011
NIGHTFeaR 4

Wallpaper Other

by Etric
Score 81%
81 Likes
19 Dislikes
Jun 14 2011
Raise Gimp

Kwin Scripts

by Hmpf
Score 61%
61 Likes
39 Dislikes
Sep 16 2012
Eventlist

Plasma 4 Widgets

Score 85%
85 Likes
15 Dislikes
Sep 07 2011
NIGHTFeaR 4

Wallpaper Other

Score 81%
81 Likes
19 Dislikes
Jun 14 2011
openSuSE

KDM4 Themes

Score 77%
77 Likes
23 Dislikes
Jun 08 2011
lzfy

KDM4 Themes

Score 80%
80 Likes
20 Dislikes
Jun 08 2011
sexy

KDM4 Themes

Score 70%
70 Likes
30 Dislikes
Jun 08 2011
NewEssenceFinal

KDM4 Themes

Score 74%
74 Likes
26 Dislikes
Jun 08 2011