profile-image

dovidhalevi

David Baron Jerusalem, Israel

recollrunner

Utilities Dec 13 2011
Score 67%
67 Likes
33 Dislikes

Jx-Jigsaws

Games Other Dec 07 2005
Score 52%
52 Likes
48 Dislikes
Event Calendar

Plasma 5 Calendars 395 comments

by Zren
Score 88%
88 Likes
12 Dislikes
Sep 13 2018
This is very nice. Finally have QT5.6 so I can use it again.

Bug: Weather shown on forecast sidebar is from wrong location. Weather shown along with agenda is correct.

Clicking on weather opens correct location page. - Jun 25 2016
Very nice. Improvements?
1. Time format: Not from KDE locale settings but enable font size, style, long/short, choices.
2. Weather: Place Icon next to time on panel. More but very brief info?
3. Calendar views: Month (now), week, day?
4. On larger views, mouseover and show events in hint-box. On daily view, show them in place or agenda list. - Mar 24 2016
Yahoo! Weather Widget

Plasma 5 Weather 63 comments

Score 68%
68 Likes
32 Dislikes
Apr 22 2016
Running Debian Sid.
The widget does not connect to Yahoo so does not work. - Apr 08 2016
Error loading QML file: file:///home/david/.local/share/plasma/plasmoids/com.librehat.yahooweather/contents/ui/main.qml:20:34: Type Weather unavailable
file:///home/david/.local/share/plasma/plasmoids/com.librehat.yahooweather/contents/ui/Weather.qml:24:5: Type Yahoo unavailable
file:///home/david/.local/share/plasma/plasmoids/com.librehat.yahooweather/contents/ui/Yahoo.qml:48:5: Type Forecast unavailable
file:///home/david/.local/share/plasma/plasmoids/com.librehat.yahooweather/contents/ui/Forecast.qml:12:1: module "QtQml.Models" is not installed

So installed it.

On plasma restart and crash and restart, plasmoid hung up reading Yahoo. - Apr 07 2016
KRunner Translator

Krunner Plugins 104 comments

Score 76%
76 Likes
24 Dislikes
Jan 20 2018
No action typing stuff like fr-en maison
No notice of this runner on the "search options" dialog.

Running up-to-date Debian Sid. - Feb 29 2016
Color Folder

Dolphin Service Menus 67 comments

Score 76%
76 Likes
24 Dislikes
Aug 06 2018
Install.sh on git looks the same.
Bash version is 4.3.42

Did, indeed, work using bash install.sh. Question is: Why did sh not work. Mine points to dash. Why?

Running Debian Sid. - Feb 02 2016
Line 7, expected (

I tried bypassing and simply running the Plasma 5 leg. Could not create /colorfolder.desktop and /colorfolder.sh. Obviously, a correct path must precede these. Maybe then, need run sudo. - Feb 02 2016
Netspeed Widget

Plasma 5 Monitoring 26 comments

Score 68%
68 Likes
32 Dislikes
Aug 06 2018
Built it from GIT. Got new options.

Font option has no effect on system tray or panels.
System tray placement still in error.
Again, B,K,M,G are sufficient. - Jan 19 2016
After reboot and obviously new log in, there is still no change, no font option. - Jan 19 2016
See no change, no font size option. Are you sure the posted 1.1 file is really the new one? - Jan 18 2016
How do I attach it?

I mean slot is a square area for single-icon. - Jan 18 2016
A couple of notes:
1. Program bar, system bar, objects are too wide, even if I do not show the arrows and units. Would prefer to fit this in a single "slot," and a somewhat smaller font and less space would do it. Do not need units like "Kib" --"K" is enough.
2. System bar object is misplaced, over-painting the one to its right. - Jan 18 2016
Qtractor

Music Production 52 comments

by rncbc
Score 88%
88 Likes
12 Dislikes
Sep 09 2018
This and recent qjackctl are looking for libjack0. This is an older version and not compatible with recent distro upgrades of Debian, etc.

I can compile it. - Jul 26 2015
Not the point.
The distro's repositories have these libs with slightly different names so a package for the distro should site them: For example, Debian has libserd-0-0 instead of libserd-0. - Sep 23 2014
Debs will not install correctly. Dependencies listed are incorrect/obsolete:
qtractor : Depends: libjack0 but it is not going to be installed
Depends: liblilv-0 but it is not installable
Depends: liblo0ldbl but it is not installable
Depends: libserd-0 but it is not installable
Depends: libsord-0 but it is not installable
Depends: libsratom-0 but it is not installable
Depends: libsuil-0 but it is not installable

- Sep 23 2014
Also latest 0.6.1

Trying to compile fails as well. It is including qt5 includes!! - Apr 30 2014
0.5 and 0.6 on Debian 32-bit. Where, oh where, is the program? - Mar 22 2014
Kwave

Music Production 57 comments

Score 83%
83 Likes
17 Dislikes
Feb 21 2016
and ... it missed one :-)

In file included from /home/david/kwave-0.8.99/plugins/codec_flac/FlacCodecPlugin.cpp:25:0:
/home/david/kwave-0.8.99/plugins/codec_flac/FlacEncoder.h:27:28: fatal error: FLAC++/encoder.h: No such file or directory
#include <FLAC++/encoder.h>
- Jan 04 2015
Ok. But, if cmake does not find a specific package, flag that package. Maybe the problem is in cmake. - Jan 04 2015
Those kde-110n packages are all localizations for specific languages. No -dev on Debian, probably part of another kde...-dev.

The cmake was, in fact, checking for the correct package poxml. The error text should have said so. I found the needed rsvg stuff and am compiling right now. If it had only mentioned "convert" (ImageMagik), would not have found the rsvg package so quickly. - Jan 04 2015
Looking for xml2pot
Don't smoke - Jan 04 2015
Plasma Google Now

Plasma 4 Widgets 5 comments

Score 57%
57 Likes
43 Dislikes
Aug 31 2014
if this is not retrieving data from Google Now (my account), then we really cannot give it this name. This would be thrown off Play were it an android app posted there.

Hopefully, big bad-begood, Google will not care what is being posted on this site, but still ... - Aug 31 2014
SMPlayer

Video Apps 494 comments

by rvm
Score 88%
88 Likes
12 Dislikes
Apr 16 2014
src/prefassociations.cpp: In constructor ‘PrefAssociations::PrefAssociations(QWidget*, Qt::WindowFlags)’:
src/prefassociations.cpp:46:6: error: ‘WindowsVersion’ is not a member of ‘QSysInfo’
src/prefassociations.cpp:46:34: error: ‘WV_VISTA’ is not a member of ‘QSysInfo’
src/prefassociations.cpp: In member function ‘void PrefAssociations::refreshList()’:
src/prefassociations.cpp:143:9: error: ‘WindowsVersion’ is not a member of ‘QSysInfo’
src/prefassociations.cpp:143:37: error: ‘WV_VISTA’ is not a member of ‘QSysInfo’
- Mar 25 2013
Need add -I/usr/include/qt4/QtNetwork
- Mar 25 2013
fast user switch

Plasma 4 Widgets 51 comments

Score 81%
81 Likes
19 Dislikes
Sep 28 2011
Actually, had a older version on /usr/local. Removed that and reinstalled. The applet works on MY login but I cannot get to it on other user's.

0.3.2 installed as

/usr/local/lib/kde4/plasma_applet_fastuserswitch.so
/usr/local/share/kde4/services/plasma-applet-fastuserswitch.desktop

What gives? - Feb 03 2013
Happens after every kde upgrade. Need to recompile so after putting 4.9.5-or#, did so. In the past, this was enough--reinsert and it is OK. However, this time, can reinsert the widget but on next loging, it is [X]'ed out once again. - Jan 29 2013
SDDM: Simple QML Based Display Manager

System Software 20 comments

by aavci
Score 74%
74 Likes
26 Dislikes
Mar 24 2013
What do I do with this?

Also, since QML is available on Android and is the UI machine for Ubuntu's Phone, useful as window manager on these? - Feb 02 2013
recollrunner

Utilities 49 comments

Score 67%
67 Likes
33 Dislikes
Dec 13 2011
Thanks.

Folks with account on Kubuntu forums can use your advice, others cannot read it.

It is unfortunate the Kubuntu is no longer supported. There are many who prefer KDE to the latest Ubuntu desktop. - Dec 14 2012
I am eagerly awaiting kde4.8 on Debian.

The bug I know of effects utf-8->local character set translation inside c++ code. It would not surprise me if nothing was changed here.

If kde4.8 prevents the plugin from showing up, this is a problem that would effect more than just this program so something here is suspicious. Unfortunately, until 4.8 gets at least onto Debian experimental, I have no way to check this.

- Apr 04 2012
We have been through this with a French user and this was, hopefully, successfully sorted out.

Recoll does support accented characters and has search rules to deal with them. Results are returned with accents.

So check: That your kde desktop is using the same codepage as the underlying shell (bash). Best that both use Unicode-UTF8 rather than a supplemented Latin page with accents--however, consistency is the key.

BTW: There is/was a problem within kde's code which was called by me so it worked OK. What kde version are you using? I am through 4.7.*. If things have been changed (presumably corrected) in 4.8.*, then I need to fix my call to reflect that, but ne'er the twain do meet. - Apr 03 2012
I do not remember if I had this running on 4.4. Maybe update to 4.5 at least. Otherwise, comment out the two lines in question--I doubt if they really do anything critical.

The tab ordering I will fix easily in the qt designer. - Feb 26 2012
1. Warning about tab-stop not valid widget--First I have seen of this but could be that I renamed widgets after setting the tab-order in the qt-designer. I do not keep names like those. If you use tabbing to step through controls and this work in unexpected manner, easy enough to fix. If not, can safely let it be for now.

2. The error in the end--I do not get this error. This is in krunner's "abstract" base class. What KDE version are you using. I am still OK with 4.7 from Debian Experimental. 4.8 has been released but I have no way of installing packages. If you have 4.8 up, this could be the problem. - Feb 23 2012
KNemo

Network 804 comments

Score 87%
87 Likes
13 Dislikes
Aug 20 2015
Dependencies are there.
Removed and recreated clean build folder.
Problem persists! - Nov 12 2012
On Debian, there are currently two libnl's, libnl1 and libnl3. I had both the lib and dev files for libnl1 (as well as the lib for libnl3) but the cmake kicked. So I updated the dev file to version 3. Still kicked. So cannot build.

Probably should be using the newer one but the package search did not like either. Only thing I can think of is that the new libnl works with multiarch.

How to get this latest and greatest to build?
- Nov 11 2012
WorkFlow Plasmoid

Plasma 4 Widgets 73 comments

Score 76%
76 Likes
24 Dislikes
Mar 24 2013
This actually DOES WORK. Not evident graphically because of the dark oxygen style.

The name given the new desktop should either follow the pager's default or simply be "new desktop" with immediate UI for editing it.

When clicking [x] removes or hides or maybe two different [x] [-] or such This is the UI question suggested in my post. - Sep 04 2012
Since the widget can close desktops and add desktops, needs interface to pager. For example, I have four desktops and add one in the widget!

Now, it gives it the same name as the first one and that is what is represents. Should adding a desktop add one to the pager as well?

Closing, hiding desktops. When is this temporary for convenience and when is this persistent and should also update the pager? Need to decide, design UI. - Sep 04 2012
[[The other activity scrolling widget allows me to change the activity name. Yours does not.]
It does, unlock the activities, double click the activity name.]
OK, works fine. Did not know activities were locked (so emphatic symbol--padlock icon with two obvious states). BTW The third icon on top inactive.

[[Problem displaying longer, line-broken names on top.]
Line broken names I dont know if exist actually in KDE.]
They don't. Just get shown that way. Usually works OK. First time was cut off (program took heights on showing view).


[[Additions might be what is up on current windows or just icons or just programs--depends on functionality built into these thumbnails and their subareas!]
what do you mean by icons or programs? (what is the difference for you ? it would be better to describe anything you want by using the term Windows. what are the subareas?)]
Right now, you can do all the same functionality with a text tree view. If showing all the wallpapers, the graphic areas could show more of what is on the work areas be used for future functionality. Example: Show its icons->hover show properties. Click? Right-click? Lots of possibilities.

[[I assume other functions (such as the window properties described) will be added]
I dont know what you mean actually...]
Found this as well, working fine.

[[Lacking right now anywhere is how to propagate icons over multiple activities]
you mean using a window in multiple activities and not everywhere?]
I mean when making a new activity or several, getting icons to the desktops with minimum fuss.

This widget shows very much promise. Once Aaron S and friends decide just what activities are supposed to do, this widget is in best start to implement it. I suggest getting it on the "playground" for future inclusion in KDE! - Sep 04 2012
BUG: Dragging the textual window info can make that change to an icon (probably non-implemented feature) and the widget is paralyzed. Can no longer re-activate it. Must restart plasma-desktop. - Sep 03 2012
OK! Built it the old-fashioned way.
cmake .. could not find kactivities cmake configs so I installed libkactivities-dev. End of story. Lesson: convenient build scripts should stop on fatal errors.

Did everything else manually. Got it working.

Comments:

Uses same icon as two other activity widgets.

The other activity scrolling widget allows me to change the activity name. Yours does not.

Problem displaying longer, line-broken names on top.

Thumbnails do not show much information. Additions might be what is up on current windows or just icons or just programs--depends on functionality built into these thumbnails and their subareas!

This is in its infancy so I assume other functions (such as the window properties described) will be added. Lacking right now anywhere is how to propagate icons over multiple activities. Must laboriously add them manually one by one.

There used to be a run-program option which has been removed from kde. The only activity option in kde right now is the name. - Sep 03 2012
It was build using your install script (sudo), looked OK.

Running KDE 4.8.4, Debian Sid - Sep 03 2012
The widget does not show up in the widgets to add it to my panel. No workflow anything. - Sep 02 2012
KVG

Plasma 4 Widgets 20 comments

Score 51%
51 Likes
49 Dislikes
May 25 2012
For those of us who prefer not to have this stuff, even in miniature, staring us in the face while we look for useful plasmoids and such, maybe there should be a special kde porn site.

I believe in the 1st amendment, internet freedom, free choice, all that, but please spare the rest of us who are interested in kde software (maybe software skins, not the other kind :-) ). - May 25 2012
Akonadi contacts plasmoid

Plasma 4 Widgets 18 comments

Score 55%
55 Likes
45 Dislikes
Apr 27 2012
I'll try the new version.

The resource was added and set up. In the address book, I do see a few items but not all the contacts from my phone. - Feb 28 2012
My contacts from my Android should be there, should they not? So far, no results.

I actually want to see them in my phone applet where they might be useful. If they show in contacts applet or in the plasmaengine viewer, they should show in my applet, at most a one line code addition.

BTW, try inserting this applet onto the panel and see what happens! Best give it an icon view, huh :-) - Feb 27 2012
FrustML

Plasma 4 Widgets 2 comments

by justi
Score 52%
52 Likes
48 Dislikes
Feb 24 2012
Since I am considering fiddling with this as well, I installed the android, played.

1. Game is frustratingly unresponsive on my LG optimus (not cutting edge). There is no help or rule sheet for those who have not touched this in forty years (or more!). This is a nice first implementation.

2. As described in the development kit, first run of anything made therewith installs the needed qt libraries. 17 meg of them! And this does not go to the SD card. Many devices will be short of "local" storage space and 17 meg could be a killer.

(To me, this local/SD dichotomy is a fundamental android weakness. I might have tried using unionfs which is around in android with some similar name!--I have not succeeded in rooting the thing. If somehow it be possible to get the libraries on the SD storage, this must be done in order to enjoy QT apps on it.)

3. For the desktop, this might better be a normal app rather than a widget. - Feb 26 2012
Mini Player

Plasma 4 Widgets 142 comments

by Emdek
Score 83%
83 Likes
17 Dislikes
Jul 01 2012
Author unknown on mp3s since I did not tag any of them.
No author on wavs
No track length on either.

The gstreamer/phonon is from Debian, possibly experimental since from there is kde4.7 - Jan 02 2012
Running Debian Sid (unstable), KDE4.7 (from experimental), Gstreamer 4.51 - Jan 01 2012
Gstreamer it is. Xine is also available but I have never done well with it.
- Jan 01 2012
1. Dragon also does not play mp3. BTW, unless one wants to front for mplayer, vlc is still the most reliable, will usually work without much fuss.
2. Volume control did not do anythings, did not bring up a slider, nada.
3. The position slider moves, that is, until I moved it too far :-)
- Jan 01 2012
1. Would not play mp3. Wav plays fine.
2. Stop button did not work.
3. Volume control did not work.
4. Dragging positions too far right froze plasma. Check threading. - Jan 01 2012