profile-image

anli

Andrew Gaydenko

QLoud

Audio Jun 30 2016
Score 73%
73 Likes
27 Dislikes
QLoud Audio
12 comments
Score 73%
73 Likes
27 Dislikes
Jun 30 2016
It seems you use qwt 5.x, while last qloud is for qwt 6.x. Try recent qwt or previous qloud. Sep 01 2011
Probably you need to modify this string in src/src.pro in accordance with your Qwt installation:

INCLUDEPATH += /usr/include/qwt5 Jul 20 2007
Score 78%
78 Likes
22 Dislikes
Jan 16 2013
Aha, have catched it, thanks! Oct 10 2009
For me the problem still exists (arrows, tree decoration - icons to open/close tree nodes - are absent) even with -DQTC_USE_CAIRO_FOR_ARROWS=true

Where to dig in? The problem is, I don't see competitors for QtCurve (thanks!) Oct 10 2009
Am I alone with QtCurve + Firefox = font_problem? Jan 29 2007
Starting from 2-3 versions ago firefox doesn't see font defined in .gtkrc-2.0 the way shown below. With "old" QtQurve and other themes all works fine.

With current QtCurve other (say, gnumeric) apps work fine too.

_________
include "/usr/share/themes/QtCurve/gtk-2.0/gtkrc"

style "user-font"
{
font_name="Lsc 9"
}
widget_class "*" style "user-font"

gtk-theme-name="QtCurve"
gtk-font-name="Lsc 9"
Jan 19 2007
QStarDict 1.0 Utilities
48 comments
Score 78%
78 Likes
22 Dislikes
May 18 2013
With 0.02 the error is shown below. I'm ready to continue build-fixing-testing dialog via direct emailing (my email is a@gaydenko.com - add QStarDict to subject, please).

----------------
src/lib/lib.cpp: In member function ‘const gchar* offset_index::read_first_on_page_key(glong)’:
src/lib/lib.cpp:572: error: no matching function for call to ‘min(long unsigned int, guint&)’ Jul 05 2007
aha... probably the issue is platform-related (I mean x86_64) rather glib-related. Jul 04 2007
which glib version must be used? With v.2.12.12 have got the error on x86_64 pc:

g++ -c -pipe -O2 -march=nocona -pipe -Wall -W -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -D_REENTRANT -DHAVE_MMAP -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtGui -I/usr/include/qt4 -Ibuild -Ibuild -o build/lib.o src/lib/lib.cpp
src/lib/lib.cpp: In member function ‘const gchar* offset_index::read_first_on_page_key(glong)’:
src/lib/lib.cpp:516: error: no matching function for call to ‘min(long unsigned int, guint32&)’
make: *** [build/lib.o] Error 1
anli qstardict # ls /usr/lib64/g Jul 04 2007
PDFedit 0.3.1s Text Editors
60 comments
Score 85%
85 Likes
15 Dislikes
May 02 2007
... this way:

PATH=/usr/qt/3/bin:$PATH; QTDIR=/usr/qt/3/; QMAKESPEC="/usr/qt/3/mkspecs/linux-g++"; ./configure --prefix=/usr/local Jan 28 2007
Have tried 0.2.4 with these env

QTDIR=/usr/qt/3/ QMAKESPEC="/usr/qt/3/mkspecs/linux-g++"

and have got the same error - 'src/kpdf-kde-3.3.2' dir still doesn't see qt3 :-( Jan 28 2007
It doesn't help. With command shown below I still have qt4 include dirs inside src/kpdf-kde-3.3.2:

QTDIR=/usr/qt/3 QMAKESPEC='/usr/qt/3/mkspecs/linux-g++' ./configure --prefix=/usr/local --with-qt-dir=/usr/qt/3 --with-qt-include=/usr/qt/3/include Jan 19 2007
Have tried with the same result:

./configure --prefix=/usr/local --with-qt-dir=/usr/qt/3 --with-qt-include=/usr/qt/3/include Jan 19 2007
The same. Probably used auto-tools scripts are not suitable for simultaneously QT3 and QT4 installed. Jan 19 2007