profile-image

trisz

Zoltan Mastala Budapest, Hungary

Kuickplay Qt4

Audio Jan 24 2010
Score 54%
54 Likes
46 Dislikes

Valentine SVG

Wallpaper Other Feb 13 2009
Score 61%
61 Likes
39 Dislikes

K-EncFS

Security Dec 17 2007
Score 80%
80 Likes
20 Dislikes

Kuickplay

Audio Dec 06 2007
Score 64%
64 Likes
36 Dislikes

K-Blueproximity

Security Oct 24 2007
Score 64%
64 Likes
36 Dislikes

KenZip

System Software Feb 12 2007
Score 71%
71 Likes
29 Dislikes

Dizzy

Wallpaper Other Jan 08 2007
Score 50%
50 Likes
50 Dislikes

Package Wizard

Development Oct 18 2006
Score 69%
69 Likes
31 Dislikes

OpenSUSE 10 svg

Wallpaper Other Mar 14 2006
Score 60%
60 Likes
40 Dislikes

Kpetals SVG

Wallpaper Other Dec 05 2005
Score 57%
57 Likes
43 Dislikes
q4wine

System Software 52 comments

Score 86%
86 Likes
14 Dislikes
Feb 27 2016
What kind of package intended for debian Lenny. I can found the same links to the confusing launchpad.net sites without any valid information about the packages. Lucid karmic jaunty and intrepid packages are listed, but you state:

"They are suitable for Debian GNU/Linux version >= 5.0 (Lenny) and for Ubuntu version >= 8.10 (Intrepid Ibex). Sources are also available ibid."

What about Lenny and >?

- Jun 23 2010
Kuickplay Qt4

Audio 6 comments

by trisz
Score 54%
54 Likes
46 Dislikes
Jan 24 2010
Extract the debian package with ark.
The data archive contains the files,
extract and move them to the same but absolute path.
- Jan 25 2010
The python code is always source.
Unpack the debian package and copy the contents to the right place!
What is your distribution?
Where are the service menu files for KDE4?
I will pack rpm/tgz as soon as you provide this information.
- Jan 25 2010
ScreenGrab

Graphics 26 comments

Score 74%
74 Likes
26 Dislikes
Aug 18 2011
My problems were as follows:
1. The license is not LGPL for this application, only GPL. (See the Information window of the application!)
The LGPL license is not included in the package.

2. The programme code structure is not according to the LGPL session "4. Combined Works. d) Do one of the following:".
It does not use shared library.
OR
Because of lack of the source code,
"recombine or relink the Application with a modified version" is not possible.

So, the source code must be included, or the license must be changed to LGPL and use any shared (common with other programmes) Qt4 library.


- Oct 30 2009
In the case of LGPL you cannot use any static Qt library files like QtCore4.dll without publishing the source code.
- Oct 29 2009
If the license is GPL, you have to upload the source. If it is not, you have to have a non-GPL (commercial) license for Qt.
- Sep 09 2009
K-EncFS

Security 41 comments

by trisz
Score 80%
80 Likes
20 Dislikes
Dec 17 2007
My main problem is the mess (.directory) appears during working with koquerror an dolphin. This prevents mounting the file system.
I hate the thumbs files on my cd-s, and i hate...
(KDE4 is not intended for the daily usage but it is only for the design.)

I must find a stupid solution for this problem.
- Jun 26 2009
python-qt3,
python-kde,
...
see the dependencies!
- Jun 26 2009
Python-KDE4 is in experimental state.
Every distro have a surprise in store for you. There is a serious risk concerning your data if you use it.
- Dec 04 2008
Unfortunately the author of encfs refused to cooperate with me. I think, he assumes that you use only command line. How can you remember the command line parameters for hundred of applications?
I forget it after I have finished my work with the frontend.

Much more serious problem is the backward compatibility...

I have to check the application regularly, and to correct it. I created this application for you, but this does not apply for encfs.

- Oct 01 2008
Is the link
/usr/bin/kencfslink
really missing after the installation?

(It was copied by the install script.
Please copy it manually from the tgz to the target directory!)

- Jul 07 2008
EncFS is not a drive encryption tool.
It is for folders.

In this state of my app you cannot modify the encrypted folder. It could be a future feature.
- May 07 2008
You can mount the encrypted folder from command line:

encfs (your home directory)/.kencfs2/.encrypted (your home directory)/.kencfs2/encrypted -S

Similar problem were reported on 1 of Nov 2007. I uploaded the new version 2.1 on 17 of Dec 2007.
Which version do you use?
- Apr 17 2008
It was tested on SuSE 10.3,
the previous release on 10.2.

The kdecore is the most important part of python-kde. It is not installed, or the wrong version installed (not for SuSE 10.2), the postinstallation script failed...
Try to reinstall it.
- Jan 14 2008
The referenced line is a 'fi' tag, I do not understand the problem.

Try from the konsole:
python /usr/local/lib/kencfs2/kencfs.py

What kind of error message appears? - Nov 08 2007
QLandkarte GT

Science 19 comments

Score 87%
87 Likes
13 Dislikes
Jul 11 2011
I have not any problem with FWTools.
I have not an internet connection on that computer, so qt4 also cannot be downloaded.

"It will copy it's own version of QT into it's application path"

How can I create it manually?
(What is the directory/file structure?)

I cannot find instructions for compilation on linux on http://www.qlandkarte.org. - Nov 26 2008
It can be installed only in special cases on Windows, only on computers with internet connection and without installed Qt4. I have an installed Qt4, and your application cannot find it, but it is in the path. I really do not want to reinstall my Qt4, because I use it in that format. I copied the executable into the Qt4 binary directory, but an error message appeared: the entering point of the process cannot be found...

On linux, much more information need for the compilation: gcc, qt4 version, dependencies...

- Nov 25 2008
Wally

Utilities 57 comments

Score 72%
72 Likes
28 Dislikes
Jul 01 2014
I think, they will not answer...

Webshot files can be downloaded manually, and stored in a local folder.
If it is possible, you can use them as wallpappers also on linux. They offer it.
With a little copyright risk, wbc files also can be imported from a win partition.
What about the local folder solution?
- Sep 17 2008
What about the Webshot format?

See:
http://www.opendesktop.org/content/show.php/webshots?content=17713

Could you integrate this code? - Sep 16 2008
GrEEn

Graphics 16 comments

Score 55%
55 Likes
45 Dislikes
Jul 15 2008
Multiplatform development systems always have own infrastructure for this task.

See:
http://doc.trolltech.com/4.0/qdir.html#home

QDir QDir::home () [static]

It is platform independent.

You need not alien libraries.
- Jul 18 2008
Be patient with the compilation on ms visualStudio! Do not use the GPL/LGPL for sources rely on non GPL/LGPL codes!

What is the origin of the headers windows.h and shlobj.h in CWinDirModel.cpp?


- Jul 17 2008
See the solution:

http://doc.trolltech.com/4.4/qlibrary.html
- Jul 16 2008
See the file ComponentsCommon.hpp!

#define COMPONENTS_EXPORT __declspec (dllexport)

It is not unix compatible.
You need not __declspec(dllexport) on Linux, because every function is exported as default...
- Jul 16 2008
I tried to compile on linux, debian etch -> lenny.
The source is not unix compatible.
Unix is case sensitive,
e.g. qplugin.h and not QPlugin.h,
GrEEn and Green are two different directories.

Other typical error:
CEffectsWidget.hpp:39: error: expected initializer before ‘CEffectsWidget’
CAdvEffectsWidget.hpp:36: error: expected initializer before ‘CAdvEffectsWidget’
CZoomWidget.hpp:21: error: expected initializer before ‘CZoomWidget’
CAdvEffectsWidget.cpp:45: warning: ISO C++ forbids declaration of ‘CZoomWidget’ with no type
CAdvEffectsWidget.cpp:45: error: expected ‘;’ before ‘*’ token
CAdvEffectsWidget.cpp: In constructor ‘CAdvEffectsWidgetPrivate::CAdvEffectsWidgetPrivate()’:
CAdvEffectsWidget.cpp:33: error: ‘theVisualWidget’ was not declared in this scope
CAdvEffectsWidget.cpp:33: error: expected type-specifier before ‘CZoomWidget’
CAdvEffectsWidget.cpp:33: error: expected `;' before ‘CZoomWidget’

The main feature of the gpl licensed Qt4 is the interoperability. Qt is not only a development tool, but it is for creating platform independent applications.
It is not a hard thing, but you must pay any attention concerning os specific issues.
It is important, because (I think) this website is visited mainly by linux users.
- Jul 16 2008
I tried to compile on linux, debian etch -> lenny.
The source is not unix compatible.
Unix is case sensitive,
e.g. qplugin.h and not QPlugin.h,
GrEEn and Green are two different directories.

Other typical error:
CEffectsWidget.hpp:39: error: expected initializer before ‘CEffectsWidget’
CAdvEffectsWidget.hpp:36: error: expected initializer before ‘CAdvEffectsWidget’
CZoomWidget.hpp:21: error: expected initializer before ‘CZoomWidget’
CAdvEffectsWidget.cpp:45: warning: ISO C++ forbids declaration of ‘CZoomWidget’ with no type
CAdvEffectsWidget.cpp:45: error: expected ‘;’ before ‘*’ token
CAdvEffectsWidget.cpp: In constructor ‘CAdvEffectsWidgetPrivate::CAdvEffectsWidgetPrivate()’:
CAdvEffectsWidget.cpp:33: error: ‘theVisualWidget’ was not declared in this scope
CAdvEffectsWidget.cpp:33: error: expected type-specifier before ‘CZoomWidget’
CAdvEffectsWidget.cpp:33: error: expected `;' before ‘CZoomWidget’

The main feature of the gpl licensed Qt4 is the interoperability. Qt is not only a development tool, but it is for creating platform independent applications.
It is not a hard thing, but you must pay any attention concerning os specific issues.
It is important, because (I think) this website is visited mainly by linux users.
- Jul 16 2008
I tried to compile on linux, debian etch -> lenny.
The source is not unix compatible.
Unix is case sensitive,
e.g. qplugin.h and not QPlugin.h,
GrEEn and Green are two different directories.

Other typical error:
CEffectsWidget.hpp:39: error: expected initializer before ‘CEffectsWidget’
CAdvEffectsWidget.hpp:36: error: expected initializer before ‘CAdvEffectsWidget’
CZoomWidget.hpp:21: error: expected initializer before ‘CZoomWidget’
CAdvEffectsWidget.cpp:45: warning: ISO C++ forbids declaration of ‘CZoomWidget’ with no type
CAdvEffectsWidget.cpp:45: error: expected ‘;’ before ‘*’ token
CAdvEffectsWidget.cpp: In constructor ‘CAdvEffectsWidgetPrivate::CAdvEffectsWidgetPrivate()’:
CAdvEffectsWidget.cpp:33: error: ‘theVisualWidget’ was not declared in this scope
CAdvEffectsWidget.cpp:33: error: expected type-specifier before ‘CZoomWidget’
CAdvEffectsWidget.cpp:33: error: expected `;' before ‘CZoomWidget’

The main feature of the gpl licensed Qt4 is the interoperability. Qt is not only a development tool, but it is for creating platform independent applications.
It is not a hard thing, but you must pay any attention concerning os specific issues.
It is important, because (I think) this website is visited mainly by linux users.
- Jul 16 2008
I tried to compile on linux, debian etch -> lenny.
The source is not unix compatible.
Unix is case sensitive,
e.g. qplugin.h and not QPlugin.h,
GrEEn and Green are two different directories.

Other typical error:
CEffectsWidget.hpp:39: error: expected initializer before ‘CEffectsWidget’
CAdvEffectsWidget.hpp:36: error: expected initializer before ‘CAdvEffectsWidget’
CZoomWidget.hpp:21: error: expected initializer before ‘CZoomWidget’
CAdvEffectsWidget.cpp:45: warning: ISO C++ forbids declaration of ‘CZoomWidget’ with no type
CAdvEffectsWidget.cpp:45: error: expected ‘;’ before ‘*’ token
CAdvEffectsWidget.cpp: In constructor ‘CAdvEffectsWidgetPrivate::CAdvEffectsWidgetPrivate()’:
CAdvEffectsWidget.cpp:33: error: ‘theVisualWidget’ was not declared in this scope
CAdvEffectsWidget.cpp:33: error: expected type-specifier before ‘CZoomWidget’
CAdvEffectsWidget.cpp:33: error: expected `;' before ‘CZoomWidget’

The main feature of the gpl licensed Qt4 is the interoperability. Qt is not only a development tool, but it is for creating platform independent applications.
It is not a hard thing, but you must pay any attention concerning os specific issues.
It is important, because (I think) this website is visited mainly by linux users.
- Jul 16 2008
I think, it is a windows application.
You have to make any effort for the easy compilation on linux. There are not any useful instructions in the source. Only for MinGW...

Do you have a successful compilation on any linux system?

Qt is platform independent, but the application may not automatically.
- Jul 08 2008
V-like

Various KDE 1.-4. Styles 16 comments

Score 60%
60 Likes
40 Dislikes
May 30 2008
I like your answer, but Steve Ballmer has never heard about any OS different from windows, and he has found these icons on microsoft.com.
Unfortunately, some governments also do not want to know about other os, and most of the users do not want to recognize blue folder icons. It is easier to remain stupid than to see with their own eyes.

I think, this theme/iconset is a honey pot with vista like icons.

- May 21 2008
You are brave concerning the TM of MS and the icons.

But this man was really brave:

http://index.hu/tech/uzlet/ballmer08051/

(See the videos! Steve Ballmer is under the table like a cat...)

Steve Ballmer continues his tour forward your country...

I think, linux has its own value without Vista.
- May 20 2008
K-Blueproximity

Security 27 comments

by trisz
Score 64%
64 Likes
36 Dislikes
Oct 24 2007
The proximity_api is present in the package

blueproximity_1.2.2_all.deb

If you use a debian based system, you have installed it with a forced option or the dpkg is broken as it is on Etch.

If you use kde, install the package blueproximity-kde_1.2.2_all.deb.
If you prefer the gtk version install the
blueproximity-gtk_1.2.2_all.deb,
but it must be the last chance...
- Apr 07 2008
You can delete the line 152
Kproximity_Ui.__dict__["_Kproximity_Ui__tr"]=trans
in the file
/usr/share/blueproximity/kproximity.py.
(Translation will be disabled for the GUI.)
- Oct 31 2007
Unfortunately, for SuSE 10.2 there is not up-to-date pybluez. I think, you compiled from the enclosed src.rpm. You may try to compile from the src.rpm of SuSE 10.3.

The following error is a bug on SuSE:
"TypeError: 'dictproxy' object does not support item assignment"
Item assignment is a basic feature of python dictionaries. SuSE may use tuple, but it is a bug. The __dict__ is a dictionary not a tuple.
I try to find out another solution. The problem is only the translation stuff...
You need not it as:
langs: ['en_US', 'en'].


- Oct 30 2007
Kommander

Development 57 comments

Score 83%
83 Likes
17 Dislikes
Nov 02 2009
Just only because your issue was not answered.

The following error messages are not so serious:

kommanderfactory.cpp:32:23: error: database2.h: No such file or directory
.
.
.

They can be fixed easily, but you cannot compile it after, because much more serious problems are present in the source. I think, it works only on the developer's system.

It cannot be compiled on debian and on suse.

You had better wait to the patched distribution release or a new version of Kommander.
- Mar 27 2008
I need e.g. 3 days for a small python-qt application, but I need a whole week if I use Kommander. I am not a beginner, and the upside-down logic of Kommander is strange for me, and remains strange forever. It is a sufferig for a practiced user to work with Kommander (It is a fact not a troll.)
I know, it is simplier to create a qt/kde binding for an object-oriented language like python. One need not to fill up the gap between the C++ library and the script. (It does not apply to the scripting format of python.) Your task is not easy.
Kommander is useful for a beginner, but bash and sh deserve more attention. I think, it must be a work of a team. (It is only an opinion not a troll.)

I will not use Kommander for python. How can I set the widget flags, for example?

- Feb 26 2008
I had essential problems with Commander.

I spent about the same time to learn Commander as to learn python-qt.
The result was disappointing for Commander. It is slow, some basic problem cannot be solved, and demands extra force to solve small problems.
Basic functions are missing from the editor, such as syntax highlighting.
The Help file is also missing. It is told, that the usage is trivial, but it is not. It is trivial to use python-qt, but not to use Commander.
I think, the whole application must be rewritten.

I recommand to everybody to use python-qt instead.
- Feb 25 2008
Valentine SVG

Wallpaper Other 8 comments

by trisz
Score 61%
61 Likes
39 Dislikes
Feb 13 2009
I like your modified versions.
I will include them in the package next year.
- Feb 14 2008
MuseScore

Music Production 34 comments

Score 83%
83 Likes
17 Dislikes
Jul 29 2015
Your score editor really differs from the others. More advanced... I can use also my left hand playing piano. I need not bother with the midi server.
The only problem is changing the instrument. If I select another sf2 file (with several instruments inside), I can hear the same piano1. Can I use another instrument?

- Jan 25 2008
My main problem concerning the different "score editors" (nted, noteedit, kguitar) is the file format incompatibility. If noteedit has an extra feature over another application, I cannot use it if it was not created with noteedit. All of the score editors are almost identical, but if any extra think appears in one of them, it cannot be used because of the missing export/import feature.
- Jan 24 2008
Traverso

Audio 21 comments

Score 84%
84 Likes
16 Dislikes
Mar 29 2009
The version 0.40 works well,
the version 0.41 compiles, but does not work, the application closes itself,
the version 0.42 does not compiles:

WPAudioReader.cpp:(.text+0x35): undefined reference to `WavpackUnpackSamples(WavpackContext*, int*, unsigned int)'
../../lib/libtraversoaudiofileio.a(WPAudioReader.o): In function `WPAudioReader::seek_private(unsigned int)':
WPAudioReader.cpp:(.text+0x2fa): undefined reference to `WavpackSeekSample(WavpackContext*, unsigned int)'
../../lib/libtraversoaudiofileio.a(WPAudioReader.o): In function `WPAudioReader::~WPAudioReader()':
WPAudioReader.cpp:(.text+0x343): undefined reference to `WavpackCloseFile(WavpackContext*)'
../../lib/libtraversoaudiofileio.a(WPAudioReader.o): In function `WPAudioReader::~WPAudioReader()':
.
.
.
WPAudioWriter.cpp:(.text+0x779): undefined reference to `WavpackCloseFile(WavpackContext*)'
collect2: ld returned 1 exit status
- Dec 29 2007
Kuickplay

Audio 14 comments

by trisz
Score 64%
64 Likes
36 Dislikes
Dec 06 2007
There is an option for looping only one music file.
About 90 % of my work is about the playlist...
If you would like to erase this feature, several function of the skin also will not work.
(See the python file, edit it if you are against the playlist.) - Dec 23 2007
I am against wma and other, $ related things.
You can insert if you like it, but do not try any video file, it is not safe for X.
I am not planning to make skins configurable. It would be a Slowplayer not a Kuickplayer.
You can edit the svg file with Inkscape.
If you move/resize the buttons, you have to modify the button areas in the code (QRect definitions).
- Dec 13 2007
There is not any daemon in the case of this application.
Scripting is not the same as daemon.
But in the case of other apps you use as a part of any distribution use deamons. Python works with the speed of C because of the bindings. Future developments tends to python.
Moreover, this applications is not in the scripting format of python, it is object oriented.
I can not see any entry of you on kde-apps.org. I think you have not any practice concerning kde programming. So you can only try a certain application. If it works, it is good. Other ideas of you are preconceived ideas.
- Nov 22 2007
A missing note: Kuickplay controls the PCM, not the main volume control. - Nov 21 2007
It must remain a slim application, otherwise it will not startup quickly.

You can find the application in the folder /usr/share/kuickplay.
You can modify the .svg and .ui file (buttons), if you do not like the colors. The svg can be converted to png, and the kuickplay_ui.ui to to py by the command:
pyuic -x kuickplay_ui.ui > kuickplay_ui.py.

I will develop another version with different skin.
- Nov 21 2007
KNetDockApp

Network 109 comments

by yodor
Score 80%
80 Likes
20 Dislikes
Jul 11 2008
Stay on the system tray minimized. The window associated with the trayicon always appears after KDE startup. - Dec 17 2007
Only a "Registration has been disabled." page appears.

You could include the deb package in the tarball uploaded to kde-apps.org.





- Dec 11 2007
Tasty Menu

Various KDE 1.-4. Improvements 499 comments

by mart
Score 81%
81 Likes
19 Dislikes
Dec 13 2007
Unfortunately, the memeory leak problem is also present in the version 1.0.6.
- Dec 17 2007
Disk Manager

System Software 18 comments

Score 80%
80 Likes
20 Dislikes
Nov 20 2007
Yes, it works.
The ext2fs is missing.
Debian unstable:
http://packages.debian.org/sid/hurd
Debian stable:
http://packages.debian.org/sid/genext2fs

There is not any other file resembles to ext2fs.
Which one is the right?
- Nov 22 2007
You must say more concerning the dependencies. E.g. which kind of ext2fs required by this application?
(Compilation error!) - Nov 21 2007