profile-image

sonjabritss

QLed

Qt Widgets 44 comments

Score 73%
73 Likes
27 Dislikes
Sep 05 2017
Hi! I'm trying to install the plugin, but when I type make I get the following error:
make -f Makefile.Release
make[1]: Entering directory '/home/sonja/Downloads/qtled'
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIC -DQT_NO_DEBUG -DQT_PLUGIN -DQT_SVG_LIB -DQT_DESIGNER_LIB -DQT_UIPLUGIN_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_XML_LIB -DQT_CORE_LIB -DQDESIGNER_EXPORT_WIDGETS -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtSvg -isystem /usr/include/x86_64-linux-gnu/qt5/QtDesigner -isystem /usr/include/x86_64-linux-gnu/qt5/QtUiPlugin -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtXml -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -Irelease -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o release/qled.o qled.cpp
In file included from qled.h:21:0,
from qled.cpp:23:
/usr/include/x86_64-linux-gnu/qt5/QtDesigner/QDesignerExportWidget:4:4: warning: #warning Header is deprecated. Please include instead. [-Wcpp]
# warning Header is deprecated. Please include is deprecated. Please include instead. [-Wcpp]
# warning Header is deprecated. Please include is deprecated. Please include instead. [-Wcpp]
# warning Header is deprecated. Please include ’
Q_EXPORT_PLUGIN2(customwidgetplugin, QLedPlugin)
^
qledplugin.cpp:113:1: error: expected unqualified-id at end of input
Q_EXPORT_PLUGIN2(customwidgetplugin, QLedPlugin)
^
Makefile.Release:286: recipe for target 'release/qledplugin.o' failed
make[1]: *** [release/qledplugin.o] Error 1
make[1]: Leaving directory '/home/sonja/Downloads/qtled'
Makefile:38: recipe for target 'release' failed
make: *** [release] Error 2 - Jun 14 2018