profile-image

felmur

Felice Murolo , Italy

KEncFS-Plasma

System Software Feb 28 2018
Score 50%
50 Likes
50 Dislikes

KEncFS

System Software Feb 05 2017
Score 68%
68 Likes
32 Dislikes

KMyGLCubeSaver

Screensavers Jun 17 2012
Score 59%
59 Likes
41 Dislikes

KBubbleSaver

Screensavers Feb 06 2010
Score 60%
60 Likes
40 Dislikes

KFlocks

Screensavers Jun 22 2008
Score 61%
61 Likes
39 Dislikes

KFieldLines

Screensavers Jun 22 2008
Score 57%
57 Likes
43 Dislikes

KBiof

Screensavers Jun 22 2008
Score 59%
59 Likes
41 Dislikes

IFMonitor

Network Jun 22 2008
Score 61%
61 Likes
39 Dislikes
KEncFS-Plasma

System Software

Score 50%
50 Likes
50 Dislikes
Feb 28 2018
Hi, the #include on line 55 of file mainwindow.cpp is needed to search for *.h files needed for Wallet app development.

In my distro (ArchLinux) those is the directory i have into include default path (/usr/include).
What is yours?
Please, follow this simple instructions and try to find your correct path:

$ cd /usr/include
$ find | fgrep Wallet

When you have found the correct path, you can fix it in mainwindow.cpp file, on line 55.
Please, tell me what is the correct Wallet path of your distro, so I can update my QMake files. Regards.
- Jul 27 2017
KEncFS

System Software 46 comments

Score 68%
68 Likes
32 Dislikes
Feb 05 2017
Hello, only today I read your message, sorry.
No, there isn't a way to change password of an existing encfs volume with KEncFS.... for now. Please try to do it manually. You can follow this guide: http://bredsaal.dk/how-to-change-encfs-password - Aug 04 2016
I had never noticed the empty toolbar below the menu. It must be a misprint of QtDesigner, so I eliminated. As for the icon, in one of many update of breeze, the "lock" icon default had disappeared, so I had replaced with another. Now I have recovered the original SVG icon breeze and I created a fixed icon for the application. Check version 1.6.2. - Apr 10 2016
Thank you. Please, check 1.6.1 version. - Apr 09 2016
have you kdelibs5-dev installed ?

- Jan 13 2015
hello, please, check if you have a "uic-qt4" or "uic-qt5". I think that uic-qt4 is the right choice. So, if you have this, make a symbolic link in your /usr/bin for the uic reference.

On Archlinux (my OS), /usr/bin/uic is a symbolic link to a file named qtchooser, which select the proper developing version of Qt libs and then run uic-qt4 or uic-qt5.

I don't know LinuxMint, but I've found some references to "uic" problems on google. If you don't have one of uic-qt4 or uic-qt5, try to run sudo apt-get install libqt4-dev

- Nov 19 2014
LOL, a few fistfuls of hair ... :-)

I'm working on a fix for this. Hope I can release new version in a few hours. - Apr 28 2014
try this modified kencfs.pro

# -------------------------------------------------
# Project created by QtCreator 2010-08-22T10:38:43
# -------------------------------------------------
TARGET = kencfs
TEMPLATE = app
SOURCES += main.cpp \
mainwindow.cpp \
fsDialog.cpp \
config.cpp \
qtsingleapplication.cpp \
qtlocalpeer.cpp \
qtlockedfile.cpp \
configdialog.cpp
HEADERS += mainwindow.h \
fsdialog.h \
config.h \
qtsingleapplication.h \
qtlocalpeer.h \
qtlockedfile.h \
configdialog.h
FORMS += mainwindow.ui \
fsdialog.ui \
configdialog.ui
OTHER_FILES +=
LIBS += -lkdeui -lkdecore -lQtNetwork
TRANSLATIONS = kencfs_it.ts kencfs_ro.ts

# archlinux
INCLUDEPATH += "/usr/include/KDE"

#fedora
INCLUDEPATH += "/usr/include/kde4/KDE" "/usr/include/kde4"
LIBS += -L/usr/lib64/kde4/devel

# install
target.path = /usr/bin/
data.path = /usr/share/kde4/apps/kencfs/translations/
data.files = *.qm
doc.path = /usr/share/doc/kencfs-1.3
doc.files = README preview.png preview2.png
desktop.path = /usr/share/applications
desktop.files = kencfs.desktop
#INSTALLS += target data desktop
INSTALLS += target data doc desktop
CONFIG += release
- Mar 13 2014
# -------------------------------------------------
# Project created by QtCreator 2010-08-22T10:38:43
# -------------------------------------------------
TARGET = kencfs
TEMPLATE = app
SOURCES += main.cpp \
mainwindow.cpp \
fsDialog.cpp \
config.cpp \
qtsingleapplication.cpp \
qtlocalpeer.cpp \
qtlockedfile.cpp \
configdialog.cpp
HEADERS += mainwindow.h \
fsdialog.h \
config.h \
qtsingleapplication.h \
qtlocalpeer.h \
qtlockedfile.h \
configdialog.h
FORMS += mainwindow.ui \
fsdialog.ui \
configdialog.ui
OTHER_FILES +=
LIBS += -lkdeui -lkdecore -lQtNetwork
TRANSLATIONS = kencfs_it.ts kencfs_ro.ts

# archlinux
INCLUDEPATH += "/usr/include/KDE"

#fedora
INCLUDEPATH += "/usr/include/kde4/KDE" "/usr/include/kde4"
LIBS += -L/usr/lib64/kde4/devel

# install
target.path = /usr/bin/
data.path = /usr/share/kde4/apps/kencfs/translations/
data.files = *.qm
doc.path = /usr/share/doc/kencfs-1.3
doc.files = README preview.png preview2.png
desktop.path = /usr/share/applications
desktop.files = kencfs.desktop
#INSTALLS += target data desktop
INSTALLS += target data doc desktop
CONFIG += release - Mar 13 2014
Note that line 42 of mainwindow.cpp must be:

#include <KWallet/Wallet>

Please, tell me if works, so I edit online package.

Regards. - Mar 13 2014
mmmm... look here:

https://apps.fedoraproject.org/packages/kdelibs-devel/contents/

seems that Fedora kde includes for kwallet is located here:

/usr/include/kde4/KDE/KWallet/Wallet.

So the include problem can fix by adding "kde4/" before the include path specified in line 42 of mainwindow.cpp. Unfortunately, I think that different path for installed kdelibs could be generate other problems while linking.

So I think that the below kencfs.pro file can temporary solve the problems. Please, tell me if this works.


# -------------------------------------------------
# Project created by QtCreator 2010-08-22T10:38:43
# -------------------------------------------------
TARGET = kencfs
TEMPLATE = app
SOURCES += main.cpp \
mainwindow.cpp \
fsDialog.cpp \
config.cpp \
qtsingleapplication.cpp \
qtlocalpeer.cpp \
qtlockedfile.cpp \
configdialog.cpp
HEADERS += mainwindow.h \
fsdialog.h \
config.h \
qtsingleapplication.h \
qtlocalpeer.h \
qtlockedfile.h \
configdialog.h
FORMS += mainwindow.ui \
fsdialog.ui \
configdialog.ui
OTHER_FILES +=
LIBS += -lkdeui -lkdecore -lQtNetwork
TRANSLATIONS = kencfs_it.ts kencfs_ro.ts

# archlinux
INCLUDEPATH += "/usr/include/KDE"

#fedora
INCLUDEPATH += "/usr/include/kde4/KDE"
LIBS += -L/usr/lib64/kde4/devel

# install
target.path = /usr/bin/
data.path = /usr/share/kde4/apps/kencfs/translations/
data.files = *.qm
doc.path = /usr/share/doc/kencfs-1.3
doc.files = README preview.png preview2.png
desktop.path = /usr/share/applications
desktop.files = kencfs.desktop
#INSTALLS += target data desktop
INSTALLS += target data doc desktop
CONFIG += release









Regards



- Mar 13 2014
Hi, try to remove "KDE" from KDE/KWallet/Wallet from line 42 of mainwindow.cpp

original: #include <KDE/KWallet/Wallet>
try: #include <KWallet/Wallet>

Regards

- Mar 12 2014
Try to patch line 103 of qtlocalpeer.cpp. Now you see:

socketName += QLatin1Char('-') + QString::number(QtLP_Private::getuid(), 16);

Remove QtLP_Private reference. Your row 103 now become:

socketName += QLatin1Char('-') + QString::number(::getuid(), 16);

Save and type "make".



- Jan 09 2013
Hi, this error doesn't depend from kencfs sources.

Please, take a look here:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=672084

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=672007

https://aur.archlinux.org/packages.php?ID=27927

- Sep 22 2012
I've added a package for 64 bit. Please, tell me if it works. - May 17 2012
I could not reproduce this bug. To me the directory is created automatically with the "sudo make install". Are you sure you use the "sudo"? - Dec 14 2010
pdfForts

Dolphin Service Menus 1 comment

Score 56%
56 Likes
44 Dislikes
Aug 29 2017
as I've said in the object, it depends on pdftk - Oct 12 2014
Ascii Design

Text Editors 2 comments

Score 59%
59 Likes
41 Dislikes
Jul 11 2014
https://aur.archlinux.org/packages/ascii-design
- May 31 2014
EasyISO

System Software 30 comments

Score 52%
52 Likes
48 Dislikes
Feb 29 2012
Good.

Please, add some row of code to check if "fuseiso" cmd is present on guest system. If not, then display a warning. - Feb 26 2012
Instant Rimshot

Plasma 4 Widgets 7 comments

Score 64%
64 Likes
36 Dislikes
Dec 13 2011
here working, with kubuntu 10.10.

The file .ogg is included into "images" directory of the plasmoid archive.

The plasmoid source seems to properly load the sound, extracting file name from the XML configuration of the plasmoid. So, i don't understand the previous comment of gnumdk.

Regards - Jan 23 2011
Event countdown Plasmoid

KDE 1.-4. Improvements 1 comment

by kzm
Score 54%
54 Likes
46 Dislikes
Dec 22 2010
Good plasmoid! - Dec 21 2010
KeyLeds Plasmoid

System Software 10 comments

Score 57%
57 Likes
43 Dislikes
Jun 08 2011
Good App, thank you. I've created a Kubuntu 10.10 Maverick Meerkat deb package, available at link below:

http://linuxboy.altervista.org/repository/dists/maverick/main/binary-i386/keyleds_1.0-1_i386.deb.php

Regards.

- Dec 12 2010
PlaybaK (aka KDE Media Player)

Video Apps 146 comments

Score 84%
84 Likes
16 Dislikes
Jul 11 2010

Kubuntu Maverick Package available here:

http://linuxboy.altervista.org/vedi_rep.php?distro=maverick

- Nov 21 2010
Plasmoid for ebay item

Plasma 4 Widgets 27 comments

by nms
Score 74%
74 Likes
26 Dislikes
Jul 27 2011
Very good job. - Sep 11 2010
Win2-7 Pack

Icon Themes 1738 comments

Score 76%
76 Likes
24 Dislikes
Aug 23 2017
Yes, it works for Italian local time with:

gconftool-2 --set "/apps/panel/applets/applet_4/prefs/custom_format" --type string "<span font_desc=\"Trebuchet MS 8.0\" weight=\"bold\">%H:%M %p%n%d/%m/%Y</span>"


- Jul 21 2010
at first, it seem to be good. But now there is another problem: the date format isn't my format. Italian (and other europeans countries) use DD/MM/YYYY. Military time use MM/DD/YYYY. There is a way? What is the file to change manually? - Jul 20 2010
yes, it works. Thank you. - Jul 19 2010
After installation of this pack, clock applet make me crazy. I would to set 24h mode for time, but I can't!

How I can do this? - Jul 18 2010
Knights

Board 97 comments

Score 81%
81 Likes
19 Dislikes
Jan 24 2013
It works now on Kubuntu karmic.

If anyone is interesting in deb package, this is mine:

http://linuxboy.altervista.org/repository/dists/karmic/main/binary-i386/kchess_20100324-1_i386.deb
- Mar 25 2010
I think that this game is strictly dependent by QT 4.6.

- Mar 24 2010
Kubuntu karmic, 9.10

/home/felice/Scrivania/KChess/src/board.cpp:38:30: error: QPropertyAnimation: Nessun file o directory
/home/felice/Scrivania/KChess/src/board.cpp: In member function ‘void KChess::Board::centerOnPos(QGraphicsItem*, KChess::Pos, bool)’:
/home/felice/Scrivania/KChess/src/board.cpp:290: error: ‘class QPointF’ has no member named ‘manhattanLength’
/home/felice/Scrivania/KChess/src/board.cpp:292: error: ‘QPropertyAnimation’ was not declared in this scope
/home/felice/Scrivania/KChess/src/board.cpp:292: error: ‘anim’ was not declared in this scope
/home/felice/Scrivania/KChess/src/board.cpp:292: error: expected type-specifier before ‘QPropertyAnimation’
/home/felice/Scrivania/KChess/src/board.cpp:292: error: expected ‘;’ before ‘QPropertyAnimation’
/home/felice/Scrivania/KChess/src/board.cpp:294: error: ‘QEasingCurve’ has not been declared
/home/felice/Scrivania/KChess/src/board.cpp:297: error: ‘QAbstractAnimation’ has not been declared
/home/felice/Scrivania/KChess/src/board.cpp:291: warning: unused variable ‘t_piece’
make[2]: *** [src/CMakeFiles/kchess.dir/board.o] Errore 1
make[1]: *** [src/CMakeFiles/kchess.dir/all] Errore 2
make: *** [all] Errore 2
- Mar 24 2010
Loopy

Video Apps 42 comments

Score 78%
78 Likes
22 Dislikes
Apr 09 2010
When you can add subtitles gesture? - Mar 01 2010
KMyGLCubeSaver

Screensavers 7 comments

Score 59%
59 Likes
41 Dislikes
Jun 17 2012
I don't know, I use kubuntu 9.10, with kde 4.3.2.

See glwidgetimpl.h. At row 39 I define a dummy image content (the kde logo). This dummy image is correctly created, as I understand.

At row 47 I try to get a list of your directory content. If the list has one or some members, I get one of this images and load it (row 57).

I something goes wrong with load, you shound see an empty cube. So, the problem can be here (row 57-61). But I have no idea.
- Feb 17 2010
uhm... the same happens on my system if the images have "jpg" extension but they aren't really jpg files. For example, if I create some files with:

echo >a.jpg in $HOME/.myglcubesaver

i see a rotating cube with empty face (mine is green, because this is the default color of the cube).

Pls, can you send me an email with some of your images? Do not send anything if the images are personal stuff.

Or you can try with something gif or jpg downloaded by images.google.com

Thank you. - Feb 16 2010
Do you see a cube with KDE symbol on all faces or a cube with empty faces?

If you delete all the images in $HOME/.myglcubesaver what you see?




- Feb 16 2010
EMoC

Utilities 6 comments

Score 56%
56 Likes
44 Dislikes
Jan 28 2010
in sources mainwindow.cpp (about at row 160) you have defined a file dialog but then you have used the static funcion:

QStringList fileNames = QFileDialog::getOpenFileNames();

to get path of files selected.

So, if you close the dialog without select anything, emoc exits with a segmentation fault or other error.

You should use this:

if (dialog.exec())
{
QStringList fileNames = dialog.selectedFiles();
QString fn =fileNames.at(0);
QStringList fs = fn.split("/");
fs.removeLast();
lastFileDirectory = fs.join("/");
ui->listView->addItems(fileNames);
}

Again, i think you should add a space string at the row in which you specify the "-s" parameter for ffmpeg (around line 340), so the correct line is:

ffmpegParams += " -s "+QString::number(p.width)+"x"+QString::number(p.height);

I suggest you to add a line like this:

printf("command is: ffmpeg %s\n",ffmpegParams.toStdString().data());

at the end of ffmpegParams construction to evalue the correct command which will be executed.




- Jan 30 2010
Kuickplay Qt4

Audio Apps 6 comments

by trisz
Score 54%
54 Likes
46 Dislikes
Jan 24 2010
oh yes! - Jan 25 2010
Service Menu Manager

KDE 1.-4. Improvements 32 comments

Score 84%
84 Likes
16 Dislikes
Sep 14 2009
In the list that appears by clicking "get new services menu", the "Install" and "Remove" buttons isn't syncronized with the main list of service menus installed into system. In other words:

1) click on "install" for a service menu in the list of "get service menus" and close the list window. In the main list, appears the new service menu.

2) now click on the service menu item in main list and click the "remove service menu" button.

3)the item is correctly removed from main list, but if you open again the list by clicking "get new services menu", the service menus you've just removed from your main list results again installed.

Other problem: some menu file installed from "get new services menu", isn't installed correctly. Example: "Compress and Attach" servicemenus. What is the correct structure of the archive recognized by your program?


- Jan 17 2010
I have made a Kubuntu Karmic Koala 9.10 .deb package.

http://linuxboy.altervista.org/vedi_rep.php

get kcm-servicemenu_0.4-1_i386.deb

- Jan 17 2010
OpenDocument Thumbnail plugin

KDE 1.-4. Improvements 30 comments

Score 86%
86 Likes
14 Dislikes
Feb 25 2010
sorry, i mean Kubuntu and not Ubuntu. - Jan 13 2010
it works without any changes for me. I have a standard ubuntu 9.10, with all the necessary ubuntu packages to compile sources under kde & qt4.

Anyway, try to add:

FIND_PACKAGE(Qt4)

before that line (line 4) in CMakeLists.txt

- Jan 13 2010
Here you can find a package for Ubuntu Karmic Koala.


http://linuxboy.altervista.org/vedi_rep.php

Package is:

oo-thumbnail_1.0.0-1_i386.deb

- Jan 13 2010
Date Time Functions

Developer Tools 2 comments

Score 56%
56 Likes
44 Dislikes
Apr 21 2008
download link doesn't works.

- Mar 26 2008
KDM Theme Manager

KDE 1.-4. Improvements 237 comments

Score 76%
76 Likes
24 Dislikes
Dec 16 2007
I think that this solution could be rigth for you.

I grab this from a slackbuild created by Gohanz, the packager of http://www.slacky.eu website.

Run this before ./configure.

ACVER=`whereis aclocal- 2>&1|sed -e 's#.*bin/aclocal-\([0-9.]*\).*#\1#'`
sed -i -e "s/am__api_version=\"1.7\"/am__api_version=\"$ACVER\"/" configure

Hope this help.

If the quoted text isn't readable, search for kdmtheme on slacky.eu and check the slackbuild into download /src directory site. - Dec 18 2007
Subtitle Composer

Video Apps 181 comments

Score 89%
89 Likes
11 Dislikes
May 25 2009
Quote:

i'm not sure if you're referring to this, but there is already a spinbox for accurate video seeking: right click on the video information controls and check "Show editable position control" (see the 2nd screenshoot).


Argh! I haven't seen this before.Thank you. - Dec 16 2007
At the beginning: thanks for the app. It's very useful.

My problems:
1) when i play video using mplayer backend (I don't have gstreamer), if I press "stop" and the "play" again, there is no audio. My Mplayer version: MPlayer 1.0rc1-4.0.3
2) I have'nt understood what means "link this line to the video"....

My requests:
3) a spinbox for fine video timing
4) xinelib (kaffeine) backend - Dec 16 2007
KBackup

System Software 105 comments

Score 78%
78 Likes
22 Dislikes
Jan 13 2018
Good app, thank you.

Why you have individually compressed each file?

This is the only one thing I don't like of kbackup. - Oct 14 2007
Root Actions Servicemenu

Dolphin Service Menus 219 comments

Score 89%
89 Likes
11 Dislikes
Aug 06 2017
Good commodity. Thank you.

I've add this to my personal package builder:

sed -i "s/open_with konqueror %U/open_with konqueror %U --caption \"ROOT FILEMANAGER\"/" Root_Actions_2.0.1/10-rootactionsfolders.desktop

sed -i "s/open_with kate %U/open_with kate %U --caption \"EDITING AS ROOT\"/" Root_Actions_2.0.1/11-rootactionsfiles.desktop

These changes remember me that I've opened an application as root. - Sep 29 2007
epdbootsplash

System Software 8 comments

Score 87%
87 Likes
13 Dislikes
Sep 01 2007
Have you released sources?

Regards. - Sep 01 2007
KIO Slave sysinfo:/

KDE 1.-4. Improvements 241 comments

Score 84%
84 Likes
16 Dislikes
Oct 26 2007
I'm Italian, so you will read the error desc in this language.

This is the error that is shown in the konqueror window when I try to run "konqueror sysinfo:/" from konsole.

"Si è verificato un errore durante il caricamento di sysinfo:/:
Il processo per il protocollo sysinfo è morto inaspettatamente."

This happens when I try to run the kio_slave as a normal user.

When I try to run it with:

kdesu konqueror sysinfo:/

seems that kio_slave works fine. So, if i run sysinfo:/ as root it works, even the first rescan() function. After the first rescan(), the error is shown again.

Any ideas?

I have a distro created from scratch, but slackware 11 seems to have the same problem. - Jun 25 2007
Instant Rimshot

Plasma 4 Widgets

Score 64%
64 Likes
36 Dislikes
Jan 23 2011
kchmviewer

Utilities

Score 85%
85 Likes
15 Dislikes
Jan 14 2011
Event countdown Plasmoid

KDE 1.-4. Improvements

by kzm
Score 54%
54 Likes
46 Dislikes
Dec 21 2010
KeyLeds Plasmoid

System Software

Score 57%
57 Likes
43 Dislikes
Dec 12 2010
plasma_pyweather

Plasma 4 Widgets

Score 89%
89 Likes
11 Dislikes
Nov 21 2010