Dave Aitken

Amarok 1.x Scripts 19 comments

Score 50%
50 Dislikes
Jan 30 2007
I updated to Ubuntu Hardy, and amarokMPC broke, giving an error on line 41, due to changes in python-XML. Apparently it interferes with some core python XML modules.

There's an easy enough fix though, you just reinstall the python-xml package, and they get put in something like /usr/lib/python2.5/site-packages/oldxml

Then edit and find line 41, which is

from xml.dom.ext.reader import Sax2

and add this as a new line just before that:

sys.path.append('/usr/lib/python%s/site-packages/oldxml' % sys.version[:3])

This lets the script know where to find the files. Hope this helps someone else! - Apr 25 2008