Places menu

Plasma 4 Widgets

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

1
Score 72%
Description:

Access your favourite places from your desktop or panel. Mount, umount and eject removable media.

Requires: plasma-scriptengine-ruby

Installable from the Plasma desktop or download it and install with
plasmapkg -i places.plasmoid

Last changelog:

8 years ago

0.1 Initial release
* Upload for Plasma 4.5

kozojed

7 years ago

i was missing Places menu from gnome since i had to convert to KDE in ubuntu 11

thanx, maybe rewrite without rubby to get in default kde installation hmmm

Report

kdekda

8 years ago

my system: Kubuntu 10.10 with kde 4.6 and plasma-scriptengine-ruby installed. The plasmoid show a messagein which it say that it can't find ruby-script.
plasma-scriptengine-ruby output:
could not findrequested component: olibreplaces

Report

C

dpalacio_double

8 years ago

Hi, which one did you install? Did the last message appear on the desktop or plasmoidviewer? Please install the 45 version and execute "plasmoidviewer olibreplaces" in the terminal.

Report

kdekda

8 years ago

both version gave the same error.
can't find ruby-script etc..(appears on the plasmoid)
here is the "plasmoidviewer olibreplaces" output:
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: File o directory non esistente
QFileSystemWatcher: failed to add paths: /home/davide/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
plasmoidviewer(4595)/kdecore (services) KServiceFactory::findServiceByDesktopPath: "" not found

Report

janet

8 years ago

I have KDE 4.5.x and installed the 45 version of the widget. But it does not produce a popup menu as it is shown in your screenshot but puts the menu items directly into the panel as a scrollable list with the heigth of the panel. Alas not very useful.

Report

C

dpalacio_double

8 years ago

I have seen this reported for Python widgets as well for KDE 4.5. Sadly, I do not have KDE 4.5 installed anywhere so I cannot test this at the moment

Report

lordlukas

8 years ago

sorry, didn't understand, How can we install it?

Report

C

dpalacio_double

8 years ago

Sorry about that. It now should be installable from the Plasma desktop.

You can also download it. Click on it and open it with "plasmapkg -i".

Report

lordlukas

8 years ago

plasma-scriptengine-ruby installed

error:
can't create script engine ruby-script for object places menu

Report

C

dpalacio_double

8 years ago

Hi. Are you using KDE 4.5 or older? Please try the 4.5 download.
If that does not work, please tell me the output of:

plasmoidviewer olibreplaces

or

plasmoidviewer org.orbitalibre.places

Report

madegirah

8 years ago

Can't find one in Fedora 14

Report

C

dpalacio_double

8 years ago

You should be able to install without problems plasma-scriptengine-ruby from Fedora 15 because the package only contains ruby scripts, that don't change very much between KDE versions.

Report

8 years ago

0.1 Initial release
* Upload for Plasma 4.5

product-maker zegenie Oct 28 2011

product-maker StrikeHoreges Oct 27 2011

product-maker tamra Sep 09 2011

product-maker DenisSeidel Aug 28 2011

product-maker rudi Jul 24 2011

product-maker tonywoolf Jul 24 2011

product-maker e1nste1n Jul 10 2011

product-maker seamanj May 19 2011

product-maker daltinn May 12 2011

product-maker Brutus180 Apr 25 2011

product-maker Infosoft Apr 04 2011

product-maker janet Mar 26 2011

product-maker lopezjll58 Mar 12 2011

product-maker AlejandroNova Mar 12 2011

product-maker leifmg Mar 12 2011

product-maker Arteal Mar 08 2011

product-maker herrbatka Mar 06 2011

product-maker nerdykid Mar 04 2011

product-maker pierigno Mar 02 2011

product-maker kem Feb 26 2011

product-maker WillS Feb 25 2011

product-maker darkmas Feb 23 2011

product-maker colomar Feb 22 2011

product-maker vitoubien Feb 22 2011

product-maker dreamsoul Feb 22 2011

product-maker 6 6

File (click to download) Version Description Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
0.1
updated Feb 21 2011
added Feb 21 2011
downloads today
0
page views today 3