OpenOffice.org1.1 toolbar icon themes

Various KDE 1.-4. Styles

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

1
Score 72%
Description:

This is a tcl script for generating OOo toolbar/menu icon themes, from kde (or other) icon sets.

Rather than focusing on individual themes for each icon set, I decided to provide a tool so that the users can create their own custom icon themes. That said, some common icon-themes from kde-look are enclosed (base = crystal).


Install
-------

Extract the downloaded file.
* To install the default theme in OOo 1.1.x, run:
"tclsh quickInstall.tcl"

* To install any custom themes,
Specify your OOo config directory in config.tcl and the theme directory, run:
"tclsh genbar.tcl"

Last changelog:

15 years ago

(0.1) Initial release

(0.2) Second release (improved functionality)
* OOo config directory is now backed up before continuing.
* Icons are now stored in a different folder, that should fix the loading error issue.
* Image index for bitmaps starts from 0.
* Option to turn icon-masking off, since some themes don't look good with masking.
* Option to add navigation icons to the function toolbar (screen-shot 2).
* few additional icons (nuvola + noia) and slots.

(0.3) - Third release (more improvements + additions)
* Koen Muylkens has joined in (more icons!)
* Significant updates in the script (no more major changes in future, hopefully).
* Option to use your default-kde icons
(slect icon theme in kcontrol, run script and the icons will appear in OOo)
* Option to add a navigation toolbar
* There is a static *untested* windows config theme under "Extras".
* Number of base icons is > 80 (22x22)

(0.32)
* Crystal base icons for font/para properties
* slotlist.csv format changed to allow icons for macros
* Runs 30% faster than v-0.3 (defaults)
* Folder "Extras" contains gimp files for font icons

(v 0.4)
* Several new icons, total > 150 (22x22)
* Configuration is now set in a separate file (config.tcl)
* New quick-install mode for OOo 1.1.x. To install the base theme, run: "tclsh quickInstall.tcl"
(no need to update config.tcl)
* Script improvements
* Static windows theme had to be removed due to space constraints.

(v 0.5)
* imagelist.xml format changed, should reduce the overhead for OOo startup.
* Script runs almost twice as fast as version 0.4 (defaults).
* Additional icons for draw, and some others updated.
* Error on qtrc not available bug fixed, and other small improvements.
* Separate submission for generating static themes: (http://www.kde-look.org/content/show.php?content=8529)

(v 0.52)
* quickInstall checks for multiple installed versions of OOo
* Option to scale icons to smaller size

Known Issues (see README)
------------
1. Debian systems
2. Background color lighter than #f1f1f1

cypherpunk

12 years ago

This would be splendid for OOo 2.x (the old icons loook kind of .. old). Any chance?

Report

KOPRajs

12 years ago

Will this work with OOo 2.x?
Or is there another way how can I set my KDE icon theme to be used by OOo?
(I'm using Vista Inspirate icons)

Thanks for help

Report

abciximab

13 years ago

Ok, I installed your OO-icons and now I just get black boxes instead of icons.
Please tell me how I can remove your patch.

Report

bleki

13 years ago

I think the problem is in "convert" (ImageMagick) binary (that is used by genbar.tcl) or maybe need more options. When convert from png to bmp, the output bmp file can't be opened by another image viewer.

Report

sanmartin

13 years ago

Please, help us.
I can't get OpenOffice back to the normality.
I'm using debian and my icons are blank.
How can we uninstall your theme?
And what should be the right install?

Report

PomTom

14 years ago

...with Ooo 1.1.4 (and KDE 3.4)

I get black boxes instead of icons

Report

steveu

14 years ago

Hi, I'm trying to install it on my ProMepis beta2 running Ooo1.1.3 but ended up with all the icons in Ooo1.1.3 disappeared. I've spent hours but can't seem to figure out the problem. I've read and re-read the instructions an the installation but the README file doesn't help at all. Can someone help? What did I not do?

Report

thomax

13 years ago

I had the same problem running OOo 1.1.4 on Kubuntu 5.04, just delete the images.xml file in you OOo config dir to get your standard icons back ;)

Report

cyboreal

14 years ago

I get the same results running this under SuSE 9.2 with OOo 1.1.3. Does it conflict with the kde extensions for OOo?

Report

mandrake-rick

14 years ago

same problem here with debian sarge / 1.1.3 .. with the KDE Extension. *grrr* and I REALLY WANT kde icons :((((((( no ways for us poor 1.1.3 User?

Report

stuartquimby

14 years ago

trying to install on a gentoo box running ooo 1.1.3 and totally striking out. I've read and re-read the README config.tcl and genbar.tcl and configured them both any possible way that makes even remote sense to me. Script always runs without complaint, but unerringly the results are a bunch of black featureless icons in OO. I see the comment about background colors and have set "set bg "#f1f1f1"" in config.tcl. I've spent a couple of hours on this already, what am I missing?

Report

hyperlite100

14 years ago

I have the exact same problem. I'm also running Gentoo and the same version of OO. I have Nuvola configured as the default icon set.

Report

madchic

14 years ago

I have the same Problem. ImageMagick make a zipped bitmap (BMz). So try this:

convert -verbose genBitmaps/userimages.bmp test.tga

and than save the TGA File as a Bitmap with eg. gimp

Report

jpanting

14 years ago

Great Job.... I did it...
But, icons in menues and tool bars are all the same size. we can't configure smaller icons for menues. for tool bars 22x22 are ok, but for menues 16x16 must be better. is there a way to change that??

Any way, thanks, my OOo suit is better since I found your job.

Report

umueller

14 years ago

I've just tried your tool but the script tells me 'couldn't execute "convert': no such file or directory". What's wrong?

Uwe

Report

nima

14 years ago

You have to install ImageMagic. This package includes the tools 'convert' and 'composite'. They are used in this script.

Report

wanthalf

14 years ago

I get no images with set maskImg "false" and only B&W icons with set maskImg "true".

It would be also nice to have 22x22 icons in toolbars and 16x16 icons in menu. Is that combination possible or do all the icons have to have the same size??

Thanks for the tool anyway!

Report

nekrobius

14 years ago

I get the same problem - unrecoverable error. What am I doing wrong?

Report

joodoo9

14 years ago

i installed the themes and now when i open open office, i get an unrecoverable error has occured

help!!!

Report

C

kol

14 years ago

just remove the:
(path to openoffice)/user/config/soffice.cfg/

Path to openoffice can be found in your ~/.sversionrc

The script also makes a backup (soffice.cfg.bak), rename it as soffice.cfg to restore any previous customizations.

That should fix it.

Report

tightcode

14 years ago

I realize this is a little off-topic, but I was wondering whether something of this sort could be equally done for StarOffice.

Cheers,

TightCode

Report

Grobsch

14 years ago

Hi, great work!! I've just change my icons on OpenOffice, now I want to know if it's possible to change the background colors of bars, like toolbar color or menubar color??

How can I change the others colors os OpenOffice, or created my own toolbar, like a KDE Theme??

Report

soulman

14 years ago

Hi

I love the thing to be able to switch icons since OO really look crap by default.

However I get a black icons no matter what I try to do.

I have modded the conf-file to chose gorilla and I have changed it to my OO conf-dir.

As I execute the script I get these messages

ThemeDir: Gorilla/22x22/
icon-size = (22,22)
num icons: 171
OpenOffice config directory:
/home/johan/.openoffice/user/config/soffice.cfg/
Backing up config dir (soffice.cfg) to:
/home/johan/.openoffice/user/config/soffice.cfg.bak2/
Background Color: (#d6d6d6)
**.**********.******..*****.*****......**.*.........*************...****......****.*.........*..*...................................****......*............................ done

which to me seems to be in order. The color is darker than the "forbidden" color, is it not?



But the icons are still black. As soon as I remove the files added to the OO conf-dir everything is alright, hence I got the old icons.

So how do I solve this?

Report

C

kol

14 years ago

Are you using a debian based distro? Its a known issue for OOo shipped with it.

Report

soulman

14 years ago

No I'm using MDK 10 Official Release.

If there is anything else I should post please let me know.

Report

15 years ago

(0.1) Initial release

(0.2) Second release (improved functionality)
* OOo config directory is now backed up before continuing.
* Icons are now stored in a different folder, that should fix the loading error issue.
* Image index for bitmaps starts from 0.
* Option to turn icon-masking off, since some themes don't look good with masking.
* Option to add navigation icons to the function toolbar (screen-shot 2).
* few additional icons (nuvola + noia) and slots.

(0.3) - Third release (more improvements + additions)
* Koen Muylkens has joined in (more icons!)
* Significant updates in the script (no more major changes in future, hopefully).
* Option to use your default-kde icons
(slect icon theme in kcontrol, run script and the icons will appear in OOo)
* Option to add a navigation toolbar
* There is a static *untested* windows config theme under "Extras".
* Number of base icons is > 80 (22x22)

(0.32)
* Crystal base icons for font/para properties
* slotlist.csv format changed to allow icons for macros
* Runs 30% faster than v-0.3 (defaults)
* Folder "Extras" contains gimp files for font icons

(v 0.4)
* Several new icons, total > 150 (22x22)
* Configuration is now set in a separate file (config.tcl)
* New quick-install mode for OOo 1.1.x. To install the base theme, run: "tclsh quickInstall.tcl"
(no need to update config.tcl)
* Script improvements
* Static windows theme had to be removed due to space constraints.

(v 0.5)
* imagelist.xml format changed, should reduce the overhead for OOo startup.
* Script runs almost twice as fast as version 0.4 (defaults).
* Additional icons for draw, and some others updated.
* Error on qtrc not available bug fixed, and other small improvements.
* Separate submission for generating static themes: (http://www.kde-look.org/content/show.php?content=8529)

(v 0.52)
* quickInstall checks for multiple installed versions of OOo
* Option to scale icons to smaller size

Known Issues (see README)
------------
1. Debian systems
2. Background color lighter than #f1f1f1

product-maker drmcnellis May 10 2015

product-maker 80 209

File (click to download) Version Description Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
updated Oct 27 2003
added Jul 24 2003
downloads today
0
page views today 4