No dependency hell 1

Wallpaper Other

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
5.0
Description:

My point was not that it does not have dependencies.
My point was about binary packages and repositories.
Rpm and Deb packages cannot ignore version dependencies.Never.That is what made me mad when using debian or fedora.You need to have package version 1.25,but you have package version 1.24 and that is why you cannot install a simple small app that hardly uses the package.

Dependencies cannot be ignored with apt,so you have to google for the damn package and this makes me mad,because you dont have a choice.You need to fetch 100mb of useless data to upgrade 0.89 to 0.90 and that all just to get a small package ( 1mb )installed.

With tgz package using distros (like Vector --teh best),you get apt-get's luxury without the dependency hell (slapt-get --dep-ignore)
UPDATE-----------
$ Uploaded a cleaner version of the wp with "compile it silly" message,lol.
$ Changed the discription so it does not confuse . Sry.
RATE TEH PENGUINS,NOT ME! LOL
$Added another version of the wp.100 clean , without the background.
-------
I swear,I will not bring this up again,only if its very urgent,lol.

nbensa

13 years ago

;-)

Report

C

blurymind

13 years ago

Ofcourse that it has dependencies,silly.
My point was not that it does not have dependencies.
My point was about binary packages and repositories.
Rpm and Deb packages cannot ignore version dependencies.Never.That is what made me mad when using debian or fedora.You need to have package version 1.25,but you have package version 1.24 and that is why you cannot install a simple small app that hardly uses the package.

Dependencies cannot be ignored with apt,so you have to google for the damn package and this makes me mad,because you dont have a choice.You need to fetch 100mb of useless data to upgrade 0.89 to 0.90 and that all just to get a small package ( 1mb )installed.

Report

anytimeIsLunchtime

13 years ago

dpkg --force-depends-version: Don't care about versions when checking dependencies.

dpkg --force-conflicts: Install, even if it conflicts with another package. This is dangerous, for it will usually cause overwriting of some files.

Report

C

blurymind

13 years ago

and then right after I start apt or synaptic,I cannot install anything before the stated BROKEN package is removed.

Report

Brandybuck

13 years ago

I've been wondering how Vector Linux does away with dependencies. The only thing I could figure is that everything was statically compiled. So I went to the Vector Linux page to find out.

Surprise! Vector Linux has dependencies just like every other distro! They even have a forum page on how to handle dependencies (http://vectorlinux.com/forum/viewtopic.php?t=325). GNOME won't work without the GTK package and KDE won't work without the Qt package. The dependency hell is still there, but since it's a lean distro to start wtih, the hell isn't quite so bad as your typical bloated distro. But there are STILL dependencies.

You are making claims that cannot be substantiated.

Report

C

blurymind

13 years ago

LOL.

I actually made someone go to vec's forum.
Well,I changed my description,so it does not confuse people.

All ubuntu lovers out there must hate me by now.Dont forget That I was One Of you months ago.Thats untill upgrading glibc6 totally borked my system and I was using the official repo. ;) That all happened just to get a 500kb package of another app.

Report

woodsmoke

13 years ago

That's just too funny, and I'm a Xandros user....keep up the great work!

ain't xandros geat!
wodsmoke

Report

C

blurymind

13 years ago

xandros is nice,but it is indeed using DEB for packagement system,which makes it (sorry) one of the penguins with a jailball and a walking stick,lol...

Report

oMasta0

13 years ago

I really enjoy these. Keep making them :)

Report

crushmaster

13 years ago

and yes you are right in what you saying!!!

Report

C

blurymind

13 years ago

thanks.
;)
I actually had this idea in my mind from quite a time.
I plan on making another version of this idea,that might look even funnier.

Report

12345678910
product-maker Count: 4 Rating: 5.0
File (click to download) Version Description Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
updated Jan 29 2006
added Jan 28 2006
downloads today
0
page views today 3