Excelsior (Engine)

GTK2 Themes

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
5.0
Description:

A Theme Engine based on Clearlooks.

Screenshots:

#1 Aqua Widget Style
#2 BubbleGum Widget Style
#3 Clarius Widget Style
#4 Flat Widget Style http://nanolx.org/free/scrn/xcl-flat.png
#5 Inverted Widget Stylehttp://nanolx.org/free/scrn/xcl-inverted.png

ENGINE OPTIONS:

contrast = # contrast. value is a float (eg 0.82)

radius = # widget roundness. value is a float

animation = # enable animation. TRUE or FALSE

scrollbarstyle = # the scrollbar style. 0 = striped; 1 = arrowed; 2 = plain

toolbarstyle = # the style of the toolbar 0 = gummy bar; 1 = glossy bar

menubarstyle = # the style of the menubar. 0 = gummy bar; 1 = glossy bar

HINT: gummy + gummy || glossy + glossy == merged bar

random_effect = # enable or disable random effects on buttons/tabs 0 = no; 1 = stripes; 2 = bubbles

random_opacity = # The Opacity of the stripes, value is a float from 0.0 to 1.0

progbar_style = # the style of the progressbar. 0 = striped; 1 = arrowed; 2 = flat gradient;

progbar_to_left = # wether to animate the progressbar rtl (right to left) or ltr (left to right). 0 = ltr; 1 = rtl

mw_gradient = # Gradient on the MainWindow, 0 = plain; 1 = horizontal gradient; 2 = diagonal gradient

aqua_tabs = # the Style of the Tabs; 0 = excelsior 1.0+; 1 = excelsior 1.0-

style = # The Widget style; one of INVERTED - BUBBLEGUM - AQUA - FLAT - CLARIUS

pellucid_scales = # How to draw the sliders on scales; 0 = opaque; 1 = pellucid

scale_trough_size = # size of the scale-trough widget (the bar behind the "volume-slider")

tooltip_style = # The Gradient on the tooltips 0 = Straight; 1 = Curved (like before);

TIP:

You can use the Gnome-Color-Chooser to modify the Theme.

If you have Excelsior 1.5.0+ you can also change the engine-options within Gnome-Color-Chooser

INSTALLATION:

Debian Systems

sudo apt-get install fakeroot dpkg-dev
( or: su -c "apt-get install fakeroot dpkg-dev")

dpkg-buildpackage -rfakeroot

This will - if you have all deps installed - generate a debian binary package, install it via:

cd .. && sudo dpkg -i excelsior*.deb
(or: cd .. && su -c "dpkg -i excelsior*.deb")

If you have built a package for SID, send it to me, so that I can provide it here
(I'm using GTK 2.15 and PANGO 1.24 at the moment, so I can't provide a Package now)

Non-Debian Systems

./configure --prefix=/usr

make

su -c "make install" / sudo make install

Perhaps you'll like it, too.

Comments welcome.
Last changelog:

10 years ago

4.1.0:

[general]

- improved configure.ac
- new autogen.sh (taken from sawfish)
- removed 9 unused variables
- fixed 2 implicit declarations
- updated debian/control description
- use single gtk/glib includes

[scale_trough]

- don't substract 2 from scale_trough_size
- fixed scale_trough right border
- set fallback value for scale_trough_size to 5

[handles]

- draw less grips on handles (4*2 if on toolbar, else 8*2)

[schema]

- added CLARIUS and FLAT to style-list

[themes]

- added scale_trough_size = 5 to all themes
- turn on random effects on all themes

azawi

8 years ago

:(

Report

Ikem

5 years ago

This is the actual download link: http://www.nanolx.org/downloads/TerraNova/Archive%20(Excelsior)/excelsior-4.1.0.tar.bz2.

Report

C

Chrispy

8 years ago

Sorry for the late reply... Excelsior is deprecated, see TerraNova instead.

Report

mylesg

10 years ago

I've built a .deb for Ubuntu 8.10 + Updates + Back-Ports but was unable to clearsign, could you help me with that?

Report

C

Chrispy

10 years ago

That is not that important, either way:

You need a gpg key for that. Create one via Seahorse.

Name of the key must be:

"Name Familyname <emailaddress>"

keep the < > characters, afterwards open debian/changelog and replace my string inthe last line "Christopher Bratusek <emailaddress>" (keep the rest of the line. and now rebuild.

Report

mylesg

10 years ago

OK, thanks, I have the key, just didn't change that line in the changelog. Now I know :)

Report

CruelAngel

10 years ago

I was wondering? What Windows manager do you use on the screenshots, and with what skin? Thanks.

Report

C

Chrispy

10 years ago

I'm a sawfish developer, so it's sawfish of course :) The Windowborder is aBOX.

http://sawfish.wikia.com -- here you can dl sawfish and almost 500 themes for it.

Report

CruelAngel

10 years ago

Oh, thanks :)

Report

Cygoku

10 years ago

Hi, I am trying to use this theme :

https://wiki.ubuntu.com/Artwork/Incoming/Intrepid/Intrepid-excelsior

But I am getting an error at line 157 using the 3.3.0 version of Excelsior. If I comment this line the error switch to line 158.

please help.

Cygoku

Report

DaveGardiner

10 years ago

BIG thumbs up here...best version of this engine so far!

Report

fireice

10 years ago

ok, thank you for that solution. i will try it. :)

Report

fireice

10 years ago

i have a selfmade theme which uses excelsior engine + pixmaps..there is something strange in thunderbird's menubar. (only with excelsior, same theme with murrine engine works fine in TB)

http://img84.imageshack.us/img84/9509/screenshot01pd2.png

btw: so far an exciting engine

Report

C

Chrispy

10 years ago

I know that problem, but it's not my fault. It's because of Thunderbirds bad Widget-Abstraction (Thunderbird is not a native GTK Application), the problem is also the case with firefox v2, with v3 not, because it has a better abstraction. To fix the issue you'll either have to set the GtkMenubar::shadow-type and the GtkToolbar::shadow-type to GTK_SHADOW_NONE or wait for thunderbird 3.

Report

Katie

10 years ago

I tried to build a deb package but I got this errors:

checking whether make sets $(MAKE)... (cached) yes
configure: error: cannot run /bin/bash ./config.sub
make: *** [config.status] Error 1
dpkg-buildpackage: failure: debian/rules build gave error exit status 2

How will I fix this?

Obviously, I got this error when I installed the fakeroot package from ubuntu repo. I have the same error too when I tried to compile this via ./configure --prefix=/usr. I'ven been successfully compiling this before via this command; It's only now I'm getting those errors after installing the fakeroot pacake...

Report

C

Chrispy

10 years ago

dunno, why this happens, but you can delete an re-extract the archive, or manually add the missing files via:

cp /usr/share/libtool/config.{guess,sub} .

or

cp /usr/share/libtool/libltdl/config.{guess,sub} .

Report

Katie

10 years ago

I have this file in that directory... Do you mean I'm going to copy theses files (config.guess & config.sub) into the excelsior folder after extraction then compile it?

Report

C

Chrispy

10 years ago

Download 3.2.1 it will not happen anymore

Report

Katie

10 years ago

I have this file in that directory... Do you mean I'm going to copy theses files (config.guess & config.sub) into the excelsior folder after extraction then compile it?

Report

Katie

10 years ago

I have this file in that directory... Do you mean I'm going to copy theses files (config.guess & config.sub) into the excelsior folder after extraction then compile it?

Report

slaapliedje

10 years ago

Excelsior is jacked when using Debian Sid + Experimental packages of Gnome.

When I try to compose an email with Evolution, the text entry is all sorts of screwey. I know it's excelsior, because as soon as I switched back to clearlooks, it works fine, well in as much as it does with Compiz leaving bits of the | around.

Report

C

Chrispy

10 years ago

Ok the Evolution Issue is solved. Just a misconfiguration of the themes.

Quote:bits of the | around.

Can you please explain that more? Screenshot or something like that?

Report

slaapliedje

10 years ago

It's because you have;

rm -f config.sub config.guess

in the debian/rules file under clean. I put a # before that line and now it compiles just fine.

Report

Katie

10 years ago

Just a clarification... Do I have to delete these files, config.sub config.guess, that are located in /usr/libtool directory?

Report

tylerbauman

10 years ago

I'm trying to install this, but it keeps telling me:
checking for x86_64-linux-gnu-pkg-config... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GTK... no
configure: error: GTK+-2.10 is required to compile excelsior
make: *** [config.status] Error 1
dpkg-buildpackage: failure: debian/rules build gave error exit status 2

I really don't know what to do at this point. I had a few other dependency issues earlier, but solved them only to reach another, thicker brick wall.

Additionally, I have "no"'s from checking for x86_64-linux-gnu-g77... no
through checking if x86_64-linux-gnu-gcc supports -fno-rtti -fno-exceptions... no

Clearly there is something very important I am missing, help?

Report

10 years ago

4.1.0:

[general]

- improved configure.ac
- new autogen.sh (taken from sawfish)
- removed 9 unused variables
- fixed 2 implicit declarations
- updated debian/control description
- use single gtk/glib includes

[scale_trough]

- don't substract 2 from scale_trough_size
- fixed scale_trough right border
- set fallback value for scale_trough_size to 5

[handles]

- draw less grips on handles (4*2 if on toolbar, else 8*2)

[schema]

- added CLARIUS and FLAT to style-list

[themes]

- added scale_trough_size = 5 to all themes
- turn on random effects on all themes

12345678910
product-maker Count: 4 Rating: 5.0
File (click to download) Version Description Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
4.1.0
updated Jan 08 2009
added Mar 07 2008
downloads today
0
page views today 3