Kopete 0.12.0 Cryptographyplugin Patch

Various KDE 1.-4. Improvements

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
7.1
Description:

Hi, i wrote a little patch for the Kopete (0.12.0) cryptrographyplugin (GPG). You can disable the "Incoming / Outgoing Encrypted Message" text which is shown in every cryptes message by default.

You have to download the kopetesource from kopete.kde.org and replace 3 files.

Install:

/* extract files */
tar xfj kopete-0.12.0.tar.bz2
tar xfz cryptoplugin_patch.tar.gz

/* replace files */

Copy all files from the folder sourcefiles (in the tar.gz) to the kopetesourcefolder kopete/plugins/cryptography/ (replace old files).

After this step you can install kopete with ./configure && make && sudo make install.

Felix
Last changelog:

13 years ago

==0.2==
- Improved plugin
- Added support for own messagemarkers (see screenshots)
- Fixed a small layoutbug

==0.1==
- Release of the first version

bastler

12 years ago

Very nice plugin! I, too, wonder why the developers of kopete never implemented something like this in the first place.

Only one suggestion:

Is there a way to also eliminate the line feed at the beginning of the message? (screen space is precious)

Report

hurra

12 years ago

Yeah, the newline is annoying.
Also the current theme is not used?

Report

C

Psypointer

12 years ago

I won't fix it, i'm not so deep invovled in the kopete development. i hope the developers will include this into the next kopete version and fix the newlineproblem.

felix

Report

C

Psypointer

12 years ago

this patch will not be in the next kopete release (0.12.1 i think because its a feature (the developer on the mailinglist said this). :(

Report

Cryss

13 years ago

Yeah! It would be cool to have this feature in the official kopete.

Report

liquidat

13 years ago

Please contact the authors of kopete to include this patch - I never understood why they have to add these strings just because you are using encryption modules...

liquidat

Report

13 years ago

==0.2==
- Improved plugin
- Added support for own messagemarkers (see screenshots)
- Fixed a small layoutbug

==0.1==
- Release of the first version

12345678910
product-maker Count:57 Rating: 7.11
File (click to download) Version Description Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
0.2
updated Jun 15 2006
added Jun 13 2006
downloads today
0
page views today 2