(Kate) FileTree plugin

Various KDE 1.-4. Improvements

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
5.0
Description:

Kate is such a perfect editor for me. But there's still one thing bother my mind: there's no file treeview browser in Kate. The current click-back-click-back file browser is usable but still, it's painful.

So, here goes your simple file treeview plugin .. simply activate in from kate preference.
Last changelog:

11 years ago

0.1-20070704:
- Happy Sync err Independence Day to all who celebrates
- Sync feature is working. Push the button with the
proxy icon thing.
- Bookmark works (persistence at ~/.kde/share/config/katefiletreerc)

BUGS:
- can't sync on an already open KFileTreeViewItem,
eg: sync on /home/foo/katefiletree after
sync on /usr/include/kde/kate/

TODO:
- prevent bookmarks duplication

01-20070627:
BUGS:
- opened doc should be active by default (FIXED)

01-20070626:
- URLcombo for free-jump navigation
- double click to open file
- go to home and root via boomark button dropdown menu
- TODO: bookmark function, filter, sync-display button

0.1
- initial ugly release
- No double-click to automate loading file into the editor, so basically you have to use drag and drop here.

robertgleeson

9 years ago

Thanks for your contribution. Looks great! I haven't been able to install it yet though. I'm stuck on:

checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE libraries installed. This will fail.
So, check this please and use another prefix!

I don't see any option to specify the path to KDE devel files inside ./configure --help. I've tried ./configure --with-extra-libs=/usr/lib/kde3 but it didn't work.

Thanks

Report

azumi

11 years ago

Could you tell me, what wallpaper is on your desktop?

Report

C

neofreko

11 years ago

You can get it from dannychoo.com

But be careful, it may be NSFW (Not Safe For Work aka don't open it from your office) sometimes

Report

bier

11 years ago

hello,

thank you for the plugin! that's a feature i always wanted to see in kate.

anyway, there seems to be something faulty here. i can't find the plugin in kate's preferences dialogs.

i am on debian and here is what i did to compile the plugin:
apt-get build-dep kate
tar xfj 60026-katefiletree-0.1-20070704.tar.bz2
cd katefiletree
./configure
make
make install

there were no errors. then i started kate. but i am unable to load the plugin, it isn't in the list of available plugins. do i miss something? my kate version is Kate 2.5.7 (KDE 3.5.7).

Report

C

neofreko

11 years ago

It should have been listed in the plugin section.

See this image http://img139.imageshack.us/img139/7636/katefiletreecy8.png

Notice the line with description: Kate File Treview Plugin please

Report

bier

11 years ago

hello again,

thanks for your help.

i was wrong. the plugin was on the kate plugins list.

but: because my $LANG environment variable is set to "de_DE", the plugin was named "Mein erstes Kate-Plugin" (in english: "my first kate plugin").

to make this even more confusing, the next entry on the list was named "Mein erstes Kate-Modul" (in english: my first kate module). so i thought of any kind of sample-plugin or so...

kind of confusing, isn't it? 8)


anyway, thank you again :-)

Report

C

neofreko

11 years ago

My bad, I should have deleted the other language translation since I didn't provide any translation for them :D

Thank you for your information

Report

KamilSzot

11 years ago

If you
./configure

and get error
"Can't find X libraries. Please check your installation and add the correct paths!"

you may need to install
libdevel/libxt-dev package

Report

bobojonez

11 years ago

I get the following error when i try make-

jon@holly:~/Desktop/linuxx86/katefiletree$ make
Makefile:857: warning: overriding commands for target `clean-bcheck'
Makefile:820: warning: ignoring old commands for target `clean-bcheck'
Makefile:862: warning: overriding commands for target `bcheck-am'
Makefile:825: warning: ignoring old commands for target `bcheck-am'
/bin/bash ./config.status --recheck
running CONFIG_SHELL=/bin/bash /bin/bash ./configure --no-create --no-recursion
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
./configure: line 1868: syntax error near unexpected token `katefiletree,'
./configure: line 1868: `AM_INIT_AUTOMAKE(katefiletree, 0.1)'
make: *** [config.status] Error 2

Any suggestions?
Automake version 1.10

Report

bobojonez

11 years ago


I got it to work. Very cool. Thanks for your hard work and willingness to share.

Report

andoy

11 years ago

I'm having the same problem. What exactly did you do to make it work?

Report

kakhaber

10 years ago

for me this problem was solved by downloading automake source version 1.9 from http://ftp.gnu.org/gnu/automake/automake-1.9.tar.gz and compiling it.
after compilining automake 1.9, plugin was installed successfully

Report

exclude

11 years ago

I had to install automake1.9, not just automake:
apt-get install automake1.9
and then a clean ./configure and a make did the trick. It solved the issue above.

Report

bobojonez

11 years ago

I am sorry but I don't remember what I did. It seems like maybe a permissions problem? Or maybe a reinstall of automake. I really wish I could be more help.

Report

andoy

11 years ago

Reinstalling automake did the trick, thanks!

Report

C

neofreko

11 years ago

phew :D

I'm very glad it works for you :)

Report

6thpink

11 years ago

In case someone is interested, I opened a bug at bugs.gentoo.org
and attached a Gentoo ebuild for this nice plugin:

http://bugs.gentoo.org/show_bug.cgi?id=184185

Regards.

-- Jesús Guerrero

Report

Filozof

11 years ago

It's great idea and (I hope) you've made it perfectly. :) I'm going to try it soon :)

Report

Diablo

11 years ago

Hi! I like your desktop, could you tell me the name of the various components? (window decorations, kicker, etc)
Thanks! :)

Report

C

neofreko

11 years ago

Actually it's fluxbox dekstop. I try my best to keep my memory consumption as low as possible since this is only a 256 MiB laptop :D

Why not KDE? well I still use many KDE app, eg: katapult, kate, dolphin/konq, kdevelop, amarok ..

Report

Diablo

11 years ago

I understand... I will try fluxbox to see if it is a good alternative to KDE ;)

Report

seraphyn

11 years ago

Thank You for this nice piece of Code. It was a missing feature.
Send this Code to the developers, this shouldn't be a plugin, this should be a piece of kate.
Seraphyn

Report

marseillai

11 years ago

Could give a link to a simply patch ?

Report

marseillai

11 years ago

thanks a lot for the patch.

Report

marseillai

11 years ago

when i try to apply your patch on kdebase it doesn't apply. i've tryed in several directory but it tells me :
kate$ patch -p1 < kate.patch
patching file ChangeLog
Hunk #1 FAILED at 2.
1 out of 1 hunk FAILED -- saving rejects to file ChangeLog.rej
can't find file to patch at input line 15
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Naur katefiletree/config.h k2/katefiletree/config.h
|--- katefiletree/config.h 2007-06-16 21:47:45.000000000 +0700
|+++ k2/katefiletree/config.h 2007-06-26 19:41:02.000000000 +0700
--------------------------
File to patch:
Skip this patch? [y]

Could you tell me how to apply ?

Report

11 years ago

0.1-20070704:
- Happy Sync err Independence Day to all who celebrates
- Sync feature is working. Push the button with the
proxy icon thing.
- Bookmark works (persistence at ~/.kde/share/config/katefiletreerc)

BUGS:
- can't sync on an already open KFileTreeViewItem,
eg: sync on /home/foo/katefiletree after
sync on /usr/include/kde/kate/

TODO:
- prevent bookmarks duplication

01-20070627:
BUGS:
- opened doc should be active by default (FIXED)

01-20070626:
- URLcombo for free-jump navigation
- double click to open file
- go to home and root via boomark button dropdown menu
- TODO: bookmark function, filter, sync-display button

0.1
- initial ugly release
- No double-click to automate loading file into the editor, so basically you have to use drag and drop here.

12345678910
product-maker Count: 4 Rating: 5.0
File (click to download) Version Description Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
0.1-20070704
updated Jul 04 2007
added Jun 08 2007
downloads today
0
page views today 1