osXBar

Karamba & Superkaramba

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
6.2
Description:

This is the Release Candidate of the new Fastest
Engine for osXBar 1.0

You can start to try the 1.0.23 RC1:

Enable Fast Image Scaling, my engine will do Smooth

PLEASE send feedback!!!! and VOTE to POLLS on my WEBSITE, it will help me to develop a better osXBar 1.0 :)
[screenshots, stuff, changelogs are on my website]

PS:
Mandrake, RedHat and other ones...
remeber:
export KDEDIR

PPS:
Do not download older version osXBar0.X!

PPPS:
It osXBar 1.0 run slow, or crash check osXBar.conf!

PPPPPS:
************** Important *************
http://www.xiaprojects.com/www/prodotti/osxbar/main.php?action=skpatch
There is my superkaramba 0.33 patch it will be REQUIRED to RUN osXBar 1.0.23
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Last changelog:

15 years ago

Check changelog on my website

on Gen 2004 I will start working to osXBar 1.1 with new engine, I hope to make osXBar 1.0 stable before :) send feedback...


If you would you like download tar.gz download the installer or use update from web site

send feedback about installer and configurator

I'm writing a Manual, do you like?
Can you help me to translate to your language?

cypherpunk

12 years ago

Run the configurator, point SuperKaramba to the theme, nothing happens.

Mandriva 2007.0

Report

jimbren

13 years ago

well...i downloaded it all and ran the configuration script, then started up Karamba and pointed it to the theme, and nothing happened.

the upper left corner gave me an odd blank box for a few minutes, that's about all.

Report

psY-MaUz

12 years ago

HI!

I have the same problem...

I'm using Kubuntu 6.10 Edgy Eft and Superkaramba 0.41


It's to bad, because i think i wuold like your bar :)

I hope u still working on it and help me :)

Report

sledgefisher

13 years ago

I get this too, has anyone got a solution to this yet?

Report

RahulBatra

12 years ago

same thing happening to me on mandriva 2006 :(

Report

rever75

13 years ago

Has this been solved I get the same issue on Mepis with SuperKaramba .37 rc2

Report

dBaser

13 years ago

Got the same result.

Report

weatherman

13 years ago

same thing happened to me (suse 10.0, superkaramba 0.37 rc2)

Report

jake3988

14 years ago

I'll just spit out what doesn't work.

1) The script will not download.

2) If I do it the regular way: ./osXBar.configure (this is a text file, thus can't do anything)

any ideas?

Report

stony777

14 years ago

I didn't think I would ask this annoying question myself sometime :)

But could you please give the whole name of the wallpaper-site you got that wallpaper from - it seems good ;)

It was just not readable due to the bar ;)

Report

AntiChrist

14 years ago

Why using Karamba?

Almost every theme does not work or you have too much sparetime.

Report

paulmccobels

14 years ago

osXBar looks like a really good product for kde, as i could see from the screenshots. Unfortunately, even though i completed every step of the installation and succeeded to load it in superkaramba, it does not show. It is completely transparent, as a matter of fact, i detected it because it blocked my desktop icons. When i run it from command line, i get a message "cannot load module xcursor.so" and that's it. I checked for it, and there's one xcursor.so file in the osxbar directory, but it doesnt seem to work fine.

For diagnosys, let me tell you I'm using KDE 3.3 from the debian port for amd64, which comes with superkaramba 0.35-2 as i checked at the package manager.

I don't know how to fix this problem, and, judging from the comments written by other users, it seems like it is a very common bug.

Can somebody tell us how to fix this?
I would be most grateful if you did.

Report

MaDiNfO

14 years ago

karamba as loaded the theme and it is loaded i have my desktop icons with a panel on it... and if i rigth clik it i get options menu but only that... can you please tell me wath is worng ?

Report

seventhguardian

14 years ago

hi.. same error... what can be wrong?

Report

cristi1979

14 years ago

superkaramba is loading the theme, but i can't see nothing. And I used both configs... Too bad

Report

cristi1979

14 years ago

And it's the same error as above:

Call to initWidget failed
Traceback (most recent call last):
File "/home/cristi/.superkaramba/osXBar_1.0.23_snow/osXBar.py", line 71, in initWidget
theEngine.Init(2)
File "/home/cristi/.superkaramba/osXBar_1.0.23_snow/osXBarEngine.py", line 259, in Init
theOptions.Init(NextStatus)
File "/home/cristi/.superkaramba/osXBar_1.0.23_snow/osXBarOptions.py", line 29, in Init
karamba.setMenuConfigOption(self.Engine.Widget, "osxbar_arrow", "1")
TypeError: an integer is required

Report

aziz93or

14 years ago

Hi !

I get this message error when i try to launch osXBar ...


> Call to initWidget failed
> Traceback (most recent call last):
> File "osXBar.py", line 71, in initWidget
> theEngine.Init(2)
> File "osXBarEngine.py", line 259, in Init
> theOptions.Init(NextStatus)
> File "osXBarOptions.py", line 29, in Init

> karamba.setMenuConfigOption(self.Engine.Widget, "osxbar_arrow", "1")
> TypeError: an integer is required


What should i do ?

Report

aziz93or

14 years ago

I have the same probleme ! some icons are hidden on the top left screen ! and when the i drag the mouse, errors appears in the terminal (where i launch superkaramba osXBar.theme)

It don't seem to works !!!

Report

dingdingdong

14 years ago

I am having problem with osxbar for SuSE 9.2 KDE 3.3. During starting, doesn't seems to do anything except hidding some icon on desktop (not all icons).

Attached is the error:
Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 1097301440 (LWP 5658)]
[KCrash handler]
#7 0x40ea5ee9 in QString::QString () from /usr/lib/qt3/lib/libqt-mt.so.3
#8 0x080ae728 in ThemeListWindow::closeTheme ()
#9 0x080b40fb in ThemeListWindow::qt_invoke ()
#10 0x40bc40ee in QObject::activate_signal ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x40bc4896 in QObject::activate_signal ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0x40f1c02c in QButton::clicked () from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0x40c5c4c9 in QButton::mouseReleaseEvent ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0x40bfa3f5 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0x40b6185f in QApplication::internalNotify ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0x40b63c06 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x407f7a91 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#18 0x40afefce in QETWidget::translateMouseEvent ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0x40afde86 in QApplication::x11ProcessEvent ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0x40b0e908 in QEventLoop::processEvents ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0x40b797b1 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0x40b795f6 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0x40b632ef in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0x0807857f in main ()

Hope you guys out there can help.

Report

basei

14 years ago

Hi, can anyone helpme ?
I've applied the patch, it dont works.

I 've now the superkarmba version 3.4

Thankyou


osXBar 1.0 FATAL ERROR:
Cannot load module: xcursor.so
FAQ:
- Where I can get a working xcursor.so module?
You can get it after you have compiled superkaramba in [examples/globalMouse/xcursor.so]
- Are you using a distro and don't know how to do this?
Try to download it from [http://www.xiaprojects.com/www/prodotti/osxbar/main.php]
- I have xcursor.so but it does not work for me
Send email to me: stefano _@_ xiaprojects.com

Traceback (most recent call last):
File "osXBar.py", line 54, in ?
import osXBarEngine
File "osXBarEngine.py", line 12, in ?
import xcursor
ImportError: Shared object "libc.so.6" not found
------------------------------------------------------
What does ImportError mean?

It means that I couldn't load a python add-on for osXBar.theme
If this is a regular theme and doesn't use python
extensions, then nothing is wrong.
------------------------------------------------------

Report

fredRX

14 years ago

Hello,

Version 1.0.23 snow won't work.
Older version are working fine...

I'm using Superkaramba 0.34 with Mandrake 10.0 AMD64 RC1

Do I have to apply the Superkaramba 0.33 patch ?
By the way, what do you mean by "Mandrake users: export KDEDIR" ?

Keep up the good job !

Report

Dominator

14 years ago

Cool wallpapers, tel me where can i get them?

Report

floyde

14 years ago

It's looking pretty good so far. 0.9 works fine but 1.0.23 doesn't work for me. I get the icons but no animation whatsoever. I'm using Suse 9.1 with KDE 3.2.1

Report

floyde

14 years ago

oops, sorry about that. I forgot to read about the superkaramba patch. All is well now.

Report

p0tatis

15 years ago

go and vote for http://bugs.kde.org/show_bug.cgi?id=21075 and maybe this will be included in kde..

Report

15 years ago

Check changelog on my website

on Gen 2004 I will start working to osXBar 1.1 with new engine, I hope to make osXBar 1.0 stable before :) send feedback...


If you would you like download tar.gz download the installer or use update from web site

send feedback about installer and configurator

I'm writing a Manual, do you like?
Can you help me to translate to your language?

12345678910
product-maker Count:257 Rating: 6.19
File (click to download) Version Description Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
1.0.23 Snow
updated Jan 18 2004
added Sep 22 2003
downloads today
0
page views today 12