SoundMania

Karamba & Superkaramba

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
6.4
Description:

Latest release highlights (ver 3.90):
-------------------------------------
- KDE 4 support!
- Serbian translations thanks to
Mladen Pejaković

This is a beta release for KDE 4 players (amarok 2 is not supported but amarok 1.4.x is). Please report bugs. PyKDE support is completely dropped due to the fact that KDE4 uses dbus.

If you want to contribute to translations, please do the following:

- a) If you want to do a new translation:
Open the file: --theme directory--/soundmania.pot in lokalize (part of kdesdk as of KDE 4.1, formerly known as kaider)

b) If you want to fix an existing translation:
Open the file --theme directory--/locale/--your language--/LC_MESSAGES/soundmania.po in lokalize (part of kdesdk as of KDE 4.1, formerly known as kaider)

- Do your translations. Please leave no 'fuzzy' translations.

- Go to edit --> edit header , in kbabel. Change the encoding to your proper encoding in the line "Content-Type: text/plain; charset=xxxxxx" (set xxxxxx to your own encoding)

- Save as 'soundmania.po'

- Send the soundmania.po file to me (my email address can be found in any py file inside the theme, also in the README)


Please have a look at the README file first if you have problems.

Introduction:
-------------------
This is a desktop applet designed for the purpose of displaying information and control of known media players.

It supports amaroK, XMMS, rhythmbox, KsCD, kaffeine, JuK.

For XMMS support you need to install the xmmsctrl package (which depends on xmms-devel):
http://user.it.uu.se/~adavid/utils/

Different backgrounds to make the theme compatible with most popular ones.

Soundmania requires:
- PyQt
- Imagemagick or PIL (Python Imaging Library)

Features:
--------------
- Displays artist name, song title, remaining time, bitrate(for amaroK, juk & rhythmbox only) of the playing song.
- Displays the album cover, if available (Look at the screenshots!). Rounded edges and/or shadow option.
- Supported languages: English, Finnish, French, German, Hungarian, Norwegian, Polish, Serbian, Turkish.
- Interactive progress bar: You can browse through the song by clicking on the progress bar.
- Control buttons
- Mouse wheel over the applet controls the volume.
- Configuration choice to switch between the players.
- Auto-select player feature.
- Configuration choices to display the album cover, shadow text, change the text and progressbar colors, the background and buttons.
- Customizable the text color.
- Customizable layout (limited)
- Condiguration window
- Optional 'Fetch albumcover for the currently playing track from internet' function. This saves the albumcovers in the ~/.albumcovers directory. When using amarok this function first asks amarok for the albumcover. In order to download an albumcover from internet, the artist and album name infos must be correctly entered in the id3 tag of the track.

TO DO:
----------
- Self-update function
- Add new themes& backgrounds

Known issues:
--------------------
- Only the font title and font size are effective in the font selection dialog

Troubleshooting:
---------------------------
Please have a look at the README file first if you have problems.
Before reporting any problems, it would be helpful to enable debug mode by modifying soundmania.py line ~50 to:
debug_mode = 2
, then start soundmania from a shell and post the output here.

Acknowledgement:
----------------------------
Thanks to:
- superkaramba, amarok, xmms, Juk, noatun, Kaboodle, KsCD, Kaffeine and rhythmbox teams
- "crystal" (Skeezo), "kubicaramba" (hds), "cynapses" (gladiac), "kpost-it, kavolo" (PitocheUrla),
"aero-g, aero-aio" (AdrienV), "TDE" (chip2003), "Krystal_Clear" (timere969), "jiin-crystal-clean, jiin-blue-crystal-clean" (jiin04), "DebiaNFO", (Noisemaker), "newramba2" (pootie), "newramba+" (s3m10s), "MetCheck" (etheri) theme authors for the backgrounds
- "k-skin" (toonmuylkens) , "rhythm" (maxime0810), "crystal" (nuka) buttonset authors
- "liquid XMMS" (baraquda), "amaroker" (Lechio) authors for the idea
- "Multiplayer" (ziuchkov) for PyKDE implementation
- "Liquid Weather ++" (matti) for translations engine. His themes rock!
- Anthony Thyssen, for round albumcovers edges code (URL: http://www.cit.gu.edu.au/~anthony/graphics/imagick6/thumbnails/)
- Ya'ir Aizenman, for 'fetching albumcovers from internet' idea. I adapted his perl script to python.
- Alastair Tse, for pytagger. This is used to fetch info from mp3's which is further used to fetch albumcover images from internet (URL: http://www-lce.eng.cam.ac.uk/~acnt2/code/pytagger/)
- Batiste FOLLET, for French translation. Eirik A. Rotevatn, for Norwegian translation. Tuomas Nurmi, for Finnish translation. Bernd Weigelt, for fixes in the German translation. Sylwester Gruszka, for Polish translation, Zsolt, for Hungarian translation, Mladen Pejakovic, for Serbian translations.
- everybody who pointed the bugs and possible improvements on the theme for testing

sorry for those whom I forget to mention who provided help for creating this theme.


Please leave your suggestions and comments.
Last changelog:

14 years ago

3.90:
- New feature: PyQt4/KDE4 support and requirement
- Cleanup: Dropped PyKDE support, noatun and kaboodle players support
- New feature: Added Serbian translations
- Bugfix: Theme doesn't initialize when progressbar is not displayed.
- Bugfix: Bitrate hiding/reappearing mechanism doesn't work consistent.

3.0:
- Disabled text-scrolling for 64 bit systems because it caused a crash due to a bug in superkaramba

2.9:
- Bugfix: Cover from the track dir is not displayed if "download cover" option is unchecked.
- Bugfix: Config window does not open if the keyboard shortcuts cannot be assigned.
- Bugfix: Textshifts don't work properly. (still some work needs to be done)
- Bugfix: Next track info doesn't update correctly.
- Cleanup: Standardized button positions
- New feature: Option for keeping the aspect ratio of the album cover image.
- Cleanup: Upgraded to pytagger 0.5
- New feature: Introducing "Soundmania Grandeur"
- Bugfix: Exception function is called before it is defined, when PIL is not installed.
- Cleanup: Moved player modules to the "modules" directory.

2.8:
- Big cleanup in the code. More than half of it is rewritten. Got rid of a major number of global variables.
- Config window is reorganized.
- User can now determine the hierarchy of the players in the auto-select player mode.
- PyQt is required from now on.
- PIL or Imagemagick (one or the other) required from now on.
- Added new text and cover vanishing/reappearing effects.
- Configuration options are stored only in ~/.superkaramba/soundmania/config
- 2 different debug modes
- Upgraded the license to GPLv3


2.7.6:
- Bugfix: artist and title continuously checked when the player is idle, causing cpu spikes.
- Missing albumcover retrieval fixed.
- Text sizes are determined via pixel size rather than number of characters.
- Dropped BMP support.
- Added new background: MetCheck


See inside the package for the full Changelog

Lechio

10 years ago

Glad to see you back at it :) Best regards, Lechio.

Report

C

ogetbilo

11 years ago

I will check the lockup issues you folks mentioned in a few weeks. Sorry, I was extremely busy in the past few months. I just saw your comments.

Report

dpetka2001

11 years ago

when i try to run the theme from superkaramba i get the following error when run from konsole
"jrn23@ ~/SuperKarambaThemes/soundmania-3.0 > superkaramba soundmania.theme
~/.albumcovers directory exists.

~/.superkaramba/soundmania directory exists.

ImageMagick installed
<type 'exceptions.ImportError'>
No module named Image
Exception occured:
Traceback (most recent call last):
File "soundmania.py", line 129, in <module>
import Image
ImportError: No module named Image
PIL not installed
<type 'exceptions.ImportError'>
No module named qt
Exception occured:
Traceback (most recent call last):
File "soundmania.py", line 155, in <module>
from qt import *
ImportError: No module named qt
PyQt not available. Shutting down!
sys.path.insert(0, '/home/jrn23/SuperKarambaThemes/soundmania-3.0/')"

my distro is gentoo and from what i can tell i have PyQt installed on my system...here's some output
"jrn23@ ~/SuperKarambaThemes/soundmania-3.0 > equery l PyQt
[ Searching for package 'PyQt' in all categories among: ]
* installed packages
[I--] [ ] dev-python/PyQt-3.17.4 (0)
[I--] [ ] dev-python/PyQt4-4.3.3 (0)"

Report

C

ogetbilo

11 years ago

So You have PyQt-3.17 installed in your system but soundmania does not recognize it. That's probably because the python module that soundmania requires is called "qt" and your PyQt-3.17 installation has a non-standard name for this module.

I don't know how things work in gentoo, but try to locate your "qt" module. In my system (fedora) it is located at:

/usr/lib/python2.5/site-packages/qt.so

Yours should be somewhere close. Python looks at a couple places for modules when they are called, these are defined in $SYSPATH. The directories "/usr/lib/python2.5/" and "/usr/lib/python2.5/site-packages/" are two of those places. Try to put a symlink to your own "qt" module in one of these directories and name your symlink "qt.so". The command you need is (as root):

ln -s /path/to/your/module.so /usr/lib/python-2.5/

Note that the "python-2.5" above might be different in your installation.

If this does not work, post me the contents of your PyQt-3.17 package and the directory where all your other regular python modules are installed.

Report

dpetka2001

11 years ago

ok here are the results

"root@ ~ > slocate qt.so
/usr/qt/3/lib/libqt.so.3.3.8
/usr/qt/3/lib/libqt.so.3.3
/usr/qt/3/lib/libqt.so.3
/usr/qt/3/lib/libqt.so
/usr/lib/xine/plugins/1.21/xineplug_dmx_qt.so
/usr/lib/xine/plugins/1.21/xineplug_decode_qt.so
/usr/lib/libpoppler-qt.so.2.0.0
/usr/lib/libpoppler-qt.so
/usr/lib/nsbrowser/plugins/mplayerplug-in-qt.so
/usr/lib/python2.4/site-packages/dbus/mainloop/qt.so
/usr/lib/python2.4/site-packages/qt.so
/usr/lib/libpoppler-qt.so.2"

"root@ ~ > equery f PyQt|grep so
/usr/lib/python2.4/site-packages/qt.so
/usr/lib/python2.4/site-packages/qtcanvas.so
/usr/lib/python2.4/site-packages/qtgl.so
/usr/lib/python2.4/site-packages/qtnetwork.so
/usr/lib/python2.4/site-packages/qtsql.so
/usr/lib/python2.4/site-packages/qttable.so
/usr/lib/python2.4/site-packages/qtui.so
/usr/lib/python2.4/site-packages/qtxml.so
/usr/share/sip/qt/qcursor.sip
/usr/share/sip/qt/qsocketnotifier.sip
/usr/share/sip/qt/qsound.sip
/usr/share/sip/qtnetwork/qserversocket.sip
/usr/share/sip/qtnetwork/qsocket.sip
/usr/share/sip/qtnetwork/qsocketdevice.sip
/usr/share/sip/qtsql/qsqlcursor.sip
/usr/share/sip/qtsql/qsqlselectcursor.sip"

and last

"root@ ~ > export $SYSPATH
declare -x ANT_HOME="/usr/share/ant-core"
declare -x CLASSPATH="."
declare -x CONFIG_PROTECT="/usr/kde/3.5/share/config /usr/kde/3.5/env /usr/kde/3.5/shutdown /usr/share/config"
declare -x CONFIG_PROTECT_MASK="/etc/env.d/java/ /etc/udev/rules.d /etc/fonts/fonts.conf /etc/terminfo /etc/texmf/web2c /etc/revdep-rebuild"
declare -x CVS_RSH="ssh"
declare -x DCCC_PATH="/usr/lib/distcc/bin"
declare -x DISPLAY=":0"
declare -x DISTCC_LOG=""
declare -x DISTCC_VERBOSE="0"
declare -x EDITOR="/usr/bin/vim"
declare -x GCC_SPECS=""
declare -x GDK_USE_XFT="1"
declare -x GENERATION="2"
declare -x HOME="/root"
declare -x INFOPATH="/usr/share/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.18/info:/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/info"
declare -x JAVAC="/etc/java-config-2/current-system-vm/bin/javac"
declare -x JAVA_HOME="/etc/java-config-2/current-system-vm"
declare -x JDK_HOME="/etc/java-config-2/current-system-vm"
declare -x KDEDIRS="/usr:/usr/local:/usr/kde/3.5"
declare -x LC_COLLATE="el_GR.utf8"
declare -x LC_CTYPE="el_GR.utf8"
declare -x LC_MONETARY="el_GR.utf8"
declare -x LC_NUMERIC="el_GR.utf8"
declare -x LC_TIME="el_GR.utf8"
declare -x LESS="-R -M --shift 5"
declare -x LESSOPEN="|lesspipe.sh %s"
declare -x LOGNAME="root"
declare -x LS_COLORS="no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.svgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:"
declare -x MANPATH="/etc/java-config-2/current-system-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-linux-gnu/2.18/man:/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/man:/opt/sun-jdk-1.4.2.17/man:/etc/java-config/system-vm/man/:/usr/kde/3.5/share/man:/usr/qt/3/doc/man"
declare -x OLDPWD
declare -x OPENGL_PROFILE="nvidia"
declare -x PAGER="/usr/bin/less"
declare -x PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.1.2:/opt/sun-jdk-1.4.2.17/bin:/opt/sun-jdk-1.4.2.17/jre/bin:/opt/sun-jdk-1.4.2.17/jre/javaws:/usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/qt/3/bin"
declare -x PKG_CONFIG_PATH="/usr/qt/3/lib/pkgconfig"
declare -x PRELINK_PATH_MASK="/usr/lib/gstreamer-0.10"
declare -x PS1="\\[\\e[32;1m\\]\\u@ \\w > \\[\\e[0m\\]"
declare -x PWD="/root"
declare -x PYTHONDOCS="/usr/share/doc/python-docs-2.4.4/html/lib"
declare -x PYTHONPATH="/usr/lib/portage/pym"
declare -x QMAKESPEC="linux-g++"
declare -x QTDIR="/usr/qt/3"
declare -x SHELL="/bin/bash"
declare -x SHLVL="1"
declare -x TERM="xterm"
declare -x USER="root"
declare -x VMHANDLE="sun-jdk-1.4"
declare -x XAUTHORITY="/root/.Xauthority"
declare -x XDG_DATA_DIRS="/usr/share:/usr/kde/3.5/share:/usr/local/share"

if there is anything else you need please tell me...thanks for your help and sorry for the delay it took me so long to respond to your first reply...thanks again...

Report

dpetka2001

10 years ago

any news to my post which you requested? another thing i would like to point out is that i discovered that there are 2 pythons in /usr/bin, one is python2.4 and the other one python2.5...i had noticed that when python and python2 are pointed (as symlinks) to python2.5 soundmania works fine but when they are pointed to python2.4 it gives me the error i describes previously...does it have to do with the way paths are looked upon depending on the different versions of python? however i don't have python-2.5 installed in my system...how come there are python2.4 and python2.5 in /usr/bin ?? thanks in advance and i hope something of what i've said might help you locate the problem...

Report

C

ogetbilo

10 years ago

Sorry dpetka2001, I haven't been able to look at soundmania for a long while.

Your problem looks like a distribution issue. The python superkaramba is using is not the python pyqt is compiled for, as far as I understood.

Keep an eye on updates. It should be fixed soon. Well, it may be fixed by now.


By the way, I just started porting soundmania to KDE 4. It should be done very soon.

Report

Hintzy

11 years ago

Since upgrading to Mandriva 2008, I've been having problems with the cpu usage of X going to 100% and KDE becoming slow/unresponsive when I leave the computer on for a long time. After a lot of work turning one program off at a time to see what happened, I narrowed the problem down to superkaramba. After more work, shutting down individual themes, I narrowed it down to soundmania (Aero-G caused the same problem on my machine at work, and I've replaced that with Aero-AIO).

When the cpu usage for X jumps to 100%, .xsession-errors fills with a lot of this message:

X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x3222b5b

The resource id changes every time. If I run soundmania from console, I get the same message. Since this problem is new with Mandriva 2008, it most likely is because of something they changed, but so far the only response I've gotten in their forums is "Superkaramba has been known to cause problems like that." (They're usually more helpful than that there...) So I wanted to see if that error meant anything to you and if you might have any ideas.

If it matters:
Mandriva 2008
KDE 3.5.7
Superkaramba 0.42
Soundmania 3.0 (though had same issue with 2.7.6)


Thanks,
-John

Report

Hintzy

11 years ago

no idea why that posted twice...sorry :-/

Report

C

ogetbilo

11 years ago

This is so weird. It doesn't happen on my i386 and x64 computers. The error message is irrelevant, it doesn't tell anything.

I don't know what to say. I appreciate your dedication to test and report bugs for soundmania.

Can you send me the contents of the ~/.superkaramba/soundmania/config file so I can try to reproduce the bug myself (you can email me or post it here)? Also inform me about your pykde status and your cpu type. I am also wondering: Does your cpu jump to 100% suddenly or does it gradually increase?

I found a couple other minor bugs so I think I will have to release a 3.0.1 version soon.

Report

Hintzy

11 years ago

Sorry for the extremely slow reply, I've been having trouble with one of my hard drives and been trying to figure out if the drive or the motherboard is behind the problem...

I don't currently have pyKDE installed. There isn't an rpm available for it that I've seen, and I've been too lazy to compile it myself. :-p My processor is an Athlon64 3200+.

Here's my soundmania config file:

VERSION = "030000"
updateinterval = 200
theme = "aero-g-round"
buttonset = "default"
player = "amarok"
playerlist = ['amarok', 'xmms', 'juk', 'kaffeine', 'noatun', 'kscd', 'kaboodle', 'rhythmbox']
textred = 255
textgreen = 255
textblue = 255
textshadow = 1
font = "DejaVu LGC Sans"
font_size = 11
showbitrate = 1
display_albumcover = 1
image_rendering = "imagemagick"
scan_cover_image = 1
show_progressbar = 1
pbarcolor = "light"
show_remaining_time = 0
mirror = "alternate"
effects = 1
round = 1
fetch = 0
scroll_text = 1
shadowcover = 1
textshift = 1
textshiftver = -5
encoding = "utf_8"
play_ra = 0
pykde_on = 0
language = ""
theme_path = "/home/john/.superkaramba/soundmania/currentver/"
keep_aspect = 0
widget_mode = "classic"



As for the CPU usage, I usually find it at 100% when I've left the computer alone for a while. I think once it did do it while I was sitting here, and it seemed to build up gradually, but I'm not sure. I'll load up the theme and keep an eye out for it.

Thanks,
-John

Report

skaar

11 years ago

i get that gradual lockup thing, i kill nspluginviewer and things stabilize, go back to normal speed, it's like there's some kind of leak in it. anyways, just switch consoles, top, >, see what's among the highest resource users in the list, check several times over a day. when you catch a slowdown you can compare and see what's started to hog, and use a killer script to check on it.

Report

Hintzy

11 years ago

Since upgrading to Mandriva 2008, I've been having problems with the cpu usage of X going to 100% and KDE becoming slow/unresponsive when I leave the computer on for a long time. After a lot of work turning one program off at a time to see what happened, I narrowed the problem down to superkaramba. After more work, shutting down individual themes, I narrowed it down to soundmania (Aero-G caused the same problem on my machine at work, and I've replaced that with Aero-AIO).

When the cpu usage for X jumps to 100%, .xsession-errors fills with a lot of this message:

X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x3222b5b

The resource id changes every time. If I run soundmania from console, I get the same message. Since this problem is new with Mandriva 2008, it most likely is because of something they changed, but so far the only response I've gotten in their forums is "Superkaramba has been known to cause problems like that." (They're usually more helpful than that there...) So I wanted to see if that error meant anything to you and if you might have any ideas.

If it matters:
Mandriva 2008
KDE 3.5.7
Superkaramba 0.42
Soundmania 3.0 (though had same issue with 2.7.6)


Thanks,
-John

Report

Upal

11 years ago

Hello
I get some problems using soundmania : the window disappears, or is not appearing.
Here's the debug :
ImageMagick installed
PIL not installed

PyQt detected!

Enhanced config window is available.

sys.path.insert(0, '/home/pol/.superkaramba/20866-soundmania-2.9.skz')
Updateinterval set to 200 ms
Setting amarok for playback as read from configuration file.
Language set to: Turque
Error reading file locale/Turque/LC_MESSAGES/soundmania.mo from zip
Call to initWidget failed
Traceback (most recent call last):
File "/home/pol/.superkaramba/20866-soundmania-2.9.skz/soundmania.py", line 616, in initWidget
File "/home/pol/.superkaramba/20866-soundmania-2.9.skz/soundmania.py", line 527, in initTranslation
File "/usr/lib/python2.5/gettext.py", line 180, in __init__
self._parse(fp)
File "/usr/lib/python2.5/gettext.py", line 273, in _parse
magic = unpack('<I', buf[:4])[0]
File "/usr/lib/python2.5/struct.py", line 87, in unpack
return o.unpack(s)
struct.error: unpack requires a string argument of length 4
Error in sys.excepthook:
Traceback (most recent call last):
File "/var/lib/python-support/python2.5/apport_python_hook.py", line 44, in apport_excepthook
binary = os.path.realpath(os.path.join(os.getcwdu(), sys.argv[0]))
AttributeError: 'module' object has no attribute 'argv'

Original exception was:
Traceback (most recent call last):
File "/home/pol/.superkaramba/20866-soundmania-2.9.skz/soundmania.py", line 616, in initWidget
File "/home/pol/.superkaramba/20866-soundmania-2.9.skz/soundmania.py", line 527, in initTranslation
File "/usr/lib/python2.5/gettext.py", line 180, in __init__
self._parse(fp)
File "/usr/lib/python2.5/gettext.py", line 273, in _parse
magic = unpack('<I', buf[:4])[0]
File "/usr/lib/python2.5/struct.py", line 87, in unpack
return o.unpack(s)
struct.error: unpack requires a string argument of length 4
Going to sleep...

Report

C

ogetbilo

11 years ago

For some reason your language setting is messed up. Edit the file:
/home/pol/.superkaramba/soundmania/config

there is a line called language, change that line to:

language = ""

It should work fine thenafter. Or alternatively, for a fresh start delete that config file. I'll also recommend deleting the /home/pol/.superkaramba/soundmania.rc
file (and perhaps all the soundmania files and subdirectories in that directory)

Report

Hintzy

11 years ago

I'm having trouble getting 2.9 working, here's the debug output:

[john@Hintzy soundmania-2.9]$ superkaramba soundmania-2.9debug.skz
sys.path.insert(0, '/home/john/Download/superkaramba/soundmania-2.9/soundmania-2.9debug.skz')
File "soundmania.py", line 786
class button():
^
SyntaxError: invalid syntax
------------------------------------------------------
What does ImportError mean?

It means that I couldn't load a python add-on soundmania.py
If this is a regular theme and doesn't use python
extensions, then nothing is wrong.
------------------------------------------------------



The theme is running on the desktop, but not visible.

Report

C

ogetbilo

11 years ago

That is a perfectly legal line in python. I don't understand why you get that error.

Did you set the debug mode to 2? See above for howto. Maybe there is an indentation error somewhere else. Python does this sometimes.

Report

Hintzy

11 years ago

I tried it at debug level 2 and got exactly the same thing EXCEPT for the position of the carat. Apparently, when the stuff I type here gets converted to html, the spacing changes, because I entered it again and in the preview it was wrong. The carat is actually under the close parenthesis (or perhaps the colon), not under the "c". I don't know if that helps.

Could it be that the version of a prereq has changed since 2.7.6 (which works fine), or that the old config info for 2.7.6 is messing it up?

Thanks,
-John

Report

C

ogetbilo

11 years ago

Hi John,
For the time being I still have no idea what's going on. Can you try erasing all the config files, both old and new:

rm -fr /home/your_username/.superkaramba/soundmania*
rm -fr /home/your_username/.albumcovers/temp
(the second one may not exist)

Did you ever try 2.9 on another system?

Report

Hintzy

11 years ago

I erased all my config files and still get the same problem. I can try my work computer (same distro, different hardware) next week, or I will be upgrading to Mandriva 2008 soon, maybe that will fix it. :-p

Report

thidney

11 years ago

Hi soundmania stop working on my 64 system quite long time ago, i recently decide to give it a try. So some feedback, if you like it.
I install pyhon-qt and python-kde-extension package, which should fullfill PyQT and PyKDE
I removed .superkaramba/soundmania* to avoid weird things.

On first run i get:
:~/karamba/soundmania-2.8> superkaramba soundmania.py
superkaramba: WARNING: KDirWatch: /home_local/pnemec_local/karamba/soundmania-2.8 is a directory. Use addDir!
Could not read config file.
Could not read config file.
Could not read config file.
~/.albumcovers directory exists.

~/.superkaramba/soundmania directory does not exist. Creating one...

ImageMagick installed
sys.path.insert(0, '/home_local/pnemec_local/karamba/soundmania-2.8/')
Traceback (most recent call last):
File "soundmania.py", line 114, in <module>
fnc_exception()
NameError: name 'fnc_exception' is not defined
------------------------------------------------------
What does ImportError mean?

It means that I couldn't load a python add-on soundmania.py
If this is a regular theme and doesn't use python
extensions, then nothing is wrong.
------------------------------------------------------

I do not know why, because function exist and no other calls make this problem. But i comment it and it worked.

When i want select my player last error jump at me:
~/.superkaramba/soundmania directory exists.

ImageMagick installed
PIL not installed

PyQt detected!

Enhanced config window is available.


PyKDE detected!

Soundmania will use PyKDE modules.

Updateinterval set to 200 ms
No player is found.
Dying with status 6
Going to sleep...
Language set to: en
<type 'exceptions.NameError'>
global name 'mplayer' is not defined
Exception occured:
Traceback (most recent call last):
File "soundmania.py", line 904, in widgetUpdated
current_time = mplayer.fnc_current_time()
NameError: global name 'mplayer' is not defined
<type 'exceptions.NameError'>
global name 'mplayer' is not defined
Exception occured:
Traceback (most recent call last):
File "soundmania.py", line 904, in widgetUpdated
current_time = mplayer.fnc_current_time()
NameError: global name 'mplayer' is not defined

I am not sure if my environment is not broken somehow (i can never be sure ;) )

Have a nice day and thank you for you great work

Report

C

ogetbilo

11 years ago

The first error is my mistake. fnc_exception is there but it is not defined yet. The order is important. You can move the fnc_exception function somewhere before that line 114, or just comment out that line as you did. Thanks for pointing this out.

The second error is not actually an error. It is an exception. 'Dying with status 6' means no player is found. What player are you trying? Did you try selecting that player instead of using the auto mode?

Thanks for the feedback.

Report

thidney

11 years ago

Sorry for long time reply. I can`t actually select any player. When i click on "Settings" i get this error message and nothink happend, no window with options, nothing.

Report

C

ogetbilo

11 years ago

Can you try the latest version (2.9) and send me the output (with debug level 2).

Report

kriko

11 years ago

Unable to open configuration window:
---
Traceback (most recent call last):
File "/home/kriko/.superkaramba/soundmania/currentver//sm_config.py", line 1197, in <module>
f = SoundMania_Configuration()
File "/home/kriko/.superkaramba/soundmania/currentver//sm_config.py", line 566, in __init__
self.languageChange()
File "/home/kriko/.superkaramba/soundmania/currentver//sm_config.py", line 698, in languageChange
wclosing = 0
self.buttonHelp.setAccel("F1")
TypeError: argument 1 of QButton.setAccel() has an invalid type
---

Report

14 years ago

3.90:
- New feature: PyQt4/KDE4 support and requirement
- Cleanup: Dropped PyKDE support, noatun and kaboodle players support
- New feature: Added Serbian translations
- Bugfix: Theme doesn't initialize when progressbar is not displayed.
- Bugfix: Bitrate hiding/reappearing mechanism doesn't work consistent.

3.0:
- Disabled text-scrolling for 64 bit systems because it caused a crash due to a bug in superkaramba

2.9:
- Bugfix: Cover from the track dir is not displayed if "download cover" option is unchecked.
- Bugfix: Config window does not open if the keyboard shortcuts cannot be assigned.
- Bugfix: Textshifts don't work properly. (still some work needs to be done)
- Bugfix: Next track info doesn't update correctly.
- Cleanup: Standardized button positions
- New feature: Option for keeping the aspect ratio of the album cover image.
- Cleanup: Upgraded to pytagger 0.5
- New feature: Introducing "Soundmania Grandeur"
- Bugfix: Exception function is called before it is defined, when PIL is not installed.
- Cleanup: Moved player modules to the "modules" directory.

2.8:
- Big cleanup in the code. More than half of it is rewritten. Got rid of a major number of global variables.
- Config window is reorganized.
- User can now determine the hierarchy of the players in the auto-select player mode.
- PyQt is required from now on.
- PIL or Imagemagick (one or the other) required from now on.
- Added new text and cover vanishing/reappearing effects.
- Configuration options are stored only in ~/.superkaramba/soundmania/config
- 2 different debug modes
- Upgraded the license to GPLv3


2.7.6:
- Bugfix: artist and title continuously checked when the player is idle, causing cpu spikes.
- Missing albumcover retrieval fixed.
- Text sizes are determined via pixel size rather than number of characters.
- Dropped BMP support.
- Added new background: MetCheck


See inside the package for the full Changelog

12345678910
product-maker Count:260 Rating: 6.42
File (click to download) Version Description Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
3.90
updated Sep 04 2008
added Feb 17 2005
downloads today
0
page views today 1