RGBA Gtk+ module

Various Gnome Stuff

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

2
Score 74%
Description:

Gtk+ module to activate RGBA in gtk apps.
Use it with Cimitan's murrine theme engine instead of patching applications.

Thanks to VMChaZ for help with debug.
http://home.kis.ru/~vmchaz

Installation
Just use PPA or (1) and (2)
1) Compile it:
gcc -fPIC -shared librgba.c -o librgba.so `pkg-config --cflags --libs gtk+-2.0`
2) Copy librgba.so to /usr/lib/gtk-2.0/modules.

3) Install Cimitan's murrine engine and themes for it
4) Activate RGBA:
- Open gnome-color-chooser
- go to "Engines" tab
- set "global" checkbox
- Choose "Murrine"
- Click preferences
- set 2 RGBA checkboxes
5)Add export GTK_MODULES=rgba to .profile
Set environment variable GTK_RGBA_APPS (usually add to .profile).
export GTK_RGBA_APPS= list of applications

GTK_RGBA_APPS variable
- set it to colon separated list of applications to activate rgba ONLY in these apps:
GTK_RGBA_APPS=gedit:app2:app3

- append "allbut" to start to activate rgba in ALL apps except listed:
GTK_RGBA_APPS=allbut:gedit:app2:app3

FAQ
Q: Some applications does not work. Is it bug?
A: It is Ok, and not bug of RGBA Gtk+ module.
Not all apps can use RGBA.
You SHOULD set up GTK_RGBA_APPS variable.
For example:
GTK_RGBA_APPS=gedit:gcacltool:gnome-help - Activate RGBA ONLY in gnome edit, gnome calculator and gnome help.
or
GTK_RGBA_APPS=allbut:gedit:gcacltool:gnome-help - Activate RGBA in ALL applications except listed.

P.S. Sorry for bad English.

Last changelog:

10 years ago

0.2
prints name of program to console when rgba activated.

0.1
first release

athremix

5 years ago

it's very nice , but how to install it in mate?

Report

juandejesuss

8 years ago

hehe first of all I want to congratulate you for this work you've done, I was trying to apply to my desktop and this is what I found:

http://img840.imageshack.us/img840/817/pantallazozb.png

as you can see "notification-area-applet" shows transparencies and "gnomenu" as well, overwritting gnome-panel's background, and dunno how to fix it properly.

I've found a file in /etc/profile.d named gtkrgba.sh where you have several lines of the exceptions, I tried to add "gnome-panel" or "notification-area-applet" but it didn't work, the area was being shown with a black background now


by the way, you should add "cheese" to your exception list, because didn't worked properly with rgba activated, after I added it to the .sh file, it worked like a charm

hope you can help me

thanks in advance for your patience

Report

juandejesuss

8 years ago

hey hello again

look I've fixed the bug I talked you about, that was because of my gtkrc settings hehe

but there's a couple of bugs that I can't fix

-on Firefox everytime I get on youtube, the videos are not visible, I just can hear audio...

-Tuxguitar doesn't work (already added that to the exception list on your file but doesn't work)


if you can help me I'd appreciate it a lot friend

look what I've achieved with your amazing .deb

http://img254.imageshack.us/img254/2863/pantallazoa.png
http://img42.imageshack.us/img42/328/pantallazo4f.png
http://img535.imageshack.us/img535/4159/pantallazo1gb.png

Report

N00bFor3v3r

8 years ago

Hey, i've deleted .profile, so there is no way to configure APP restrictions, plz can someone paste your own profile script, I'm n00b enought about this.

Report

tsujan

8 years ago

Add the contents of this file to the end of your "profile":

http://dl.dropbox.com/u/7793460/profile

Report

jarom004

8 years ago

so im running ubuntu 10.04 (don't know if that wil make a difference, but i added the PPA and i wasn't able to download all f the packages when i updated. . and i alos am not really sure how to do step 5 with the RGBA. . . i'm kinda new to all this. . any tips would be greatly appreciated

Report

jarom004

8 years ago

sorry i figured out the ppa but i don't understand how to "Add export GTK_MODULES=rgba to .profile" and the rest of number 5...im sorry if this is way obvious, but im new and still learning

Report

tsujan

8 years ago

I found that if "XLIB_SKIP_ARGB_VISUALS=1" is used before Firefox command, the above issue doesn't appear.

Report

tsujan

8 years ago

Flash 10.1 stopped working in Firefox 3.6.4 with gtk2-module-rgba, although both FF and exe are excluded. Audio is OK but there's no video. It works with RGBA disabled.

I think this issue is related to Flash and not FF because the standalone flash player has some problem too (it's also excluded from RGBA applications and works OK with RGBA disabled).

Report

zniavre

9 years ago

hello

i think the ppa murrine patched is too transparent

you should keep the regular murrine engine to be fully usable/readable


to change transparence level you should edit src/support.h file into murrine source (wich i still think cimi (murrine's dev) use the best values, and modify : /* Opacity settings */
and recompile murrine engine "normal" way

regards

Report

C

aleksey

9 years ago

I think we need a .gtkrc setting for transparency.
Someone should say about it to author of murrine.

Report

zniavre

9 years ago

http://www.cimitan.com/murrine/node/add/feature


you are welcome to ask


:o)

Report

C

aleksey

9 years ago

http://www.cimitan.com/murrine/node/204

Looks like Cimi not want this...

Report

algalord

9 years ago

exist any way to control the % of transparency?

Report

C

aleksey

9 years ago

No.Ask author of murrine theme engine for this.
Turn on blur in compiz settings, it will help read text on transparent parts of windows.

Report

algalord

9 years ago

I Ask because I don't have blur support for my ATI hd3200 video card.

Report

mucha

9 years ago

do you know where i can find that engine?

Report

Steh

9 years ago

http://www.gnome-look.org/content/show.php/Murrine+Engine+%28Ubuntu+Packages%29?content=99516

This is an unstable version with some cool new features, I'm using it and it works fine... Anyway just search Murrine in Synaptic to get the official Cimi release (if you're using Ubuntu, the engine is alredy installed, Human Murrine is a Murrine theme)

Report

VCoolio

9 years ago

Hi, thanks for your app, works nice. One thing bugs me though (I posted this at the murrine site too, but cimi made me aware of this being an issue with your module): the console output disables usage of zenity. Like this:
enter:
echo `zenity --entry`

if I type "blahblah" the output is:
progname=zenity; RGBA=on blahblah

Don't know what to change; I guess the code in the .c file on line 46 (printf ("\nprogname=%s; RGBA=on\n",progname);) should be different.

Report

VCoolio

9 years ago

Actually, if you change line 46 to

fprintf (stderr, "\nprogname=%s; RGBA=on\n",progname);

it seems to work.

Report

JotamanX

9 years ago

Amazing Job!!
it works fine

on archlinux just type: yaourt librgba-gtk-module

Report

lester2

10 years ago

...but I've already submitted here a similar one once http://www.linux.org.ru/view-message.jsp?msgid=2607191#2609315 Then Cimi came and asked me to remove the entry. He doesn't like an interference with his code. Hope you will succeed more then me.

Report

cimi86

10 years ago

That's true, but I'm considering the svn more stable to be used.
I still hope no .debs or similar will be published for this kind of thing: it is meant to be *testing-only*

Report

smif1984

10 years ago

test case:
exclude for instance rhythmbox using rgba in .profile file:

export GTK_MODULES=rgba
export GTK_RGBA_APPS=gedit

So the only application which should use rgba would be gedit.

Then open a terminal and type rhythmbox: the application could not start because it crashes.

I don't know where this comes from, it seems that it's ignoring the blacklist..

Report

C

aleksey

10 years ago

It is impossible.
export GTK_MODULES=rgba
export GTK_RGBA_APPS=gedit
rhythmbox
(rhythmbox:14393): Rhythmbox-WARNING **: Unable to start mDNS browsing: ?????? MDNS ?? ???????
(rhythmbox:14393): Rhythmbox-WARNING **: Unable to stop mDNS browsing: ?????? MDNS ?? ???????


rhythmbox works fine

Report

10 years ago

0.2
prints name of program to console when rgba activated.

0.1
first release

File (click to download) Version Description Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
0.2 .deb avaible
updated Feb 23 2010
added Mar 06 2009
downloads today
0
page views today 5