soniK

Audio Apps

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
7.4
Description:

soniK is an open source digital audio editor for Linux, using the KDE
platform. soniK allows you to record, edit and process sounds on your
computer.

soniK's main features include:
* Record & play audio using your computer's soundcard
* Visualise the audio as a waveform or a spectrogram
* Edit the audio and transform it with a wide variety of plugins
* Generate new sounds
Last changelog:

13 years ago

This is the 1.0.0 release. Changes since 1.0 beta2 are bug fixes.

BeteNoire

11 years ago

Knock, knock, are you alive, Sonik?
Last releas comes from 2 years back (11/06/2006) and there were promises to disable arts support in favor of ALSA and JACK.

Report

BorgQueen

12 years ago

soniK is faster (perhaps lighter?) and smoother. The audio file output is clean and clear.

This bug fix shows a lot of improvement. For example, I once had a lock up problem when selecting a new file in stereo but that has completely disappeared. While this lock up problem never occurred on Ark Linux or Knoppix, and only randomly on Vector Linux SOHO, it did appear on Debian 3.1, Fedora Core 4, and a couple of other apps. This is no longer the case as far as I can tell.

soniK ran smoothly no matter what distro it ran on (even when I tried to wreck it lol).

This puts SoniK up there with my fave (and hopefully soon to be a qt app) ReZound.

The Author should be proud!

Well done tenfoot!

Report

beroarklinux

12 years ago

We've just added this to Ark Linux. Ark Linux users just "apt-get update; apt-get install sonik" -- others in need of an rpm may try their luck with
http://arklinux.osuosl.org/dockyard-devel/SRPMS/sonik-1.0.0-1ark.src.rpm
http://arklinux.osuosl.org/dockyard-devel/i586/sonik-1.0.0-1ark.i586.rpm
http://arklinux.osuosl.org/dockyard-devel/i586/sonik-devel-1.0.0-1ark.i586.rpm

Report

djworld

13 years ago

I made a SUSE 10.1 RPM. It's available here:
http://www.polinux.upv.es/~vfernandez/suse/10.1/RPMs/i586/sonik-1.0.0-1polinux.i586.rpm

Report

djworld

12 years ago

The link has changed, it's here now:
http://www.polinux.upv.es/~vfernandez/suse/10.1/i586/sonik-1.0.0-1polinux.i586.rpm

There's more information here:
http://www.polinux.upv.es/~vfernandez/suse/10.1

Report

gohanz

13 years ago

A SlackWare TGz package with SlackBuild Script is Ready to DownLoad!!!

http://www.slacky.it/


http://www.slacky.it/index.php?option=com_remository&Itemid=29&func=fileinfo&id=1067

Report

bitcrazy

13 years ago

Hi,
I get the following error on configure:
configure: error: Your Installation isn't able to compile simple C++ programs.
Check config.log for details - if you're using a Linux distribution you might miss
a package named similiar to libstd++-dev.
error: Bad exit status from /var/tmp/rpm-tmp.21069 (%build)
I've libstdc++ and libstdc++-devel installed. Distro is SuSE 10.1. So, what's going wrong there?

Greetings

m0nk

Report

gohanz

13 years ago

A SlackWare TGz package with SlackBuild Script is Ready to DownLoad!!!

http://www.slacky.it/

http://www.slacky.it/index.php?option=com_remository&Itemid=1&func=fileinfo&filecatid=1085&parent=category

Report

bitcrazy

13 years ago

Hi,
trying to compile sonik gives me the following error:
then mv -f ".deps/libsonikpart_la.all_cpp.Tpo" ".deps/libsonikpart_la.all_cpp.Plo"; else rm -f ".deps/libsonikpart_la.all_cpp.Tpo"; exit 1; fi
editapplydialog.h:58: error: extra qualification ‘Sonik::EditApplyDialog::’ on member ‘createUi’
make[3]: *** [libsonikpart_la.all_cpp.lo] Error 1

System is SuSE 10.1 with KDE 3.5.2

Report

C

tenfoot

13 years ago

Sorry, small mistake in a header file. Try this patch:

http://sonik.sourceforge.net/patches/editapplydialog_build_fix.patch

Download it to the sonik source dir and apply it with:

patch -p0 < editapplydialog_build_fix.patch

Hope this helps

Rob

Report

fm1968

13 years ago

Hi, I tried to install it on a Slackware 10.2 with kernel-ide-2.4.31, kde 3.5.1 and qt-3.3.4, using this configure line:
./configure --prefix=/opt/kde --without-arts --disable-ladspa
but when I run it:
bash-3.00$ sonik
sonik: SonikApp: readConfig
sonik: Sonik::Display: normal
sonik: Sonik::Display: spectral
sonik: Sonik::Edit: amplify
sonik: Sonik::Edit: basicGenerator
sonik: Sonik::Edit: format
sonik: Sonik::Edit: reverse
sonik: Sonik::Edit: select
sonik: Sonik::FileIO: libaudiofile
sonik: Part::setupPlugins: disp 2, file 1, audio 0
ASSERT: "!empty()" in /usr/lib/qt/include/qvaluevector.h (375)
ERROR: Communication problem with sonik, it probably crashed.
bash-3.00$ KCrash: Application 'sonik' crashing...

Also, I noticed that --disable-ladspa was necessary, otherwise I would have gotten, and that freetype is a dependency

Report

C

tenfoot

13 years ago

Try this patch:

http://sonik.sourceforge.net/patches/no_audio_crash.patch

Download it to the sonik source dir and apply it with:

patch -p0 < no_audio_crash.patch

This should allow you to run sonik without arts installed. sonik only supports aRts output at the moment so you won't be able to play or record. There should be support for other sound systems (e.g. JACK) in 1.1, but it's not done yet.

I'd also advise you to install the ladspa headers and plugins as these are what make sonik useful, providing filtering, distortion, delays and other effects.

Hope this helps

Rob

Report

BorgQueen

13 years ago

The version still hangs when I choose "Edit New File". Completely freezes.

Report

C

tenfoot

13 years ago

These issues should have been resolved in 1.0 beta2

Report

ATAHUALPA

13 years ago

* Record & play audio using your computer's soundcard

Personaly I not use arts, I have not installed it, so it can possible make this apps able to use directly ALSA system?

Report

C

tenfoot

13 years ago

arts is the only sound system supported at the moment. soniK's plugin architecture makes it easy to add new sound systems such as alsa or jack, but I haven't got round to writing these yet (contributions welcome!).

In the next beta I'll make it so that soniK can be compiled without arts (--without-arts option to configure). Until then, I'll add arts as a requirement on the sonik website.

Report

kdeappsce

13 years ago

arts will die soon. ALSA and JACK are the things to go for modern apps. Support for both would be very cool. ALSA for the desktop users, JACK for the (semi)professionals.

Didn't try it (not using arts) but anyway, cool idea: Thanks for the work!

Report

BorgQueen

13 years ago

For the most part, its a really good app but when I try to create an new audio project it just hangs.
Everything else seems to work very well. Over all I like it.

Let me know if you need any info to trace the bug. System info: Debian 3.1 / KDE 3.3.2

Report

C

tenfoot

13 years ago

These issues should have been resolved in 1.0 beta2

Report

13 years ago

This is the 1.0.0 release. Changes since 1.0 beta2 are bug fixes.

12345678910
product-maker Count:56 Rating: 7.36
File (click to download) Version Description PackagetypeArchitectureRelease Channel Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
1.0.0
updated Jun 11 2006
added Jan 30 2006
downloads today
0
page views today 4