Lphoto

Graphic Apps

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
5.0
Description:

This is a Photo Library program from Linspire. They developed it for their Linspire Linux Desktop, and then released it under the GNU/GPL. They make it hard to find the source code for this, and try to get you to pay for the program instead. I found the links and wanted to share them with everyone. This is a pretty neat program, the only drawback is that the path where it saves your photos is hardcoded into the program. I modified this for myself, maybe someone could add a dialog box for this to make it configurable. The best part is that is ha an option to turn your photo libraries into (S)VCD and sets them to your favorite music. Very cool!

I run this on SuSE - 9.2 with no problems.

To install just type "python install.py" as root. It is that easy!

steff

14 years ago

What's this?
What can I do?

stw@linux:~> lphoto
Traceback (most recent call last):
File "/usr/lib/python2.3/site-packages/Lphoto/lphoto.py", line 20, in ?
from glshow import *
File "/usr/lib/python2.3/site-packages/Lphoto/glshow.py", line 3, in ?
from OpenGL.GL import *
ImportError: No module named OpenGL.GL
stw@linux:~>

First i have installed "kdebindings3-python" and "python-opengl-2.0.1"

Running SuSE 9.2

Report

ioannisss

14 years ago

What's this?
What can I do?
ioannisss@ioannisss:~/bin/lphoto-2.0.42> lphoto
Traceback (most recent call last):
File "/usr/lib/python2.3/site-packages/Lphoto/lphoto.py", line 3, in ?
from kdeemul import *
File "/usr/lib/python2.3/site-packages/Lphoto/kdeemul.py", line 6, in ?
from kdecore import *
ImportError: No module named kdecore
ioannisss@ioannisss:~/bin/lphoto-2.0.42>
Running SuSE 9.2

Report

C

tommycw1

14 years ago

Install kdebindings-python with YaST

Report

uga

14 years ago

.

Report

uga

14 years ago

it built just fine with the latest pyQt bindings, but it crashes on me when trying to use the xine arts output plugin. Shame, I liked the app!

Report

uga

14 years ago

ignore this bugreport. It refers to LSongs ;)

Report

linux3114a

14 years ago

Having installed the RPM giving by Joephine
or installed via python install.py wihout problem.

When starting lphoto nothinh occurs Strange

Report

Phemt

14 years ago

in gentoo the package has been installed fine as well as python and pyqt but when i exec it i get:
Traceback (most recent call last):
File "/usr/lib/python2.3/site-packages/Lphoto/lphoto.py", line 3, in?
from kdeemul import *
File "/usr/lib/python2.3/site-packages/Lphoto/kdeemul.py", line 6, in ?
from kdecore import *
ImportError: No module named kdecore

Report

Josephine_double

14 years ago

Do you have kdelibs3 installed?

Report

Phemt

14 years ago

sure...i built kdelibs from sources with gentoo (emerge kdelibs)

Report

Josephine_double

14 years ago

Binary of Lphoto 2.0.42 is available here:
http://jk.allsoft.ro/92/lphoto-2.0.42-1.i586.rpm

Report

C

tommycw1

14 years ago

Thanks for the Binaries for Lphoto and Lsongs. I uploaded the RPM for Lphoto to KDE-apps. I figured that I would save you some bandwidth. Unfortunately, the RPM for Lsongs was too big to be uploaded. There is a 500kB limit.

Do you have rpms for pyxine and pyid3lib? I could not find them anywhere, and I think that people may want them.

Report

Josephine_double

14 years ago

pyxine and pyid3lib are available either via apt from my repository (rpm http://jk.dordetara.ro/ SuSE/9.2-i586 jk) either browsing it manually at http://jk.dordetara.ro/SuSE/9.2-i586/RPMS.jk/

Report

Josephine_double

14 years ago

pyxine and pyid3lib are available either via apt from my repository (rpm http://jk.dordetara.ro/ SuSE/9.2-i586 jk) either browsing it manually at http://jk.dordetara.ro/SuSE/9.2-i586/RPMS.jk/

Report

linux3114a

14 years ago

Ok for your RPM but cannot install because PyQt packages needed as dependencies for this RPM ..
I don't find PyQt for Suse 9.2
Thanks for your Rpm

Report

Josephine_double

14 years ago

In Suse, PyQt can be found in kdebindings3-python 3.3.2-3. If you have apt (and i strongly recommend the use of it), you can just type: apt-get install PyQt.

Report

linux3114a

14 years ago

A big Thank Josephine
Ok I can install this RPM

Report

linux3114a

14 years ago

raoul@linux:~/work/lphoto-2.0.42> sudo python install.py
Password:
Traceback (most recent call last):
File "install.py", line 17, in ?
import distutils.sysconfig
ImportError: No module named distutils.sysconfig
raoul@linux:~/work/lphoto-2.0.42>


I run with a Suse 9.2

Report

linux3114a

14 years ago

Previous error solved by installing Python-devel.
Now I need PyQt packages but don't find these packages in my suse 9.2 distribution ( CD1-5 )

Where can I found its?

Report

matt2002

14 years ago

it's in kdebindings-python

Report

TimLinux

14 years ago

su -c "python install.py "
Password:
Traceback (most recent call last):
File "install.py", line 17, in ?
import distutils.sysconfig
ImportError: No module named distutils.sysconfig

Report

ViRgiLiO

14 years ago

It's better.

Report

fab

14 years ago

or GNOME (also said to be better) [1]

Fab

[1] Choice is good

Report

Exigentsky

14 years ago

It would help if it was more obvious that it's free for everyone. The first download link indicates that the software costs $19.95, but if one scrolls down there are links to the dsc and tarball packages for no cost.

While the price may be intended to show how the software would be priced comparatively or how much it costs for Linspire users, that should be made more clear.

Otherwise, this is really good and easy to use, but somewhat underpowered software.

Thank you!

Report

12345678910
product-maker Count: 4 Rating: 5.0
File (click to download) Version Description PackagetypeArchitectureRelease Channel Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
2.0.42
updated Jan 24 2005
added Jan 23 2005
downloads today
0
page views today 4
System Tags app software