eggy

Developers Apps

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

3
7.4
Description:

Eggy is an IDE/editor for UNIX. Eggy has syntax highlighting, template features, options for compiling and running your code, auto completion/indentation and lots more. Eggy also supports group projects in which you can see live changes being made by others.

Eggy currently supports the following languages: Python, Java, C/C++, D, Perl, Ruby, VHDL, shell scripting, web development (HTML, JavaScript, XML, CSS) and SQL.

Last changelog:

11 years ago

- support for xml
- fixed settings lineup
- automatically fill in project and package from new file created from the project tree

derula

9 years ago

Hi, I get a "memory access error" when starting. No further information is given. Just

linux-00ip:~> ./eggy.py
Speicherzugriffsfehler
linux-00ip:~>

I'm on openSUSE 11.1 but using Qt 4.5, and a pyqt 4.5 snapshot (downgrading to pyqt 4.4 doesn't help; same error).

Also, the website at http://eggy.student.utwente.nl/ seems to be down.

Report

vrjeala

10 years ago

Extremely nice ide, pleasant to the eye and to work with. I'm using it to play with ruby.
Question: Do you have any plans on integrating some rails features?
Ex: rails projects, rake tasks, generators
thx and once again great job!

Report

C

eggy

10 years ago

Thanks, glad you like it :-). I'm sorry though, for I have no such plans.

Report

andersos

11 years ago

Interesting IDE. But when I try to run it I get error :

File "./eggy.py", line 61, in ?
gui = Model(base, appname, email, website)
File "/mnt/home/source/python/pyqt/eggy/model/Model.py", line 147, in __init__
File "/mnt/home/source/python/pyqt/eggy/gui/MainWindow.py", line 56, in __init__
File "/mnt/home/source/python/pyqt/eggy/gui/MainWindow.py", line 390, in _createEditors
File "/mnt/home/source/python/pyqt/eggy/model/Model.py", line 336, in _fileNew
File "/mnt/home/source/python/pyqt/eggy/model/Model.py", line 314, in _fileAddOpenFile
File "/mnt/home/source/python/pyqt/eggy/model/Model.py", line 1409, in tabChanged
File "/mnt/home/source/python/pyqt/eggy/model/Model.py", line 1377, in _projectGetCurrentInfo
TypeError: expected a character buffer object

What could it be? I installed all dependencies. I'm on Debian lenny.

Report

C

eggy

11 years ago

Thank you for your comment! I really appreciate feedback. I'm was so stupid as to provide the .pyc bytecode files in the tarball, I forgot to remove them. The new tarballs on the website are correct. You could also do, in th eggy directory: rm *.pyc */*.pyc
Please let me know if this solves your problem.

Apologies for the inconvenience.

Report

andersos

11 years ago

I tried both to remove *.pyc and get newer tarball. Still get error :

File "./eggy.py", line 61, in ?
gui = Model(base, appname, email, website)
File "/home/andersos/eggy-0.1/model/Model.py", line 147, in __init__
super(Model, self).__init__()
File "/home/andersos/eggy-0.1/gui/MainWindow.py", line 56, in __init__
self._createEditors()
File "/home/andersos/eggy-0.1/gui/MainWindow.py", line 390, in _createEditors
self._fileNew()
File "/home/andersos/eggy-0.1/model/Model.py", line 336, in _fileNew
self._fileAddOpenFile(name, editor, True)
File "/home/andersos/eggy-0.1/model/Model.py", line 314, in _fileAddOpenFile
self.tabChanged(self.editorTabWidget.currentIndex())
File "/home/andersos/eggy-0.1/model/Model.py", line 1409, in tabChanged
project, package, filename = self._projectGetCurrentInfo()
File "/home/andersos/eggy-0.1/model/Model.py", line 1377, in _projectGetCurrentInfo
project = filename.replace(self.projectDir, "").split("/")[0]
TypeError: expected a character buffer object

Report

C

eggy

11 years ago

I placed new tarballs on the website. This time eggy should start, if not, I derserve to be shot.

Report

andersos

11 years ago

Yes! New one worked no problem. Thanks!!

Report

C

eggy

11 years ago

Another person also had this problem at first, and when he removed the files (rm *.pyc */*.pyc) the problem was solved. I have also tested it and it seems to work for me too. Are you absolutely sure that there are no .pyc files left somewhere? does find . -iname "*.pyc" return no result? I sure hope some .pyc files were left, because I cannot seem to reproduce this error.

Report

C

eggy

11 years ago

Another person also had this problem at first, and when he removed the files (rm *.pyc */*.pyc) the problem was solved. I have also tested it and it seems to work for me too. Are you absolutely sure that there are no .pyc files left somewhere? does find . -iname "*.pyc" return no result? I sure hope some .pyc files were left, because I cannot seem to reproduce this error.

Report

andersos

11 years ago

I tried both to remove *.pyc and get newer tarball. Still get error :

File "./eggy.py", line 61, in ?
gui = Model(base, appname, email, website)
File "/home/andersos/eggy-0.1/model/Model.py", line 147, in __init__
super(Model, self).__init__()
File "/home/andersos/eggy-0.1/gui/MainWindow.py", line 56, in __init__
self._createEditors()
File "/home/andersos/eggy-0.1/gui/MainWindow.py", line 390, in _createEditors
self._fileNew()
File "/home/andersos/eggy-0.1/model/Model.py", line 336, in _fileNew
self._fileAddOpenFile(name, editor, True)
File "/home/andersos/eggy-0.1/model/Model.py", line 314, in _fileAddOpenFile
self.tabChanged(self.editorTabWidget.currentIndex())
File "/home/andersos/eggy-0.1/model/Model.py", line 1409, in tabChanged
project, package, filename = self._projectGetCurrentInfo()
File "/home/andersos/eggy-0.1/model/Model.py", line 1377, in _projectGetCurrentInfo
project = filename.replace(self.projectDir, "").split("/")[0]
TypeError: expected a character buffer object

Report

11 years ago

- support for xml
- fixed settings lineup
- automatically fill in project and package from new file created from the project tree

12345678910
product-maker Count:26 Rating: 7.38
File (click to download) Version Description PackagetypeArchitectureRelease Channel Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
0.3.2
updated Apr 07 2009
added Mar 25 2008
downloads today
0
page views today 1
System Tags app software