kconfigure

Developers Apps

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
7.1
Description:

Kconfigure simplifies compiling and installing software by providing a graphical interface.

Easy to use, just click the configure file in Konqueror and then configure, make and install the sources within kconfigure easy to use GUI. You can also pass configure and build arguments, log your install progress, and even use checkinstall to build (and install) rpm/slack/deb packages.
Last changelog:

14 years ago

*Update: Added a src.rpm package. Please let me know if you create a package for a given distribution.

Version 2.1 includes
Added:
- Custom checkinstall options.
- Qmake support.
- Switched to a build install selector (instead of multiple install buttons.)
- bzip files are now supported.

Fixed:
- A bug that kept checkinstall and make install from working on Suse Linux.
- A bug in the configure help system that kept any help info from loading into the dialog, thus making Configure Help worthless.
- Dozens of other minor bugs.

gnemmi

14 years ago

seems like a fine soft (interesting at least...)
but it needs qt3.3 doesn't it?
I'm still on 3.2.3 =/

Report

C

brockers

14 years ago

It should not. I used the kde 3.3 autoconfig build setup stuff in kdevelop but it should still work on other versions of kde 3.x. I will try it on another machine tonight and see if I can get it working.

Bobby

Report

gnemmi

14 years ago

just in case:
[gnemmi@hellraiser gnemmi]$ locate libqt-mt
/usr/lib/qt3/lib/libqt-mt.so.3
/usr/lib/qt3/lib/libqt-mt.prl
/usr/lib/qt3/lib/libqt-mt.la
/usr/lib/qt3/lib/libqt-mt.so
/usr/lib/qt3/lib/libqt-mt.so.3.2.3
/usr/lib/qt3/lib/libqt-mt.so.3.2
[gnemmi@hellraiser gnemmi]$ rpm -qf /usr/lib/qt3/lib/libqt-mt.so.3.2.3
qt3-3.2.3-55982cl
[gnemmi@hellraiser gnemmi]$

Report

C

brockers

14 years ago

I have successfully got it installed on kde 3.2.1 on Suse 9.1. What distro and what version of kde are you running?

Bobby

Report

gnemmi

14 years ago

[gnemmi@hellraiser gnemmi]$ cat /etc/conectiva-release
Conectiva Linux 10
[gnemmi@hellraiser gnemmi]$ rpm -qa | grep kdebase
kdebase-3.2.3-63233cl
[gnemmi@hellraiser gnemmi]$ rpm -qa | grep kdelibs
kdelibs3-3.2.3-63232cl

everything compiles ok (I've succesfully packaged kasablanca, krusader, kcheckgmail, baghira, comix, galaxy, etc..). This is the first app that complains about my qt/qtlibs version :(

Report

C

brockers

14 years ago

gnemmi, my email address is available in the AUTHORS file within the kconfigure source. Send me an email and I *will find a way* to get you running.

Bobby

Report

C

brockers

14 years ago

Try this for me:

./configure --disable-mt
make && makeinstall

Bobby

Report

gnemmi

14 years ago

[gnemmi@hellraiser kconfigure-2.0]$ ./configure --disable-mt

bla bla bla...

checking for Qt... configure: error: Qt (>= Qt 3.3) (library qt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
[gnemmi@hellraiser kconfigure-2.0]$

:(

Report

gbN00b

14 years ago

you could create symbolic links in /usr/lib to all those or just copy them to /usr/lib.

great utility!! just installed it tonite and have already found it very valuable. thanx.

Report

gnemmi

14 years ago

according to the ./configure:

checking for Qt... configure: error: Qt (>= Qt 3.3) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!
error: Bad exit status from /home/gnemmi/paquetes/kconfigure/BUILDROOT/rpm-tmp.99506 (%build)


RPM build errors:
Bad exit status from /home/gnemmi/paquetes/kconfigure/BUILDROOT/rpm-tmp.99506 (%build)

Report

vernr

14 years ago

Pretty basic error. You probably haven't installed qt3-devel files. They will need to match the qt3 version you have installed on your system.

Report

gnemmi

14 years ago

basically if it where so basic, i basically wouldn't post it :P

[gnemmi@hellraiser gnemmi]$ rpm -qa | grep qt3 | sort
qt3-3.2.3-55982cl
qt3-assistant-lib-3.2.3-55982cl
qt3-designer-lib-3.2.3-55982cl
qt3-devel-3.2.3-55982cl
[gnemmi@hellraiser gnemmi]$

Report

14 years ago

*Update: Added a src.rpm package. Please let me know if you create a package for a given distribution.

Version 2.1 includes
Added:
- Custom checkinstall options.
- Qmake support.
- Switched to a build install selector (instead of multiple install buttons.)
- bzip files are now supported.

Fixed:
- A bug that kept checkinstall and make install from working on Suse Linux.
- A bug in the configure help system that kept any help info from loading into the dialog, thus making Configure Help worthless.
- Dozens of other minor bugs.

12345678910
product-maker Count:111 Rating: 7.05
File (click to download) Version Description PackagetypeArchitectureRelease Channel Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
2.1
updated Mar 16 2005
added Oct 20 2004
downloads today
0
page views today 4
System Tags app software
+