Beryl on Debian GNU Linux Testing

Utilities

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
Score 68%
Description:

This is a script which will install Beryl and possibly nVidia or ATI drivers on your Debian TESTING system.

Languages available:
- French
- English
- Polish
- German thanks to Armin
- Romanian thanks to Andersonian
You can send me your translations by e-mail.

HOW TO EXECUTE:
Open a terminal and do sh beryl-debian.sh

NOTE: I had confirmation that Beryl works fine with the fglrx driver. Thanks to István Szöcs for his mail ;)

Last changelog:

12 years ago

v 1.1.6: Add possibility to install Heliodor if you use GNOME
You can see the countdown at the beginning.
v 1.1.5: new language: Romanian
v 1.1.4: new language : German
v 1.1.3: Add possibility to install aquamarine if you use KDE.
v 1.1.2: Beryl packages are now downloaded from a debian repository with apt.
v 1.1.1: ask user if he want to install drivers
v 1.1.0: add choice between ATI or nVidia drivers
ask user if he want to update his system
-----------------------------
v 1.0.7: add ppc Beryl packages
fixed dependencies for Beryl packages
v 1.0.6: update i386 Beryl packages to 0.1.5
v 1.0.5: edition of xorg.conf with gedit or kwrite
v 1.0.4: new language: Polish
v 1.0.3: new language: English
v 1.0.2: choice between i386 and amd64 packages
v 1.0.1: delete all installation files
packages are downloaded from my ftp
v 1.0.0: initial release

Andersonian

12 years ago

To all Romanians out there: I just added the Romanian translation.

It's funny though, that if you can read and understand this, it means you don't actually need it :)

Report

Belisarivs

12 years ago

I had a brief look at that script and I don't see XGL to be downloaded. I'm looking for XGL deb for Testing (to make Beryl working on GF 2 MX). Where should I look?

Report

gecko

12 years ago

Why is it not for ATI or grafics card independent?

Report

seraphyn

12 years ago

you change the System to SID.
Beryl and components works in Etch, too, without any problems. Take a look on it, i think it would be nice to have somthing for Etch, and it will be nice to switch your gnome relatet code to KDE ;)
beryl wirh emerald works fine in KDE in Etch, too.

Keep up the good work you're on the right way imo.

seraphyn

Report

pinotree

12 years ago

What does it have to do with kde-apps.org?

It's a taylored shell script for a specific distro, and the only interaction with the user is donw using a GNOME application.

Report

zvonSully

12 years ago

the screen shot is from a GNOME desktop !

Report

samexner

11 years ago

um... no you dont
look closer... thats KDE.. you can see kicker

Report

zvonSully

11 years ago

second screenshot

Report

C

mateusz93

11 years ago

Yes I changed it :)

Report

12 years ago

v 1.1.6: Add possibility to install Heliodor if you use GNOME
You can see the countdown at the beginning.
v 1.1.5: new language: Romanian
v 1.1.4: new language : German
v 1.1.3: Add possibility to install aquamarine if you use KDE.
v 1.1.2: Beryl packages are now downloaded from a debian repository with apt.
v 1.1.1: ask user if he want to install drivers
v 1.1.0: add choice between ATI or nVidia drivers
ask user if he want to update his system
-----------------------------
v 1.0.7: add ppc Beryl packages
fixed dependencies for Beryl packages
v 1.0.6: update i386 Beryl packages to 0.1.5
v 1.0.5: edition of xorg.conf with gedit or kwrite
v 1.0.4: new language: Polish
v 1.0.3: new language: English
v 1.0.2: choice between i386 and amd64 packages
v 1.0.1: delete all installation files
packages are downloaded from my ftp
v 1.0.0: initial release

product-maker 44 97

File (click to download) Version Description PackagetypeArchitecture Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
1.1.6
updated May 20 2007
added Jan 17 2007
downloads today
0
page views today 1
System Tags app software