Kopete Antispam Plugin

Chat & Messenging

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

7
Score 84%
Description:

Kopete Antispam Plugin helps to protect kopete messenger from various spammers by using simple answer/question scheme:

Potential spammers receive a simple question, and they are ignored until they answers question.

Both KDE3 and KDE4 versions are available, see downloads.

Compilation:

To compile plugin you need a kopete shared library. In Debian and Ubuntu Karmic it's libkopete-dev package, in older Ubuntu - kdenetwork-dev, in openSUSE - kopete-devel.

KDE3 version uses autotools, to install you need:

./configure
make
sudo make install

KDE4 version uses CMake, so you need:

cmake -DCMAKE_INSTALL_PREFIX=/usr .
make
sudo make install

Where /usr prefix is for Debian/Ubuntu, for other distributions it may vary.

PPA for Karmic available: https://launchpad.net/~alexey-noskov/+archive/kde

Last changelog:

10 years ago

Version 0.5:

- Multiple answers support, patterns in answers
- Fixes in contact deleting in KDE 4.2

Version 0.4:

- Ability to ignore all unknown contacts.
- Ability to remove contacts failed test.

Big thanks to Richard Donkin (aka Cato here) for his patch!

Version 0.3 KDE4:

- KDE4 port, using CMake for building plugin.

Version 0.3:

- Added white list, containing wildcards: if some wildcards matches contact no test needed for him.
- Added notification about passing test: when some contact passes test, it receives message about it.

joergm2706

8 years ago

Thanks for it. Installation was no problem under ubuntu, but therefore it is necessary first to install cmake - this isn't preinstalled per default.

Report

sarbash

8 years ago

Реквестирую фильтрацию запросов авторизации.
Спасибо.

Ask for authorization requests filtration.
Thanks.

Report

swiftscythe

8 years ago

I've compiled it, installed and enabled in arch linux, but it doesn't ask a question to people who start chatting with me... Is it still working? I've tested on the msn network.

Thanks in advance!

Report

C

alno

9 years ago

If in Ubuntu Karmic you get something as "Phonon library or includes NOT found!" try to reinstall "libqt4-phonon-dev" package.

Report

xwild

9 years ago

If you get the following error: "
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found. Please set CMAKE_CXX_COMPILER to a valid compiler path or name."

Try to install "lsb-cxx" package.

kubuntu 9.10 (karmic)
Linux xwild 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:05:01 UTC 2009 x86_64 GNU/Linux

Report

pippo73

9 years ago

I've had a kopete crash and the kde member told me that it is due the Kopete Antispam Plugin.

The bug is the following

http://bugs.kde.org/show_bug.cgi?id=213095

Could you take a look at it?

Tnx

leo

Report

C

alno

9 years ago

Oh... Sorry for a long answer..

I'll try to fix it in nearly time.

Report

pippo73

9 years ago

Hi,

I'm trying to install your plugin on a Karmik Koala box but I get the following error:

-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.5.2 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Phonon includes NOT found!
CMake Error at /usr/share/kde4/apps/cmake/modules/FindPhonon.cmake:63 (message):
Phonon library or includes NOT found!
Call Stack (most recent call first):
/usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:559 (find_package)
/usr/share/cmake-2.6/Modules/FindKDE4.cmake:81 (FIND_PACKAGE)
CMakeLists.txt:3 (find_package)


-- Configuring incomplete, errors occurred!
=========================

libqt4-phonon-dev and libphonon-dev are installed on my system and also kdenetwork-dev which now is called libkopete-dev

Any idea how to fix it?

tnx

Report

pippo73

9 years ago

I fixed the problem tnx to this 3d
http://bugs.launchpad.net/ubuntu/+source/cmake/+bug/386742

Just resintall libqt4-phonon-dev package

and good antispam to everybody ;)

Leo

Report

overmind88

9 years ago

can you add descent support for gettext translatioins?

потому что нынешний русский первод сильно выбивается из перевода остального кде :)

Report

StirlitzKyrlitz

9 years ago

http://download.ubuntu.pl/_Karmic_Koala_/kopete/

Report

Pollywog

9 years ago

The previous version of the plugin worked, but although the *.so files are in the correct place with the newer version (0.5), Kopete (Ubuntu Jaunty) does not see the plugin. Perhaps I still have the older version so I can go back to it.

Report

Pollywog

9 years ago

Nevermind. After a reboot, it works.

Report

pippo73

9 years ago

For those like me using kubuntu 9.04,
the right way to compile it is:

$ cmake -DCMAKE_INSTALL_PREFIX=/usr .
$ make
$ sudo make install

my 2 cents... :)

Report

Pollywog

10 years ago

I am unable to compile in KDE 4.2 (ubuntu Jaunty) because make complains it cannot find the Kopete libraries. I am using cmake but it is the 'make' step that fails.

I am using this plugin also in KDE3 where it seems to stop the auth spams.

Report

Pollywog

10 years ago

I visited the homepage for the plugin and in the FAQ, I found the information I needed to compile the plugin in Ubuntu Intrepid and Ubuntu Jaunty. I believe this plugin even stops authorization spam sent through the ICQ server, something I have been unable to do until now.

thanks for the plugin.

Report

Sagittarius

10 years ago

So thank you very much.

Report

Chain

10 years ago

Do you know by any chance why it doesn't work, and how I can fix it? I am trying to compile against KDE4-trunk.

Linking CXX shared module lib/kopete_antispam.so
Undefined symbols:
"QObject::childEvent(QChildEvent*)", referenced from:
vtable for KopeteAntispamPluginin kopete_antispam_automoc.o
vtable for KopeteAntispamPluginFactoryin kopeteantispamplugin.o
vtable for KopeteAntispamConfigin kopeteantispamconfig.o

Report

C

alno

10 years ago

It was a bug in CMakeLists.txt file.

Now it's fixed, thanks to Gentoo Team Ru.
You may download fixed source.

Report

Chain

10 years ago

Thanks it works like a charm now, using KDE 4.2.0 now.

Report

C

alno

10 years ago

It looks like it can't find some Qt symbols.

Please send me output of cmake and make commands.

Report

Cato

10 years ago

I've written a patch for Kopete Antispam v0.3, tested on KDE 3.5.8 (but should work on any KDE 3.x version I think).

It defines anyone not in your contact list as a spammer, which is a bit harsh perhaps but helps avoid the problem of spammers appearing in your temporary contacts list. For people who don't often add contacts it's a good solution to Kopete spam, though it doesn't stop someone adding you to their contacts list and you then getting a message to authorise this.


To download the patch, see
https://sourceforge.net/tracker/?func=detail&atid=1076376&aid=2333222&group_id=229210

I've also passed this to Alexey Noskov, so it can go into the main plugin in some form.

Report

uteck

10 years ago

I installed this on CentOS5.2 with the RPM and it went in fine, but when I enable the plugin it says it can't fine libpcreposix.so.3. I have Pcre installed which seems to be package that provides the library.

Report

pippo73

10 years ago

Hi all,
I'm trying to install this plugin on my kubuntu platform.

I start with

cmake -DCMAKE_INSTALL_PREFIX=/usr /lib/kde4/ .

and this goes well but when I run the make command I get the following error.


$ make
[...SNIP...]
[ 55%] Building CXX object CMakeFiles/kcm_kopete_antispam.dir/kopeteantispamconfig.o
Linking CXX shared module lib/kcm_kopete_antispam.so
/usr/bin/ld: cannot find -lkopete
collect2: ld returned 1 exit status
make[2]: *** [lib/kcm_kopete_antispam.so] Error 1
make[1]: *** [CMakeFiles/kcm_kopete_antispam.dir/all] Error 2
make: *** [all] Error 2


Could you help me pls

Report

C

alno

10 years ago

Did you install kdenetwork-dev-kde4 package?

Try it, if no.

Report

10 years ago

Version 0.5:

- Multiple answers support, patterns in answers
- Fixes in contact deleting in KDE 4.2

Version 0.4:

- Ability to ignore all unknown contacts.
- Ability to remove contacts failed test.

Big thanks to Richard Donkin (aka Cato here) for his patch!

Version 0.3 KDE4:

- KDE4 port, using CMake for building plugin.

Version 0.3:

- Added white list, containing wildcards: if some wildcards matches contact no test needed for him.
- Added notification about passing test: when some contact passes test, it receives message about it.

product-maker aspotashev Jun 10 2011

product-maker 14 92

File (click to download) Version Description PackagetypeArchitecture Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
0.5
updated Dec 27 2009
added Jun 09 2008
downloads today
0
page views today 5
System Tags app software