Description:

awesome-widgets (ex-pytextmonitor)

PLASMA 5 COMPATIBLE

LOOKING FOR TRANSLATORS! (see https://github.com/arcan1s/awesome-widgets/issues/14)

A collection of minimalistic widgets which looks like Awesome Window Manager widgets.

Features
* easy and fully configurable native Plasma widget which may be used as Conky widget or as Awesome-like information panel
* panel which shows active desktop status
* clear Conky-like configuration with html tags support
* custom command support (it may be simple action as well as special custom tag)
* graphical item support - tooltips, bars

See links for more details.

Didn't find required feature? Just ask for it!

Installation
tar xJf awesome-widgets-3.3.1-src.tar.xz
mkdir awesome-widgets/build && cd awesome-widgets/build
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ../
make && sudo make install
NOTE on Plasma 5 it may require -DKDE_INSTALL_USE_QT_SYS_PATHS=ON flag

Dependencies
* plasma-framework

Optional dependencies
* proprietary video driver
* hddtemp (make sure that it may be run without password)
* smartmontools (make sure that it may be run without password)
* music player (mpd or MPRIS supported)

Make dependencies
* cmake
* extra-cmake-modules

Links
* Homepage https://arcanis.me/projects/awesome-widgets/
* Migration to 2.* https://arcanis.me/en/2014/09/04/migration-to-v2/
* Extensions https://arcanis.me/en/2014/12/19/aw-v21-bells-and-whistles/
* Formatters and macros https://arcanis.me/en/2016/06/05/aw-formatters-and-macros/

Tigerpaper

1 year ago

Hi there,

I cannot build with the sources for the version 2.4.0 under kubunutu 16.04, with qt 5.5.1.
Cmake commande seems to work, with the following command:
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DKDE_INSTALL_USE_QT_SYS_PATHS=ON ../sources/

However, the make command doesn't work and give me this :

[...]
[ 53%] Built target awesomewidgets
Scanning dependencies of target plasma_dataengine_extsysmon_automoc
[ 55%] Generating plasma-dataengine-extsysmon.json
Unknown property type for key "X-Plasma-EngineName" -> falling back to string
Generated "/home/raphael/Code/awesome-widgets-release-2.4.0/build/extsysmon/plasma-dataengine-extsysmon.json"
[ 56%] Automatic moc for target plasma_dataengine_extsysmon
Generating extsysmon.moc
Generating moc_extsysmon.cpp
[ 56%] Built target plasma_dataengine_extsysmon_automoc
make[2]: *** Aucune règle pour fabriquer la cible « /home/raphael/Code/awesome-widgets-release-2.4.0/sources/3rdparty/task/task.h », nécessaire pour « extsysmon/__/3rdparty/task/moc_task.cpp ». Arrêt.
CMakeFiles/Makefile2:207 : la recette pour la cible « extsysmon/CMakeFiles/plasma_dataengine_extsysmon.dir/all » a échouée
make[1]: *** [extsysmon/CMakeFiles/plasma_dataengine_extsysmon.dir/all] Erreur 2
Makefile:138 : la recette pour la cible « all » a échouée
make: *** [all] Error 2

(Sorry for french locale)
So: Is there something I can do to make it compile?

Report

C

arcanis

1 year ago

just have two questions:

1. Why did you use old version (actual one is 3.*)?
2. What is the your plasmashell version?

Report

Tigerpaper

1 year ago

1. Because apparently, build with 3.x is impossible, due to 16.04 not having qt 5.6 but 5.5 instead.
2. Plasmashell 5.5.5

Report

C

arcanis

1 year ago

sorry, missed your comment.

First of all I should note that I officially provide:
a) patches for old qt version (may be found in directory patches with quick instruction how to use it)
b) I provide Ubuntu 16.04 compiled packages for some time (at least they work on Kubuntu versions)

Regarding to your issue. I've looked one more time on your error and it seems to be related to one old component which is not used anymore. Probably I may provide you patch if you wish, but I would recommend you use the newest versions instead :)

Report

Tigerpaper

1 year ago

Thanks, it works nicely now!

Report

paviluf

2 years ago

Hello,

I can't make it work on Netrunner 16 (Kubuntu 15.04 derivative)

I followed the instructions but I have this error:

Could not find a package configuration file provided by "Qt5" with any of the following names:

Qt5Config.cmake
qt5-config.cmake

I tried with -DKDE_INSTALL_USE_QT_SYS_PATHS=ON but that don't work too

Report

paviluf

2 years ago

I make it works. It needed to install this :

$ sudo apt-get install cmake extra-cmake-modules build-essential qtbase5-dev libkf5windowsystem-dev libkf5service-dev plasma-framework-dev qtdeclarative5-dev libkf5notifications-dev

Report

pyrforos

2 years ago

when i run sensors
i get
Quote:
atk0110-acpi-0
Adapter: ACPI interface
Vcore Voltage: +1.42 V (min = +0.85 V, max = +1.70 V)
+3.3 Voltage: +3.45 V (min = +2.97 V, max = +3.63 V)
+5 Voltage: +5.05 V (min = +4.50 V, max = +5.50 V)
+12 Voltage: +12.35 V (min = +10.20 V, max = +13.80 V)
CPU FAN Speed: 4623 RPM (min = 600 RPM, max = 7200 RPM)
CHASSIS FAN Speed: 2860 RPM (min = 600 RPM, max = 7200 RPM)
CHASSIS FAN 2 Speed: 2509 RPM (min = 600 RPM, max = 7200 RPM)
CPU Temperature: +45.0°C (high = +60.0°C, crit = +95.0°C)
MB Temperature: +40.0°C (high = +45.0°C, crit = +75.0°C)

k10temp-pci-00c3
Adapter: PCI adapter
temp1: +38.9°C (high = +70.0°C)
(crit = +90.0°C, hyst = +88.0°C)

so when i use the $temp1 command i get only the k10temp-pci-00c3 info witch is 38.9
i tried to make a script with the
Quote:
sensors | grep 'Temperature' | awk '{ print $1 " " $2 " " $3; }' | sed -e 's/Temperature//'
but i get nothing as output...
can you help me please? Thank you!

Report

pyrforos

2 years ago

same thing with the new version...

Report

pyrforos

2 years ago

when i run sensors
i get
Quote:
atk0110-acpi-0
Adapter: ACPI interface
Vcore Voltage: +1.42 V (min = +0.85 V, max = +1.70 V)
+3.3 Voltage: +3.45 V (min = +2.97 V, max = +3.63 V)
+5 Voltage: +5.05 V (min = +4.50 V, max = +5.50 V)
+12 Voltage: +12.35 V (min = +10.20 V, max = +13.80 V)
CPU FAN Speed: 4623 RPM (min = 600 RPM, max = 7200 RPM)
CHASSIS FAN Speed: 2860 RPM (min = 600 RPM, max = 7200 RPM)
CHASSIS FAN 2 Speed: 2509 RPM (min = 600 RPM, max = 7200 RPM)
CPU Temperature: +45.0°C (high = +60.0°C, crit = +95.0°C)
MB Temperature: +40.0°C (high = +45.0°C, crit = +75.0°C)

k10temp-pci-00c3
Adapter: PCI adapter
temp1: +38.9°C (high = +70.0°C)
(crit = +90.0°C, hyst = +88.0°C)

so when i use the $temp1 command i get only the k10temp-pci-00c3 info witch is 38.9
i tried to make a script with the
Quote:
sensors | grep 'Temperature' | awk '{ print $1 " " $2 " " $3; }' | sed -e 's/Temperature//'
but i get nothing as output...
can you help me please? Thank you!

Report

maxkaspar

3 years ago

This problem has reappeared again. HDDTemp works without root priviledges (without sudo) from the command line.

It displays the following on the hddtemp line:

[hddtemp: $hddtemp0℃]

Report

C

arcanis

3 years ago

hi,
thank you for the report. Yep, there was small typo from version 1.8.2 (when I've added temperature units). It should be fixed in the current version (1.10.2), at least it works for me.

BTW, you may now configure hddtemp cmd from configuration interface.

Report

vkv

3 years ago

Хорошо бы добавить clementine в список плэеров, там достаточно строчек по аналогии с амароком:
qdbus org.mpris.clementine /Player GetMetadata
qdbus org.mpris.clementine /Player PositionGet

Report

C

arcanis

3 years ago

ок, добавлю в следующей версии

Report

vkv

3 years ago

о, спасибо, вижу в гите уже есть, но должно быть не org.kde.clementine а org.mpris.clementine

Report

C

arcanis

3 years ago

Хм, у меня и с org.kde вроде работало=) спасибо за информацию, проверю. Все равно, релиз не раньше выходных будет

Report

C

arcanis

3 years ago

ага, и правда, невнимателен немного. Теперь работает

Report

vkv

3 years ago

работает
но тут другая подстава : при включении показывания плэера, плодятся зомби от плазмы, с интервалом в секунду
и с клементином и с амароком
это только у меня?

Report

C

arcanis

3 years ago

Да, это нормально (в смысле так и задумано).
Некоторые поля (gpu, hddtemp, custom, player, ps, pkgmanager) задействуют самописный dataengine, который, в отличии от стандартных системных, вызывает внешние команды (а иначе никак). Насчет секудны не уверен - но, по идее, команды должны вызываться только по запросу, а значит интервал появления зомби - установленный интервал обновления.

Report

vkv

3 years ago

по-моему, всё-таки не очень нормально:), за одну песню появятся больше сотни зомби, а за дни непрерывной работы - и не сосчитать.
я решил пойти другим путём, считываю и вывожу теги через custom command:
qdbus org.mpris.clementine /Player GetMetadata|awk '/artist:/{for (i = 2; i <= NF; i++) printf "%s ", $i;printf "%s",":"};/title:/ {$1="";print }'

Report

C

arcanis

3 years ago

ответил на этот пост, потому что сайт ограничивает количество ответов.

Во первых, по идее, запущенные процессы должны убиваться. Причем через некоторое короткое время. По крайней мере, к следующему запросу у меня уже не наблюдается процесса, который проверял в предыдущий раз. Если это не так, значит да, это не нормально и надо разбираться.
Во вторых, опять же, по идее, кастомная команда не должна решать этой проблемы =)

Report

vkv

3 years ago

в том-то и дело, что они не убиваются, поэтому и смастерил костыль
давайте разбираться:)

Report

C

arcanis

3 years ago

в гите есть версия с пробным фиксом (идея в том, чтобы не запускать команды для тех плееров, информация с которых не нужна). Попробовал перенести настройки плеера из виджета в dataengine. С точки зрения настроек почти ничего не поменялась (хотя плеер надо будет выбрать повторно и теперь он на последней вкладке).

По идее, должно быть эквивалентно вашему решению (т.о., если ваш фикс подходит, то и этот должен тоже подходить)

Report

vkv

3 years ago

ок, сейчас не плодятся
сэнкс

Report

vkv

3 years ago

Приветствую, и еще раз спасибо за тулзу. Хочу спросить, можно ли сделать так. чтобы ширина плазмоида не скакала в зависимости от количества цифр в показаниях датчиков? Ну, то есть как бы зафиксировать длину?

Greetings, and thank You again. I would to know, is it possible to set plasmoid's width fixed, despite sensor's values?

Report

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
3.3.3
updated Aug 03 2017
added Feb 21 2013
downloads today
1
page views today 10