Image 01
profile-image

baDibere

Erdem ARTAN Ankara ~ Rize, Turkey
stable sysinfo 2.0

Various KDE 1.-4. Improvements 20 comments

by key87
Rating: 7.7
Feb 04 2009
i have a problem with cmake. Maybe it's a general problem for my computer :

CMake Error at CMakeLists.txt:7 (kde4_add_plugin):
Unknown CMake command "kde4_add_plugin".


CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 2.6)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run "cmake --help-policy CMP0000".
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!


- Feb 04 2009
SciDAVis

Science 4 comments

Rating: 6.9
Mar 27 2010
Thanks for answer but problem wasn't solved. My qwt path is /usr/qt/4/include/qtw but I get same error. I changed the scidavis.pro writing unix:INCLUDEPATH +=/usr/qt/4/include/qwt INCLUDEPATH +=/usr/qt/4/include/qwt respectively. - Nov 06 2008
All dependencies are installed but I get following errors while trying to build :

guDa@baDibere scidavis_0.2.0-beta1 $ qmake
guDa@baDibere scidavis_0.2.0-beta1 $ make
cd scidavis && make -f Makefile
make[1]:`/home/guDa/Desktop/scidavis-0.2.0-beta1/scidavis_0.2.0-beta1/scidavis' dizinine giriliyor
g++ -c -pipe -O2 -D_REENTRANT -Wall -W -DSCRIPTING_CONSOLE -DSCRIPTING_DIALOG -DSCRIPTING_MUPARSER -DQT_PLUGIN -DTS_PATH=\"/usr/share/scidavis/translations\" -DDOC_PATH=\"/usr/share/doc/scidavis\" -DLEGACY_CODE_0_2_x -DQT_NO_DEBUG -DQT_SVG_LIB -DQT_QT3SUPPORT_LIB -DQT3_SUPPORT -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/qt/4/mkspecs/linux-g++ -I. -I/usr/qt/4/include/QtCore -I/usr/qt/4/include/QtCore -I/usr/qt/4/include/QtNetwork -I/usr/qt/4/include/QtNetwork -I/usr/qt/4/include/QtGui -I/usr/qt/4/include/QtGui -I/usr/qt/4/include/QtOpenGL -I/usr/qt/4/include/QtOpenGL -I/usr/qt/4/include/Qt3Support -I/usr/qt/4/include/Qt3Support -I/usr/qt/4/include/QtSvg -I/usr/qt/4/include/QtSvg -I/usr/qt/4/include -I/usr/qt/4/include/QtAssistantClient -I/usr/qt/4/include/QtAssistant -I../3rdparty/qwtplot3d/include -I../3rdparty/qwt/src -I/usr/local/include -Isrc -Isrc/future -I/usr/include -I../tmp/scidavis -I. -o ../tmp/scidavis/muParserScript.o src/muParserScript.cpp
In file included from src/Table.h:38,
from src/muParserScript.cpp:35:
src/Graph.h:38:22: error: qwt_plot.h: No such file or directory
src/Graph.h:39:29: error: qwt_plot_marker.h: No such file or directory
src/Graph.h:40:28: error: qwt_plot_curve.h: No such file or directory
In file included from src/Graph.h:42,
from src/Table.h:38,
from src/muParserScript.cpp:35:
src/Plot.h:37:27: error: qwt_plot_grid.h: No such file or directory
In file included from src/muParserScript.cpp:36:
src/Matrix.h:42:29: error: qwt_double_rect.h: No such file or directory
In file included from src/muParserScript.h:37,
from src/muParserScript.cpp:33:
src/Script.h:69: warning: type qualifiers ignored on function return type
In file included from src/Graph.h:42,
from src/Table.h:38,
from src/muParserScript.cpp:35:
src/Plot.h:44: error: expected class-name before '{' token
src/Plot.h:54: error: 'QwtPlotItem' was not declared in this scope
src/Plot.h:54: error: template argument 1 is invalid
src/Plot.h:56: error: 'QwtPlotItem' has not been declared
src/Plot.h:60: error: ISO C++ forbids declaration of 'QwtPlotCurve' with no type
src/Plot.h:60: error: expected ';' before '*' token
src/Plot.h:61: error: ISO C++ forbids declaration of 'QwtPlotItem' with no type
src/Plot.h:61: error: expected ';' before '*' token
src/Plot.h:62: error: 'QwtPlotItem' was not declared in this scope
src/Plot.h:62: error: template argument 2 is invalid
src/Plot.h:64: error: ISO C++ forbids declaration of 'QwtPlotMarker' with no type
src/Plot.h:64: error: expected ';' before '*' token
src/Plot.h:66: error: 'QwtPlotMarker' has not been declared
src/Plot.h:93: error: expected ',' or '...' before '&' token
src/Plot.h:93: error: ISO C++ forbids declaration of 'QwtPlotPrintFilter' with no type
src/Plot.h:98: error: expected ',' or '...' before 'map'
src/Plot.h:98: error: ISO C++ forbids declaration of 'QwtScaleMap' with no type
src/Plot.h:101: error: expected ',' or '...' before 'map'
src/Plot.h:101: error: ISO C++ forbids declaration of 'QwtScaleMap' with no type
src/Plot.h:104: error: expected ',' or '...' before '&' token
src/Plot.h:104: error: ISO C++ forbids declaration of 'QwtScaleMap' with no type
src/Plot.h:106: error: 'QwtPlotItem' was not declared in this scope
src/Plot.h:106: error: template argument 2 is invalid
src/Plot.h:107: error: 'QwtPlotMarker' was not declared in this scope
src/Plot.h:107: error: template argument 2 is invalid
src/Plot.h: In member function 'QList<int> Plot::curveKeys()':
src/Plot.h:53: error: request for member 'keys' in '((Plot*)this)->Plot::d_curves', which is of non-class type 'int'
src/Plot.h: In member function 'int Plot::curvesList()':
src/Plot.h:54: error: request for member 'values' in '((Plot*)this)->Plot::d_curves', which is of non-class type 'int'
src/Plot.h: In member function 'QList<int> Plot::markerKeys()':
src/Plot.h:65: error: request for member 'keys' in '((Plot*)this)->Plot::d_markers', which is of non-class type 'int'
In file included from src/Table.h:38,
from src/muParserScript.cpp:35:
src/Graph.h: At global scope:
src/Graph.h:165: error: 'QwtPlotItem' has not been declared
src/Graph.h:207: error: ISO C++ forbids declaration of 'QwtPlotItem' with no type
src/Graph.h:207: error: expected ';' before '*' token
src/Graph.h:209: error: 'QwtPlotItem' has not been declared
src/Graph.h:286: error: expected ',' or '...' before '&' token
src/Graph.h:286: error: ISO C++ forbids declaration of 'QwtDoubleRect' with no type
src/Graph.h:417: error: ISO C++ forbids declaration of 'QwtPlotMarker' with no type
src/Graph.h:417: error: expected ';' before '*' token
src/Graph.h:624: error: expected ',' or '...' before '&' token
src/Graph.h:624: error: ISO C++ forbids declaration of 'QwtSymbol' with no type
src/Graph.h:727: error: 'QwtPlotMarker' has not been declared
src/Graph.h:727: error: ISO C++ forbids declaration of 'LineStyle' with no type
src/Graph.h:727: error: expected ';' before 'mrklStyle'
src/Graph.h: In member function 'void Graph::replot()':
src/Graph.h:241: error: 'class Plot' has no member named 'replot'
src/Graph.h: In member function 'QString Graph::axisTitle(int)':
src/Graph.h:435: error: 'class Plot' has no member named 'axisTitle'
In file included from src/muParserScript.cpp:36:
src/Matrix.h: At global scope:
src/Matrix.h:270: error: 'QwtDoubleRect' does not name a type

*** 49 errors, 1 warnings
make[1]: *** [../tmp/scidavis/muParserScript.o] Hata 1
make[1]: `/home/guDa/Desktop/scidavis-0.2.0-beta1/scidavis_0.2.0-beta1/scidavis' dizininden çıkılıyor
make: *** [sub-scidavis] Hata 2
- Nov 06 2008
netgo_ng

Network 46 comments

Rating: 6.9
Oct 18 2009
Ok! No error now but program doesn't work. I mean I couldn't connect to a no-password-wireless-ap.

DHCP doesn't get IP - Oct 26 2008
Make error under gcc 4.3.1 kde 3.5.10 using Pardus

Here is the output : http://ogrenci.hacettepe.edu.tr/~artan05/netgo_ng_error.txt - Oct 26 2008
I haven't got the file "/root/.netgo_ng/scripts/ipup.sh"

My dhcpcd version is "dhcpcd 3.2.3"
Compile time options: ARP DUID INFO RESOLVCONF
- Sep 01 2008
It seems there is a problem with dhcpcd:

- Shutting down interface eth1 ....
- Setting up eth1 via iwconfig ....
- terminating existing dhcpcd .... if exist
- Setting up interface eth1 via dhcpcd .... timeout 30 sec.
usage: dhcpcd [-adknpEGHMNRSTY] [-c script] [-h hostname] [-i classID]
[-l leasetime] [-m metric] [-r ipaddress] [-s ipaddress]
[-t timeout] [-u userclass] [-F none | ptr | both]
[-I clientID] <interface>
- no IP address yet ..... backgrounding. - Aug 31 2008
Thank You..

I can install it now. I will try using it later. If I get any problem, I write here. - Aug 31 2008
Thanks for your interest but the problem continues.

The output is http://ogrenci.hacettepe.edu.tr/~artan05/CONF2.txt - Aug 31 2008
I couldn't install it because make command gives error. I'm using GCC 4.3.1 and KDE 3.5.9 on Pardus Linux.

Here is my ./configure and make command outputs. http://ogrenci.hacettepe.edu.tr/~artan05/CONF.txt - Aug 31 2008
KGmailNotifier

Email 148 comments

Rating: 7.4
Jul 09 2012
The program couldn't connect. There is always a warning that says this. Under KDE 3.5.9, Pardus 2008.1 - Sep 23 2008
Kompile

System Software 100 comments

Rating: 7.1
Jun 09 2007
Ok.. No problem. - Jul 24 2008
I have downloaded stable version and I installed it (using ./configure, make, make install). But when I want to try to run it, an error shows and says :
"You have forgot to specify a valid sources tarball or specified file isn't a valid sources tarball!
Specify an existing and valid source tarball please.
Maual selection of sources tarball and building options manual setup will be avaiable in future version."

What does it mean? What's the problem and solution?

Thanks.. - Jul 24 2008