Image 01
profile-image

callintegrator

callintegrator callintegrator
Telephony
test
callintegrator

Telephony 12 comments

Score 50.0%
Apr 06 2008
great. Just copy the exe "callintegrator" in the same directory as "initcall" and use it to change your config file if you need to switch between different providers.

Your problem might be due to Qt 4.3 I have Qt 4.2, or something else was messed up.

Let me know if you have any further problems. - Jul 31 2007
Why can't I see a "reply" link in your last message?

Anyway please do the following

run qmake -v and post the output now go into the deepest directory called "callintegrator" and remove all files, the only ones you have to keep are

callintegrator.cpp
callintegrator.h
callintegrator.ui
main.cpp

now run the following commands inside that directory:

qmake -project
qmake
make

and post the output.

Thanks.

If you want to use voipbuster the code in the config file is voipbuster-auth. - Jul 30 2007
Hi,

German is fine for me. Don't know Debian, I am using Suse.

1. initcall
Works fine for you. Copy it to a directory in your search path.
Work around until the issue with Qt is solved.
Create manually using a text editor a file ~/.callintegrator. With the following content
c = either of, without quotes, "peterzahlt", "freecall", "freecall-auth", "voipbuster" or was it "voipbuter-auth" need to check the source code as soon as I have access again. sorry. this determines which provider you want to use.
u = <your username> if you use freecall-auth or voipbuster
p = <your password> if you use freecall-auth or voipbuster
r = 0
s = <your home phone number e.g. 004989123456>
w = 8

Now you can add the hook in kaddressbook as described in the documentation html file.

this is only a work around, the Qt GUI does nothing else than creating this config file.

2. callintegrator
You can see in the output
that Qt desinger has the wrong version, version 3.x versus 4.0. Please ensure that Qt designer 4.0 or higher is installed. run make again in the callintegrator folder and post your results.

If you run a 32bit system you can try to use the compiled files provided in the package.
- Jul 30 2007
Hi,
it should be sufficient to run make (not qmake) in the top directory. If that doesn't work, please do the following and post the output:

1. directory "initcall"
Run make here, if it doesn't work run g++ -Wall initcall.cpp

2. directory "callintegrator"
Run make here.

What platform do you use? Which distro? Can you compile other Qt4 (not Qt3!) applications? Somehow I have the feeling that you call some Qt3 objects.

Please post the above outputs and I'll see what it might be.

- Jul 29 2007
PS: rather send me an email to get a quicker answer: callintegrator@web.de - Mar 17 2007
Which version do you run? In which directory do you run "make"? Which platform and which Qt version?

I 've changed the setting that way that I compile two main programs with one make call. Usually one make is only good for one main routine.

Anyway, please provide the above info to figure out what went wrong.

Btw, freecall has changed some paramters in order to get it working again I'll release a new version today or tomorrow. But that has nothing to do with your compilation. Just to let you know in advance - Mar 17 2007
PDFedit

PDF Software 60 comments

Score 50.0%
May 02 2007
I have exactly the same compile problem as the very first post. I have the Qt3 libs installed. Please provide an advice.

I was really waiting for this program!!!! - Jan 19 2007