Image 01
profile-image

ciobi

Marian Ciobanu
MP3 Taggers

MP3 Diags

MP3 Taggers Jul 30 2016
Score 75%
75 Likes
25 Dislikes
MP3 Diags

MP3 Taggers 21 comments

by ciobi
Score 75%
75 Likes
25 Dislikes
Jul 30 2016
Not long after my previous comment I thought of 2 workarounds, then I implemented one of them, and now the build has finished. There is a 2009.1 rpm at http://download.opensuse.org/repositories/home:/ciobi/Mandriva_2009.1/i586/ . Hopefully this will work. - Jul 07 2009
The openSUSE-provided build for 2009.1 seems broken. I wanted to tell 2009.0 to use a newer Boost, but I don't think that is possible. It seems that 2009.0 has 1.34, 1.35 and 1.36, while 2009.1 has 1.37 and 1.38, so there's no overlap. So, sorry - currently I can't build for 2009.1. - Jul 07 2009
It looks like my rpm is for 2009.0 while you have 2009.1, so I guess that explains it. I tried to build for 2009.1, but I got a strange error; I hope to fix it soon. - Jul 06 2009
OK, thanks. An RPM got built: http://download.opensuse.org/repositories/home:/ciobi/Mandriva_2009/i586/

Can you have a look and let me know if there's something that should be changed? - Jul 05 2009
Can you send me your .spec file, so I can include Mandriva in the automatic build? - Jul 05 2009
I got the file. What was supposed to happen was for an "unsupported" note to get generated for the file, but there was a bug. Now I fixed the bug and went further and added support for the missing feature. The fix will be in the next version, of which the sources should be available soon, the Linux binaries in a few hours, while the Windows binary will have to wait until tomorrow. - Jun 21 2009
Sorry, I meant the MP3 file. (I obviously have the CPP.) I'm pretty sure that this assert is triggered consistently by an MP3 file (or perhaps all the files in an album.) I was hoping that you can isolate such a file and make it available. Please let me know if you can't figure which file caused the crash. - Jun 21 2009
I'm pretty sure that it's an easy fix, but I need the file that triggered the assert. So, can you mail it to me or make it available somehow? - Jun 21 2009
I knew there were issues with some fonts, (due to a Qt bug, unless I'm missing something) but it turns out that on Ubuntu 9.04 most fonts cause problems. So I created a new release, which implements a workaround. There are also some other minor UI tweaks. - May 25 2009
Thank you for your comment.

I installed GCC 4.4 on an openSUSE 11.1 and noticed that there is an issue with older Boost versions as well. I added the missing header and also made a note about Boost, in the documentation. - May 25 2009