profile-image

dantti

Daniel Nicoletti São Paulo, Brazil

Apper

System Software Jan 08 2013
Score 84%
84 Likes
16 Dislikes
Apper

System Software 224 comments

Score 84%
84 Likes
16 Dislikes
Jan 08 2013
Yes, just right click the updates list and select the column you want. - Jan 30 2014
All that information depends on which distribution are you using. - Oct 23 2013
Sorry I don't know how to use ports or what does that error mean, but kpackagekit means that you are trying to use an old version since it was renamed to Apper long ago... - Oct 10 2013
You can do that using pkcon :D - Jan 08 2013
It's a known bug, because other widgets don't repaing the background, it's a bug in the theme engine which should repaint after an animation, which doesn't happen. - Aug 07 2012
Ximion has packaged it again :D
https://launchpad.net/~ximion/+archive/packagekit/+packages - May 23 2012
no, the issue he's talking about should openSUSE specific our license handling is quite different from theirs... - May 23 2012
Can you please elaborate a test case?
Distro/package etc?
did you make install on /usr?
I tested this several times and it actually worked... - May 22 2012
Fixed in this release sorry for the delay - May 21 2012
You're welcome! - May 21 2012
Easy install kdelibs-dev package - Nov 28 2011
now it's easy you are missing the most important dependencie: PackageKit. if you are in Debian install the packaged version, if you are in any other distro check for compiled packages, otherwise changes are you will need to write a backend to talk to the package managent of the distro. But most modern distros have a backend for it. - Oct 25 2011
you are missing the install prefix:
cmake .. -DCMAKE_INSTALL_PREFIX=/usr/
if you don't install in /usr KDE can't find the KCModule - Oct 24 2011
http://imgur.com/ to paste images, also if you have IRC access you can contact us on #packagekit (freenode).
Maybe this conversation would be easier by mail. - Oct 13 2011
I use it every day and it works fine, you have some conflict that can be avoided by not updating all packages, but I can't know what your problem is if you don't paste the whole problem.
Please take an screenshot of the error or something and additionally use pkmon and put it on a paste bin. - Oct 13 2011
Sorry don't get very much what you have said, but packagekit works on resolving deps exactly the same way as apt-get would. - Oct 13 2011
Yes, it is a problem, tho I don't have the time to fix this by myself, if you can help you just need to convert those tools to talk debconf protocol. - Oct 13 2011
there are two ways of having icons, the first is with AppInstall data (which had become deprecated but still in use in Ubuntu - will be replaced by AppStream soon), or by having scanDesktopFiles in /etc/PackageKit/PackageKit.conf then you refresh your cache and it should start showing icons for installed apps.. - Oct 13 2011
No, apt-listbugs is disabled by PackageKit because it requires stdin which is not supported by PackageKit. In the future, if someone change apt-listbugs to use debconf then it will work. - Oct 13 2011
Well the pending changes is currently just a queue to install what you clicked, you don't even need to go there, but otoh I think I could use some improvements by simulating the install, but it's not so simple...
Best - Oct 11 2011
I'll try to add this to the 0.7.1 version thanks. - Oct 10 2011
I'm working on this but as PackageKit does not provide that info I can't instantly add this feature, but I'm about to add this to PackageKit itself hopefully PackageKit 0.7.1 or .2 will have it :D - Jul 29 2011
Yes thanks, I got sad when I hear the news (expecially because nobody talked to me about that).
But don't worry Apper is going to be developed and improved further, currently it's the only Package manager available to all major distros out there (Debian, Ubuntu, Fedora, openSuse and more).
keep an eye on my blog soon I'll be posting news about the new features and the feature of Apper.
Best. - Jul 29 2011
Yes, for Apper I'll do more testing on this,
Thanks. - Jul 29 2011
Yup, I know I'm working on a fix for Apper,
Thanks - Jul 29 2011
Yes, it does, but by default on Kubuntu it does not display unless there are packages to be removed.
If you want to see them all the time go to KPackageKit settings and check "Show confirmation Dialog when installing/updating"
Best. - Jul 29 2011
You need to have a sqlite db file in /usr/share/app-install/desktop.db check to see if it's there and readable.
best - Jan 03 2011
k nice :)
there are two patches:
http://gitorious.org/packagekit/packagekit/commit/fd9980ca72318d7e5e2787bd18b6abdd8cd5559d

http://gitorious.org/packagekit/packagekit/commit/ec2953e49025afe66451a7064bd111eda1ec8c79

thanks - Dec 22 2010
Are you using Fedora? If so an updated package will be released soon, I've added a new method to packagekit-qt I thought it was on the 0.6.10 version but it seems that I was wrong.. - Dec 21 2010
No I can't reproduce, maybe a backtrace would help :D - Nov 17 2010
>but i hope you understand me ;).
>I ask me why there is no ready
>.deb Package für kpackagekit ?
Because I'm not a packager :P

>And if kpackagekit find the way to
> the official Debian Repositiore in Future?
Not by itself.. but yes as we have PackageKit
in SID it's way easier.

>And under: http://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=kpackagekit;dist=unstable
>I read that there is no maintainer für kpackagekit is that true ?
yes, there is no _Debian_ maintainer yet, but Matthias Klumpp
is about to package it, if you can help him please do :D

>Apart from that Kpackgekit is a great Application and big thanks to the developers.
you welcome. - Nov 17 2010
Ok, as explained on this LP bug, KPackageKit is actually able to use apt-cacher BUT the config _must_ go into kde proxy settings or /etc/PackageKit/PackageKit.conf.
Not the best solution but I have fixed this issue now, I'm just not sure a new package will be created for this to work. - Nov 04 2010
You need a newer KDE, I think at least kde 4.4 but not 100% sure if I''m using a kde 4.5 class - Oct 28 2010
Please ask kde german translation team to update that. - Oct 13 2010
Yes, you need packagekit-qt >= 0.6.8 which is and won't be available at Kubuntu 10.4, but Kubuntu 10.10 already has the lastest packages. - Oct 06 2010
Yeah I know that too :P
Probably the current realease that your are looking for? Probably this highlights the changes
http://dantti.wordpress.com/2010/09/29/open-the-package-get-your-application/

best - Oct 05 2010
Hmm sorry, never saw that problem, can you try with gnome-packagekit? might be a bug in the yum-backend. - Oct 05 2010
Well I'm sorry but I don't use Arch, my time is short and writting the aptcc backend took a lot of my time.. - Sep 03 2010
Yeah, it really sucks :P it's a bug in packagekit-qt, I told the author but he didn't fix it yet, after I finish some stuff I'm doing I'll try to fix that myself :D - Jun 10 2010
does gnome packagekit works?
does searching for packages in kpackagekit works? - Apr 11 2010
Please tell me which distro, backend, and version of PackageKit and KPackageKit that are you using. - Apr 11 2010
There is no such application view that talks with PackageKit, you are probably confusing with some other application.
That screen shot from gnome packagekit is showing the gnome desktop group... just that...
(which also works in kpk) - Mar 22 2010
1. If you don't like seeing 15 vlc related packages complain to your distro.

2. If you want to see GNOME packages just click on the combo box and select GNOME desktop.

FYI Both applications have exactly the same functionality. - Mar 22 2010
I've planned to improve the search on the list when there are alread packages there (no time yet),
for the others it's just not possible for now... - Mar 18 2010
Hmm I believe that with the coming version (0.6) this is already fixed - Mar 13 2010
This happened because packagekit libs were not installed on the right place, that's why I told you to use a local dir for the prefix. After that manually copy the files to the right dirs.
BTW I think it's best to try first with aptcc backend, apt has lots of deps in Debian, which you can try to get them after you are sure PackageKit is working.. (or stick with aptcc :D ) - Mar 12 2010
Right, well the build stuff is quite simple although I must admit could be more detailed, I run the autogen script as follows: ./autogen --enable-gtk-doc --prefix=/home/daniel/code/packagekit/pkbin/ --enable-aptcc --with-default-backend=aptcc --with-security-framework=dummy

Be careful with '--with-security-framework=dummy' cause it will let all users do everything, I use this since we didn't have polkit-kde working with polkit-1 but now I works so you might want to try to remove that.
The --enable-aptcc enables a backend written by me to work with apt (made in c++), but if you prefer you can use the python version (which will be --enable-apt).

hope this helps,
Best. - Mar 09 2010
Your PackageKit is not properly installed, check if the DBus confs are installed on the right places, I develop KPackageKit and aptcc backend on Debian squeeze. - Mar 03 2010
thanks, fixed in 0.5.4 - Jan 19 2010
the rule is simple kpk 0.5 should work with Pk 0.5, Kpk 0.6 (not ready yet) will work with Pk 0.6 - Jan 14 2010
Score 72%
72 Likes
28 Dislikes
Aug 21 2011
Score 72%
72 Likes
28 Dislikes
Aug 21 2011