profile-image

davidsansome

David Sansome

Clementine

Audio Apps Mar 31 2011
Score 73%
73 Likes
27 Dislikes

Clementine

Audioplayers Mar 31 2011
Score 86%
86 Likes
14 Dislikes

GTK-QT Theme Engine

GTK1 Themes Mar 10 2008
Score 69%
69 Likes
31 Dislikes

BeQunge

Developer Tools Dec 11 2006
Score 59%
59 Likes
41 Dislikes

Winterbar

Various Stuff Nov 03 2004
Score 54%
54 Likes
46 Dislikes

Radiation spill

Wallpaper Other Aug 17 2002
Score 43%
43 Likes
57 Dislikes
Clementine

Audioplayers 66 comments

Score 86%
86 Likes
14 Dislikes
Mar 31 2011
openSUSE's package doesn't have FTS either :(
If you just compiled sqlite3 from source and "make install"ed it then it probably didn't go in the right place, and Clementine is still using the system package. You can check by running sqlite3 and typing:
CREATE VIRTUAL TABLE foo USING fts3();
If it succeeded it will give no output.

Anyway, try Clementine from SVN as in the comment below and let me know if it works.= - Jun 30 2010
Slackware's sqlite package doesn't have FTS3 enabled. I've added a workaround in svn - Clementine will now use its own static sqlite if it needs to. Could you try it and let me know if it works for you? Instructions are here:
http://code.google.com/p/clementine-player/source/checkout - Jun 30 2010
Clementine opens another audio stream to do the crossfading between tracks - try turning off crossfading in the settings dialog.

But regardless, Ubuntu should have set up pulseaudio to allow two things to play at once. Make sure it's actually installed and running, see the second FAQ entry here:
http://code.google.com/p/clementine-player/wiki/FAQ - May 11 2010
Ok that's good - 5-10 seconds is about how long it's supposed to take to check if each of the directories has changed.
Let me know if it gets worse again! - May 10 2010
It should only be rescanning your files if one of the directories has changed since the last time Clementine opened. Could anything else be modifying those directories? Are the directories mounted over the network, or is your home directory encrypted? - May 10 2010
Yep, the CPU usage is something I'm working on at the moment. It shouldn't be so high while it's not playing and the analyzer is disabled though... - Apr 20 2010
Hey, try the 0.3 beta for mac, that should hopefully fix this problem:

http://code.google.com/p/clementine-player/downloads/detail?name=clementine-0.3_beta2.dmg - Apr 19 2010
Looks like slackware's Qt package is a bit broken, its sqlite plugin doesn't actually export the sqlite symbols.

Try the svn version of clementine - I've just committed a workaround that should make everything still work when those symbols couldn't be loaded. - Mar 24 2010
Hmm no idea, sorry :)
Try a "make clean" and "make" again. - Mar 23 2010
What happens? Do you get any error messages when you try to run it? - Mar 23 2010
Sorry - this should be fixed in svn now.
For now turn off Release mode when you're compiling and it should work ok. You can do this by running "ccmake .." in bin/, and clearing CMAKE_BUILD_TYPE. - Mar 23 2010
Thanks for the feedback :)
I hadn't actually tested Clementine with those formats on Windows yet. I'll make sure I do for the next release!

It uses DirectShow on Windows so in theory it should be able to play the same formats as windows media player. Maybe something's going wrong there though... - Feb 24 2010
Ok, I've built the latest version of taglib myself and it's clean now.
Windows version is back up. - Feb 23 2010
Wow thanks for letting me know. That was the official taglib binary from the taglib website.

Virustotal report here if anyone else is curious:
http://www.virustotal.com/analisis/2f92ce50c6afc83d01388010fc26e64d0c815487dde5e5a9ea08086187cef3d0-1254867149

I've pulled the windows downloads from the website, and I'll put them back up once I've compiled taglib myself. - Feb 23 2010
Ah thanks, I hadn't actually tested on Mandriva-based distros yet. - Feb 22 2010
Hi,

I've added a source RPM, it's now available above, or also on this link:

http://clementine-player.googlecode.com/files/clementine-0.1-5.fc12.src.rpm

Let me know how you get on! - Feb 22 2010
Clementine

Audio Apps 53 comments

Score 73%
73 Likes
27 Dislikes
Mar 31 2011
GStreamer has proven itself to be a very good backend. The API itself is a little hairy (personally I don't like GObject or GLib, which is why Clementine is written in Qt :)), but it does work very well.

We tried xine first actually - it worked great on Linux but was very buggy on Windows - I spent a couple of weeks trying to fix a race condition between the mp3 decoder and the DirectSound backend before giving up on it.
We've also tried VLC. While it has excellent support for different file formats, it does tend to skip a lot on playback.
Incidentally these two backends (plus a Phonon backend) can be enabled in Clementine if you compile it yourself. Look for the options in ccmake or cmake-gui.

I'm curious as to why you dislike GStreamer so much. Is there any reason other than the gnome dependencies - ie. is the audio quality worse?
I really don't see dependencies as being a problem, most distributions these days make installing them easy, and it's not like you have to have any of gnome running while you use Clementine. - May 27 2010
Thanks for the attitude.

Which other audio backend would you recommend that is cross-platform, as easy to use, as well tested, and supports as many formats as gstreamer? - May 15 2010
Nope that's right - clementine uses gstreamer for playback now.

Having a couple of extra libraries installed doesn't hurt, and those ones are fairly small anyway. You don't have to run gnome! - May 01 2010
Thanks!

The Portuguese translation looks to be pretty much complete:
https://translations.launchpad.net/clementine/trunk/+pots/translations

Clementine isn't in any repos yet, but I think the Ubuntu package on the website ought to work ok on Debian.

David - Apr 28 2010
Nope we didn't change anything on our end, must've been a temporary problem somewhere.
Glad you got it working eventually :) - Mar 07 2010
We used the xine audio engine from Amarok because it supports fading and the animated scope you can see at the bottom of the window. Phonon doesn't seem to be able to do either of these things well, and actually doesn't appear to be maintained very well inside Qt - I don't think it's received any new features since it was first included. - Mar 03 2010
Can you check the m5sum of the file you downloaded? It should be: 89e2436ffe5cc4f1e46a4c0ab86f9c5d

Also try downloading the .dmg directly from Google Code:
http://code.google.com/p/clementine-player/downloads/list - Mar 02 2010
Yep this is something that bothers me too - it does attempt to do some clever various artists detection but it's obviously not very good.
I'll try to improve it a bit for the next release. - Feb 24 2010
Thanks for the offer but I already have a Spanish translation in SVN! - Feb 24 2010
That's a good idea, I'll make sure it's an option for the next release. - Feb 23 2010
It's something I'm working on for the next release. Can I email you when I have a Qt Linguist file ready? - Feb 23 2010
Thanks, that's a nice list of suggestions :)

*makes a note* - Feb 22 2010
GTK-QT Theme Engine

GTK1 Themes 280 comments

Score 69%
69 Likes
31 Dislikes
Mar 10 2008
Oops.

Thanks - I've commited the fix to SVN. - Mar 16 2008
Hi,

Can you run:
GTK_QT_ENGINE_DEBUG=1 logjam
And then send me the last couple of lines of output before the crash?

Also, which Qt style are you using?

Thanks - Mar 16 2008
Thanks for the comments!

I've been trying to reproduce your bonobo problem, but it compiles fine on my box without libbonobo. Can you remember the error you got? If not, what distro are you using? I'll see if I can reproduce it.

And yes, Firefox still looks strange with gtk-qt. Not really sure there's much I can do about it, since it's Firefox that's using GTK themes incorrectly. - Mar 16 2008
Argh sorry about that - looks like it's time to find a new hosting provider.

I've mirrored the file here in the meantime:
http://people.freedesktop.org/~davidsansome/gtk-qt-engine-1.1.tar.bz2 - Mar 11 2008
Hi Erin,

I fixed this last night! Have a play with the latest version in SVN and let me know if the problem still exists.

Thanks! - Nov 01 2006
Yep, I'm experiencing some problems with KDE 3.5.4 as well. Not sure what the cause is yet, I'll look into it and get back to you when I have a solution. - Aug 04 2006
Thanks, I've confirmed this bug and added it to the freedesktop bug tracker so I don't forget about it:

https://bugs.freedesktop.org/show_bug.cgi?id=7694 - Jul 30 2006
What Qt style are you using Scsi? - Jul 06 2006
Thanks, I'll look into it - Dec 23 2004
The problem with the scrollbars is a firefox bug - not one that I'm able to fix.

Do those other errors crash firefox?
When do they occur? As soon as you run the program? - Dec 23 2004
Try it out!

If it doesn't, let me know, and I'll try to fix it. - Jun 16 2004
My apologies for the bugs in 0.4. I've just released 0.41, which will hopefully clear some of these up.

I've tested it on:
Mandrake 10.0 Official
Suse 9.1
Fedora Core 2
Debian Testing

If you still experiences crashes with 0.41, please let me know, and I'll investigate further.

Thanks. - Jun 16 2004
The KControl module is there so people can easily select the theme, without having to edit configuration files by hand or use switch2 (which I've found to be very buggy).

I've discovered a way to set GTK icons in code, so users don't need to fiddle with the rc file when they change theme in KDE. I'll be working on this for the next release, and I'll use your code as a reference :) - Jun 16 2004
GTK-QT Theme Engine

KDE 1.-4. Improvements 24 comments

by appy
Score 76%
76 Likes
24 Dislikes
Jan 26 2005
Just to prevent confusion: this isn't an update of the theme engine, it's just a repost to make it appear on KDE-Apps.org as well as KDE-Look.org.

I'm hoping to release a new version towards the end of February. - Jan 26 2005
Winterbar

Various Stuff 4 comments

Score 54%
54 Likes
46 Dislikes
Nov 03 2004
It's the default wallpaper that comes with Suse 9.1 - Nov 03 2004
The Linux Registry Editor

System Software 13 comments

Score 49%
49 Likes
51 Dislikes
Aug 13 2004
You really shouldn't be distributing Autopackages until it reaches version 1.0. Anyone who installs this package is likely to have trouble upgrading when 1.0 is finally released. - Aug 12 2004
GTK-QT Mandrake 10.1 RPM

GTK1 Themes 33 comments

by ntesa
Score 31%
31 Likes
69 Dislikes
Dec 23 2004
That was a very quick RPM :) - Jul 30 2004
Hi ntesa,

The problems people are having with this RPM are caused by the "section" entry being set incorrectly in the /usr/lib/menu/kcmgtk.menu file.

It should read:
section="System/Configuration/KDE/LookNFeel"

Also, although it's not really necessary, you should change the package name in the menu file to:

?package(gtk-qt-engine): ...

Thanks for taking the time to build this RPM :) - Jun 18 2004
Really Slick Screensavers

Screensavers 43 comments

Score 62%
62 Likes
38 Dislikes
Jul 24 2004
Hi,

I hope this error is fixed in 0.2 as well. Could you test it for me?

Thanks - Jul 14 2004
I think I've fixed this in version 0.2. Can you try it out, and tell me if it works for you?

Thanks - Jul 14 2004
My guess is you don't have OpenAL installed. - Jul 13 2004
Tina32 - This is not Aida32

System Software 18 comments

Score 54%
54 Likes
46 Dislikes
Jul 06 2009
I don't really think that's fair.

Surely having something German on this site is better than having nothing at all. I don't mind if it's not in English. Maybe I won't be able to use/understand it, but I know there are people out there who will. - Jul 05 2004