Image 01
profile-image

grulja

Jan Grulich , Czech Republic
Plasma 4 Widgets
Akonadi calendar plasmoid

Plasma 4 Widgets 64 comments

Rating: 7.7
Nov 10 2012
It won't be ported, because it would need to be rewritten to QML and also there is no Qt5 version of Akonadi available. - May 03 2015
I'm not able to reproduce it with my events. I have a lot of events where many of them take only a day and I see them only once. Are you sure you don't have your calendar selected twice in the configuration of this applet? - May 28 2013
It's not a bug. I moved the date on the side when the date label has a small font. Maybe I could use smaller limit for this or it could be up to user to set what he wants. - Nov 11 2012
It should be fixed, try newer version please. Thanks - Nov 07 2012
Hm it's not possible to use Akonadi for holidays so that's why it doesn't work in my plasmoid. I can take a look on it in future, but now I don't have much time. Thanks for patience. - Nov 07 2012
I know what is wrong and I will fix it. Thanks - Nov 05 2012
I'm afraid that it wont work. You could try to update your kdepim to newer version. - Oct 21 2012
Try the latest version, I added an option for this. - Oct 21 2012
I think that kincidenceeditor is a part of new kdepim. What version of kdepim do you have? - Oct 17 2012
In Kubuntu you have to install these packages:
kdelibs5-dev kdepim-dev qt4-dev xsltproc libboost-dev
I assume that in Debian they should have same name.

- Oct 16 2012
You have to install development packages for Qt, KDE, KDEPIM. - Oct 16 2012
I looked into the source code of CWP and the author paints the widget itself. I will try to look at it when I have time. Unfortunately I'm too busy now because i will have exams. - Aug 12 2012
Hi,
I think it is not possible because transparency is a property of the Plasma theme and I use Plasma widgets with default background. - Aug 12 2012
For me it works. I'm from Czech Republic so we are at the same time zone. I convert the date and time of events in this plasmoids to local time zone which is defined in system clock/date (i think). Maybe you have wrong time zone in your system settings but not in KDE settings. - Jul 25 2012
Thanks, it's nice to read something like this. It's a good idea and so if i will have free time i'll do it. - Jul 23 2012
Hi,
you have to install boost-devel package. - Jun 16 2012
Try it and you will see :) - Apr 23 2012
I don't understand exactly what you mean. If you can describe it closer I will try do something with it. Thanks - Apr 17 2012
Hi,
I changed some things in resizing. Can you try the new version and let me know if it's ok or if it's at least better? - Apr 16 2012
Akonadi contacts plasmoid

Plasma 4 Widgets 18 comments

Rating: 6.4
Apr 27 2012
Can you show me screenshot of this? Because I don't know what you mean :) - Apr 23 2012
Try it now please, I hope it should work now. Thanks - Apr 23 2012
I removed the line where you have problem. Maybe I didn't upload it correctly to kde-look. Can you try version from git? - Apr 22 2012
Try it now :) - Apr 22 2012
Thank you. Now it's should be ok. - Mar 12 2012
I display only contacts which are in KAddressbook, so if you can't see them in KAddressbook, they won't be in my plasmoid. Maybe there is some problem with Akonadi-google. Are you sure you have all phone contacts in https://www.google.com/contacts_v2/#contacts? Maybe they are only in SIM card. - Feb 28 2012
I display only contacts which are in KAddressbook, so if you can't see them in KAddressbook, they won't be in my plasmoid. Maybe there is some problem with Akonadi-google. Are you sure you have all phone contacts in https://www.google.com/contacts_v2/#contacts? Maybe they are only in SIM cards. - Feb 28 2012
Try to install your boost-devel package. - Feb 28 2012
Do you have your google contacts in KAddressbook? You have to add Google contacts resource from Akonadi-google to your Akonadi resources. It should look like this http://imageshack.us/photo/my-images/402/akonadi.png/ - Feb 28 2012
Akonadi tasks plasmoid

Plasma 4 Widgets 24 comments

Rating: 7.5
Jul 24 2012
No, I mean git version of Akonadi-google because if you get it from deb/rpm package repository you may have old version :) - Apr 21 2012
And try new version from git :) - Apr 21 2012
Try https://projects.kde.org/projects/playground/pim/akonadi-google it's much better then resource that you want to use. - Apr 21 2012
This is not Akonadi-google resource that I have mentioned. But my plasmoid should work with all resources if you will use -DALL_COLLECTIONS=true option. - Apr 21 2012
Hi,
do you have any tasks collections in KOrganizer? If you have collections in KOrganizer do you see any collections in general config of plasmoid? - Apr 21 2012
Hi,
I'm happy that you like my plasmoid. The problem which you described is a matter of Akonadi-google which is Akonadi resource for communicating with Google. I'm in contact with Akonadi-google developer and he is preparing new version of this resource. I think he's planning to release it soon. - Mar 30 2012
Try it now. I used preffered size instead of minimum size so you can now resize plasmoid as you want. - Mar 29 2012
I found that function which I used is only in Qt 4.8 so I assume that you have old version of Qt. The only solution for you could be upgrading to new version. - Mar 17 2012
Try it now I tried to fix it. - Mar 17 2012