Image 01
profile-image

HeikoSchfer

Heiko Schäfer , Germany
Card

NetMauMau

Card Aug 22 2015
Score 50%
50 Likes
50 Dislikes
Qt Components

QGitHubReleaseAPI

Qt Components Aug 19 2015
Score 52%
52 Likes
48 Dislikes
NetMauMau

Card 19 comments

Score 50%
50 Likes
50 Dislikes
Aug 22 2015
For your packaging, you may be insterested in following: https://bugs.launchpad.net/getdeb.net/+bug/1419407 - Feb 08 2015
Also you can see the Debian packaging on how to split the server into suitable subpackages. - Feb 06 2015
Generally would it be possible to move the discussion to Github? There are also all relevant documentation.

Server start is done best via xinetd.

You can see, comment and even make pull requests on here: https://github.com/velnias75/NetMauMau-Qt-Client and https://github.com/velnias75/NetMauMau - Feb 06 2015
Ok, but for the future, it seems I got it to work in the src.pro as well.

But there are new source files listed as well, so you may want to update your spec after 0.13 is finished (should happen tomorrow)

Also if you publish your packages somewhere, can you give me the instructions for both packages to include in my README.md's? - Feb 06 2015
Hm, you are right. Now it doesn't work for me too :-O - Feb 06 2015
Last idea, I guess you didn't took the src.pro 1:1?

Important for the translation are the last 3 lines of the src.pro. Do you have pasted them, too? - Feb 06 2015
It seems qmake is extremely reluctant concerning installations.

Isn't it possible, like on Gentoo & Debian, to call lrelease from the spec and to add the *.qm manually?
- Feb 06 2015
in your spec, did you call

qmake CONFIG+=release

? - Feb 06 2015
Edit: the translation should go into

/usr/share/nmm-qt-client - Feb 05 2015
The updated src.pro from Github should install the translations as well into /usr/share/nmm-qr-client

Do you have lrelesse installed? On some systems it may be called lrelease-qt4. Translations are
produced by a call to lrelease src.pro.

All resources are compiled in with rcc, so they are not installed separately.

Can you paste the complete output of make install? - Feb 05 2015
An updated src.pro you can find here:

https://raw.githubusercontent.com/velnias75/NetMauMau-Qt-Client/master/src/src.pro - Feb 05 2015
The project file hasn't yet any install targets, because they have been simply not needed for Debian and Gentoo.

As temporary workaround in src.pro you can add

unix:target.path = /usr/bin
unix:INSTALLS += target

before

unix:INCLUDEPATH += "/usr/include/netmaumau"

The next release will install all files correct - Feb 05 2015