Image 01
profile-image

KDEforever

Karsten Malcher
Oxygen Original Plasma theme

Plasma Themes 10 comments

Score 68%
68 Likes
32 Dislikes
Dec 22 2017
It's a pity - this will not work on Debian:
oxygen-mix :depends on: oxygen5-icon-theme which is a virtual package and is not provided by any available package. - Dec 20 2017
Sorry alex-I, but i find your design children-like too.
Options and the possibility for experiences are good,
but for the first you should respect that humans are creatures of habit.
So Linux has no chance for the users if everything changes from version to version.
So options should be additional options to a good standard. - Dec 20 2017
KDE4 Icon Cache Reset

Various KDE 1.-4. Improvements 9 comments

Score 48%
48 Likes
52 Dislikes
Sep 20 2012
This published script is bullshit - sorry.

But how can i rebuild the icon cache correct? - Nov 24 2015
Kate C++ Helper Plugin

Text Editors 29 comments

by zaufi
Score 67%
67 Likes
33 Dislikes
Sep 08 2015
With some help and little modifications it is possible now to compile this plugin for Debian 8.2 stable (jessie).

You will find the complete discussion here:
https://github.com/zaufi/kate-cpp-helper-plugin/issues/24

Here i suggested to add this plugin to the distribution:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=799204
There is a short description how to compile it. - Sep 17 2015
For other users:
Any question must be adressed at
https://github.com/zaufi/kate-cpp-helper-plugin/issues - Sep 16 2015
After modifying CMakeCache.txt and FindLibClang.cmake and installing additional libraries i could pass the first bridge and the make files where generated.

This was only a short time of luck, because make fails directly with

Generating moc_cpp_helper_plugin.cpp
/srv/test/kate-cpp-helper-plugin-master/src/cpp_helper_plugin.h:63: Error: Undefined interface
automoc4: process for /srv/test/kate-cpp-helper-plugin-master/build/src/moc_cpp_helper_plugin.cpp failed: Unknown error
pid to wait for: 0
returning failed..
src/CMakeFiles/katecpphelperplugin_automoc.dir/build.make:49: recipe for target 'src/CMakeFiles/katecpphelperplugin_automoc' failed
make[2]: *** [src/CMakeFiles/katecpphelperplugin_automoc] Error 1
CMakeFiles/Makefile2:297: recipe for target 'src/CMakeFiles/katecpphelperplugin_automoc.dir/all' failed
make[1]: *** [src/CMakeFiles/katecpphelperplugin_automoc.dir/all] Error 2
Makefile:147: recipe for target 'all' failed
make: *** [all] Error 2


This software seems to be hopeless.
Now i understand why i could not find it in any distribution. - Sep 16 2015
This is a nice tool, but it can only be used when it is old enough that it can be integrated into a normal distribution. :-(

Problems with compilation are completely ignored by the author. - Sep 08 2015
-- Configuration type chosen: Release
-- Found Qt-Version 4.8.6 (using /usr/bin/qmake)
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Found KDE 4.12 include dir: /usr/include
-- Found KDE 4.12 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
CMake Error at /usr/share/cmake-3.0/Modules/FindPackageHandleStandardArgs.cmake:136 (message):
Could NOT find LibClang (missing: LIBCLANG_LIBRARY) (Required is at least
version "3.3")
Call Stack (most recent call first):
/usr/share/cmake-3.0/Modules/FindPackageHandleStandardArgs.cmake:343 (_FPHSA_FAILURE_MESSAGE)
cmake/modules/FindLibClang.cmake:98 (find_package_handle_standard_args)
CMakeLists.txt:84 (find_package)


but libclang is installed!

ii libclang-3.5-dev 1:3.5-10 amd64 clang library - Development package
ii libclang-common-3.5-dev 1:3.5-10 amd64 clang library - Common development package
ii libclang1:amd64 1:3.5-25 amd64 C, C++ and Objective-C compiler (LLVM based)
ii libclang1-3.5:amd64 1:3.5-10 amd64 C interface to the clang library


- Aug 25 2015
Is there any Debian package for this plugin.
You are always using the newest tools that doesn't fit the stable version.
I don't want to install a complete distribution to compile one plugin. ;-)

Example for Debian GNU/Linux 8.1 (jessie):
CMake Error at CMakeLists.txt:5 (cmake_minimum_required):
CMake 3.1.0 or higher is required. You are running version 3.0.2
- Aug 25 2015
ShowImage

Graphic Apps 58 comments

Score 66%
66 Likes
34 Dislikes
Dec 18 2016
I am really lucky that i found ShowImage after Kuickshow does not run anymore!

Everything is perfect and it's really fine that the shortcuts can be defined.

But i miss the possibility for a quick correction of gamma, brightness and contrast like in the Kuickshow.
It was very useful to press simply "g" or "G" when you want to get details visible in dark zones of a picture.

Would it be possible to add this feature in ShowImage? - Jul 13 2015
Muon Package Management Suite

System Software 21 comments

Score 83%
83 Likes
17 Dislikes
Apr 20 2011
Just follow the instructions from this HowTo:
http://bostonpeng.wordpress.com/2013/04/06/hotwo-muon-solydk/
- Aug 17 2013
I have the same question.
How can i build muon?
It seems not to be the usual make process.
Any hints would be very helpful. - Aug 17 2013
Kate CTags Plugin

Text Editors 16 comments

Score 80%
80 Likes
20 Dislikes
Feb 09 2007
It would be perfect to have a tree view with ctags in kate.

Is there no hope for such a solution? - Sep 13 2012
ShowImage

Graphic Apps

Score 66%
66 Likes
34 Dislikes
Jul 13 2015