Image 01
profile-image

simpl

Dh\'to Betoo , United States of America
Graphic Apps
Qosmic

Graphic Apps 27 comments

by simpl
Score 58.0%
Oct 24 2011
The linker can't find liblua. Try to find liblua.so on your system, and then add the directory it resides in to the LIBS variable in qosmic.pro like this:

LIBS += -L/full-path/to/liblua/

Then run the build.sh script again. - Mar 29 2008
Thanks, I've made the change. - Feb 18 2008
Thanks, I've added this to the README. - Feb 18 2008
It looks like the linker can't find the libflam3.a library. Can you check that qosmic/flam3/libflam3.a exists? - Nov 06 2007
If that doesn't do it, then try adding

LIBS += -L/path/to/dir_containing_libxml2.so/ -lxml2

to qosmic.pro, and then do what I suggested with the 'export' lines above. - Oct 23 2007
Try this

export LDFLAGS="-L/path/to/dir_containing_libxml2.so/"
export LIBS="-lxml2"
./build.sh clean ; ./build.sh - Oct 23 2007
Okay, I was almost totally wrong. I think you are missing a library that is needed to build libflam3. Check that you have libxml2 installed on your system. Then type './build clean ; ./build' in the qosmic directory. - Oct 23 2007
It looks like the expat library is not in the search path for the linker.
Look for a file named libexpat.so.1 or 'libexpat.so*' using locate or find.
Then add the following line to qosmic.pro toward the top:

LIBS += -L/path/to/directory/containing_libexpat/

where you use the path to libexpat you found above. Then run qmake, and then
run make. Hopefully that will do the trick. - Oct 23 2007
Thank you for posting. I hadn't even considered the qt-copy patches. I've updated the web page :) - Oct 14 2007
You're right, it's doesn't appear anywhere in the qt docs.

I've been using qt-4.3.1. I did a quick google with your error message, and there was something about these being part of an undocumented api used by designer. Maybe you could try updating qt if you haven't already. - Oct 05 2007
KrcStat

System Software
by binro

Score 58.0%
9   May 08 2011