MagIcons

Icon Themes

Source (required if based on other people's work): Add the source-code for this project on git.opendesktop.org

10
Score 75%
Description:

MagIcons is an application to manipulate whole iconsets. With MagIcons you are able to create color schemes for icons within seconds.

This is the first release. So please let me know if you are lucky or if you got into trouble while using MagIcons.

If you want to create an iconset, please read the wiki: http://www.magicons.bplaced.net/wordpress/

Here are some Icon Themes that you can manipulate by MagIcons:
Humanity-Colors (http://gnome-look.org/content/show.php/Humanity-Colors?content=117230)
Tok-tok (http://gnome-look.org/content/show.php/Tok-tok+%28MagIcons%29?content=120841)
Lila-Ubuntu (http://gnome-look.org/content/show.php/Lila-Ubuntu?content=118114)
Multicolor-Gnome (http://gnome-look.org/content/show.php/Multicolor-Gnome?content=124842)


Enjoy this release!
Last changelog:

8 years ago

** 0.1-0 (2010-02-20)
Release of the first public beta
** 0.1-1 (2010-02-24)
Solved: Minor bug with preview size
** 0.1-2 (2010-02-27)
Solved: Bug with handling symbolic links while installing new Iconsets
** 0.2-0 (2010-05-04)
Complete rewrite with many changes
** 0.2-1 (2010-05-13)
Added russian translation
** 0.3-0 (2010-05-20)
Solved: bug at updating and deleting iconsets
Solved: bug depending on cleaning the cache folder
Improved: svg color-substitution
Aquarell iconset: added more icons

... and dont forget to vote :-)

kennyr

4 years ago

The source link is indeed dead and dependency issues arise.

I'm on Fedora 20 and got this to work. I downloaded the .deb file and extracted the usr/ folder from it. With that, I repackaged it into an rpm with fpm (https://github.com/jordansissel/fpm).

However, when starting the MagIcons executable I got the "One or more dependencies are missing!" error.

It turns out that the Image library used in this Python program, PIL, has been forked under a new name: Pillow. The import statement required to use is slightly different.

This article helped me fix the source files: http://reinout.vanrees.org/weblog/2013/09/24/pil-pillow-image-import.html

I motified /usr/share/magicons/MagIcons so that "import Image" is now "from PIL import Image", I also had to modify MI_Functions.py, MI_Painter.py and MI_Iconcut.py, found in /usr/share/magicons/src/. The Image import statement there is now "from PIL import Image, ImageOps, ImageChops, ImageEnhance".

With these modifications I got MagIcons to work on my system. Hope this helps someone.

Report

Huku9H1F

4 years ago

Is the source link dead, or is it just me?

Report

DDZ

5 years ago

Hello!

Thank you for this tool! :)

I would like to install it in Manjaro (based on Arch) from MagIcons_Source_0-3-0.tar.gz but a dependency is missing without tell me which.
python-gtk2, python-imaging, python-gconf, gettext are installed, of course.

Any idea?
Thank you in advance for your answer and have a nice day. :)

Report

hhh

6 years ago

I'm confused... when coloring the Humanities icon set, you use to have settings for something like "extras" (for example, it would color the plus sign for the folder-new icon).

Were those settings removed?

Report

C

alexibaba

6 years ago

Hi hhh,
you're right. At my installed version (old) of "humanities" are these settings available.

But MagIcons is only the tool to configure those icons. The changeable colors are defined at the icons, in this case at humanities. You should ask Jennie from Humanities. Maybe this settings have been removed at the last update.

Good luck!

Report

hhh

6 years ago

Aha, that explains the "old" versions there. I renamed the versions I had in ~/.magicons, installed the others and now I have both versions.

Thanks so much for responding! Cheers. :^)

Report

stepnjump

6 years ago

I just installed these iconsets and now there seems to be no way to desinstall them... Why?

Report

C

alexibaba

6 years ago

Hi,
You can use your packet-manager (synaptic) to deinstall MagIcons :-)

Report

stepnjump

6 years ago

ah thank you!

Report

hhh

7 years ago

The solution to my triple post above was python-glade2 , it should be added to the list of dependencies.

Report

gservetas

8 years ago

Great work. Thank you

Report

virtalmix

8 years ago

Thanks a lot, this is great work!
I wish I could devellop apps in PyGTK as well but I've found it very hard to learn...
Anyway, Just let me know if you need a French Translator, I'd be happy to help.

Report

hhh

8 years ago

I had this working on Xfce, but I had to reinstall my OS and now I can't get it to work. When I run "MagIcons" in terminal it says One or more dependencies ar missing!, but gdebi show "All dendencies are satisfied". Any ideas?

Report

hhh

8 years ago

A triple post! How embarrassing... I must have hit the back/forward buttons and it was resending the message. Sorry!

Report

hhh

8 years ago

I had this working on Xfce, but I had to reinstall my OS and now I can't get it to work. When I run "MagIcons" in terminal it says One or more dependencies ar missing!, but gdebi show "All dendencies are satisfied". Any ideas?

Report

hhh

8 years ago

I had this working on Xfce, but I had to reinstall my OS and now I can't get it to work. When I run "MagIcons" in terminal it says "Missing one or more dependencies are missing!", but gdebi says "All dependencies are satisfied". Any ideas?

Report

Karmicbastler

8 years ago

please bring up some more Icons, which could be reworked by your little nice app.

Yes I use it in Ubuntu 10.10 Maverick Meerkat now. It wors so fine for me.

Thanks for this nice app.

Greetings
Karmicbastler

Report

jmichal

8 years ago

Hi,
I created similar and probably much better program icoGEN, look here:
http://gnome-look.org/content/show.php/icoGEN?content=124870

Report

Karmicbastler

8 years ago

hi Dear,
I love your App now andI wanted to ask, if there is a possibility for a ppa-repository to make updating of your app easier for me.
At the time, I have version 0.2.0 and I wanted to upate to your new version.

Please tell me, how I can get this managed. Normally, I use the update-manager of Lucid or even Terminal.

Greetings
Karmicbastler

Report

C

alexibaba

8 years ago

Hi Karmicbastler,

at present there is no repository for MagIcons. However on Ubuntu the update is quite simple:
Download the deb file and make a doubleclick on it. The packet installer "GDebi" will pop up and you can carry out an update. You don't need to remove the old version at first.
I have also thought about a repository but that is future.

Report

deflorator

8 years ago

Seems like a great idea. But it only works with one external iconset - Humanities, so it's not much use as yet.

Report

deflorator

8 years ago

OK, there are 4 sets that should work - I haven't read through the whole description :). Let's hope this will get developed.

Report

C

alexibaba

8 years ago

I hope so too!
In the near future every PNG iconset will be installable.

Report

Hoodoo

8 years ago

Great idea and great approach to building iconsets!

Any chances to make it work with Any Color You Like?

Report

C

alexibaba

8 years ago

Hi Hoodoo,

ACYL is not installable by MagIcons. But of course it would be possible to use it together with MagIcons (I tried it out by myself).
I have seen, that many people like MagIcons and there are some iconsets that will be suitable with MagIcons. I'm planning to ask the developers to build up a MagIcons variant of their work.

So I think you need to be patient.

Report

8 years ago

** 0.1-0 (2010-02-20)
Release of the first public beta
** 0.1-1 (2010-02-24)
Solved: Minor bug with preview size
** 0.1-2 (2010-02-27)
Solved: Bug with handling symbolic links while installing new Iconsets
** 0.2-0 (2010-05-04)
Complete rewrite with many changes
** 0.2-1 (2010-05-13)
Added russian translation
** 0.3-0 (2010-05-20)
Solved: bug at updating and deleting iconsets
Solved: bug depending on cleaning the cache folder
Improved: svg color-substitution
Aquarell iconset: added more icons

... and dont forget to vote :-)

File (click to download) Version Description Packagetype Architecture Downloads Date Filesize DL OCS-Install
Pling
Details
license
version
0.3-0
updated May 20 2010
added Feb 20 2010
downloads today
0
page views today 5